Bug Hunting Session
Bug 98686 - Some images in Impress disappear spontaneously (seems to be for images that are copies of an image on one slide.. ?)
Summary: Some images in Impress disappear spontaneously (seems to be for images that a...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.0.5.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 116456 116681 (view as bug list)
Depends on:
Blocks: Image-Caching
  Show dependency treegraph
 
Reported: 2016-03-15 15:33 UTC by mail
Modified: 2019-02-19 18:55 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
Presentation with corrupted icon on nearly all slides in the upper right corner. (332.88 KB, application/vnd.oasis.opendocument.presentation)
2016-03-15 15:33 UTC, mail
Details
Nearly identical slides to first attachment for this bug with intact graphics. (315.59 KB, application/vnd.oasis.opendocument.presentation)
2016-03-20 17:30 UTC, mail
Details
screen print of problem (93.82 KB, image/png)
2016-05-25 15:31 UTC, Cor Nouws
Details
Presentation with corrupted graphics on slide 17 (2.72 MB, application/vnd.oasis.opendocument.presentation)
2016-06-06 07:49 UTC, mail
Details
Example file (588.40 KB, image/png)
2018-02-26 17:08 UTC, Telesto
Details
Yet another presentation with corrupted images (icons top right corner) (1.37 MB, application/vnd.oasis.opendocument.presentation)
2018-06-22 11:58 UTC, mail
Details

Note You need to log in before you can comment on or make changes to this bug.
Description mail 2016-03-15 15:33:41 UTC
Created attachment 123604 [details]
Presentation with corrupted icon on nearly all slides in the upper right corner.

Quoting from bug 46447:

"Since several versions, and also in previously used openoffice versions, and at least for all 3.x versions I had, the presentation module Impress shows the following bug which completely ruins any given presentation. This bug occurs on a regular basis - usually once every presentation I generate:

For no specific reason, suddenly, images which have been embedded (not linked) into a presentation 'disappeare' with only a 'missing-link' placeholder displayed instead of the image in the editing mode of Impress.

Once this behavior occurs, the presentation is irreversibly damaged <...>."

I was plagued by this bug for what 7? 10? years - and I can't f***ing believe it's back again - just by lucky chance it only killed an hour of work this time.
 

At least an error message or a warning would be nice before saving unknowingly the corrupted file!!!
Comment 1 mail 2016-03-15 15:34:32 UTC
The slides are not confidential, do with it whatever you like.
Comment 2 Cor Nouws 2016-03-17 22:04:24 UTC
Hi Christian,

Sorry to read of this problem.
I'm not sure if it is the same as in report 46447.
On slide #4 there are also other images that do not disappear. So I think that it is a different problem maybe.
Could you please also post a good version of the file?

Is the image that disappeared the same as the one on slide #2?
(Why not work with a master page with that element? Not that that per see would solve the issue, I guess...)

Thanks - Cor
Comment 3 mail 2016-03-20 17:30:31 UTC
Created attachment 123746 [details]
Nearly identical slides to first attachment for this bug with intact graphics.
Comment 4 mail 2016-03-20 17:35:24 UTC
Hi Cor,

thanx for taking care of that bug! I'm not placing the image on the master slide because I'm using it as a visual cue for the last item on the slide, i.e. it appears at the same time as e.g. the last bullet point.

Yes, the images that disappear on subsequent slides are the same as the one on slide #2 (at least I think so ...) - it should be an SVG-File.

At least for me, the "old bug" caused only some images to disappear, not all. Hence, at least the effect is same-same :-/ ...

Best regards,

Christian
Comment 5 Cor Nouws 2016-03-25 16:21:39 UTC
Thanks for the info and the file, Christian.

Opening the file.. see if I can reproduce.
If you have any tips on circumstances, actions: those are more then welcome.
Cheers - Cor
Comment 6 Buovjaga 2016-03-27 15:50:23 UTC
(In reply to mail from comment #3)
> Created attachment 123746 [details]
> Nearly identical slides to first attachment for this bug with intact
> graphics.

I tested with this. Saved and reloaded a couple of times, but images stayed in place.

64-bit, KDE Plasma 5
Build ID: 5.1.1.3 Arch Linux build-2
CPU Threads: 8; OS Version: Linux 4.4; UI Render: default; 
Locale: fi-FI (fi_FI.UTF-8)
Comment 7 mail 2016-04-06 09:18:50 UTC
Strange. The only "special circumstances" I can think of are:

- This is a presentation with a long history, dating back to LO 3.x
- This is the first time I've used an SVG as an "icon" on all slides

I'm cautiously using SVG icons in LO 5.0.3 under Linux Mint where I cannot downgrade to LO 4. Here, I cannot reproduce the bug (I'm experiencing frequent crashes but that's a different story).
Comment 8 Buovjaga 2016-04-06 09:41:17 UTC
You can install several versions to test: https://wiki.documentfoundation.org/Installing_in_parallel
Comment 9 jose.velez 2016-04-07 07:24:05 UTC
I have a presentation in which occasionally the images disappear.

I have inspected the source file, and I have observed that the png file of the eclipsed image is corrupt.

I have used a hex inspector, and I have observed that the corresponding image file is corrupted. It is full of secuences like 00 FF 00 FF... or 33 66 99 CC FF.
Comment 10 Michael Meeks 2016-05-09 09:51:41 UTC
Oooh - that is interesting ! with the normal image loss bug - I would expect to have simply no image stream in the document.

You seem to have a much more interesting version of this. That is very curious. Any chance of a hex-dump of the first 128 bytes or so before and after ? also - the file-sizes ?

Sounds most interesting; thanks !
Comment 11 mail 2016-05-10 07:58:49 UTC
Do you need the original graphics (png and svg icons) or can you extract them from the intact presentation?
Comment 12 Pierre C 2016-05-19 19:15:58 UTC
Yes, same problem with LO 5.0.6.3

May images disappears on my last odp file. 

It was my first day working with LO 5.0.x branch

-> I Go Back to 4.4.6
Comment 13 Cor Nouws 2016-05-25 15:31:52 UTC
Created attachment 125283 [details]
screen print of problem

Encountered the same problem.
Image on page #2 that is a copy of the one on page 1 disappeared.
See the screen print. Note that at that time the image was still visible in the preview in the side pane.

(In reply to Michael Meeks from comment #10)
> Any chance of a hex-dump of the first 128 bytes or so before and
> after ? also - the file-sizes ?

Looking at this
  http://linuxcommand.org/man_pages/xxd1.html
I guess I should use the -len option ?

Also; I do have the file with problem and after repair. Not sure if that may help?
Comment 14 Cor Nouws 2016-05-25 15:32:56 UTC
I encountered the problem in a recent 5.2 master
Comment 15 mail 2016-06-06 07:49:37 UTC
Created attachment 125506 [details]
Presentation with corrupted graphics on slide 17

Another example for a corrupted graphics.
Comment 16 Telesto 2016-12-17 19:19:01 UTC
Still a repro with:
Version: 5.4.0.0.alpha0+
Build ID: 1427817a944f3cf1020b2f06a2ca934847b56ba8
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2016-12-17_10:04:15
Locale: nl-NL (nl_NL); Calc: CL

Steps to Reproduce (maybe some are redundant)
1. Open attachment 123746 [details] in Impress
2. Set Save AutoRecovery information to 1 or 2 minutes (Tools -> Options - Load/save )
3. Open all the slides by scrolling down (Side Pane) 
4. Make a change to a sheets (for example moving an image a bit)
5. Minimize Impress 
6. Wait for the next autosave
7. Restore the Impress Window

Icon in the upper right corner should be gone (mostly)
Comment 17 Michael Meeks 2016-12-19 10:11:29 UTC Comment hidden (obsolete)
Comment 18 Michael Meeks 2016-12-19 11:42:59 UTC
Great to have this reproducible ! thanks for the great work there ... we should really mark this to the tracker for all these sillies ...
Comment 19 QA Administrators 2017-12-21 03:36:54 UTC Comment hidden (obsolete)
Comment 20 Telesto 2018-01-02 11:00:22 UTC
Still reproducible
Version: 6.1.0.0.alpha0+
Build ID: a9b202a6b7000e7af34f2a639ca207122a3968bf
CPU threads: 4; OS: Windows 6.3; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-12-26_23:10:23
Locale: nl-NL (nl_NL); Calc: CL
Comment 21 Telesto 2018-02-26 17:08:24 UTC
Created attachment 140160 [details]
Example file

I'm reproducing the same issue the image attached (created with the Microsoft Snipping Tool)

1. Launch Impress with a fresh empty presentation
2. Set the auto-save to 1 minute (Tools -> Preferences)
3. Add the image using drag & drop or Insert Image
4. Minimize the screen 
5. Restore the screen after two or three minutes 

No repro with Writer
Comment 22 Mike 2018-02-28 21:34:00 UTC
I have a problem with missing images on some Ubuntu 16.04 computers, but not others. I found that replacing the .config/libreoffice/user folder on the computer with the problem with the folder from the computer that doesn't have the problem fixed the problem.
Comment 23 Buovjaga 2018-03-01 08:32:32 UTC
(In reply to Mike from comment #22)
> I have a problem with missing images on some Ubuntu 16.04 computers, but not
> others. I found that replacing the .config/libreoffice/user folder on the
> computer with the problem with the folder from the computer that doesn't
> have the problem fixed the problem.

Others will be able to test this with Safe Mode: Help - Restart in safe mode and then Continue in safe mode.
Comment 24 Buovjaga 2018-03-18 14:18:45 UTC
*** Bug 116456 has been marked as a duplicate of this bug. ***
Comment 25 Buovjaga 2018-03-29 19:28:39 UTC
*** Bug 116681 has been marked as a duplicate of this bug. ***
Comment 26 baifcc 2018-06-21 07:53:28 UTC
Would you mind to try UN-check Use OpenGL for all rendering and restart Libre if the problem is gone?
Comment 27 Buovjaga 2018-06-21 08:06:30 UTC
(In reply to baifcc from comment #26)
> Would you mind to try UN-check Use OpenGL for all rendering and restart
> Libre if the problem is gone?

I would rather hope this change solves the problem: https://blog.documentfoundation.org/blog/2018/06/19/image-handling-rework-for-libreoffice-collaboras-tender-results/

Also see the latest comments in the meta: https://bugs.documentfoundation.org/show_bug.cgi?id=47148#c39
Comment 28 mail 2018-06-22 11:58:54 UTC
Created attachment 143032 [details]
Yet another presentation with corrupted images (icons top right corner)

Win 7 64b, LO 6.0.4.2
Comment 29 mail 2018-10-07 18:25:32 UTC Comment hidden (obsolete)
Comment 30 Pierre C 2018-10-07 19:20:50 UTC Comment hidden (no-value)
Comment 31 mail 2018-10-08 07:14:28 UTC Comment hidden (no-value)
Comment 32 Edwar Saliba Júnior 2018-11-23 12:37:15 UTC
I'm using 6.0.6.2 release version and have the same problem. Some images desapear espontaneously in presentation after file to be closed. I'm not sure, but I think it happens only with images that I modified original size after placed its in the slide. I'm using GNU\Linux (Debian 9.5)
Comment 33 Cor Nouws 2019-02-19 18:12:48 UTC
dear all,

Little change in summary.

Thanks for report on images and user profile - must be a different topic.

@telestro: what do you think, does the summary make sense for you?
Comment 34 Cor Nouws 2019-02-19 18:14:48 UTC
(In reply to mail from comment #28)
> Created attachment 143032 [details]
> Yet another presentation with corrupted images (icons top right corner)
> 
> Win 7 64b, LO 6.0.4.2
Not that the behavior is acceptable as such, but what happens if you make the image in the top right corner of the slide a part of the master slide?
Comment 35 Telesto 2019-02-19 18:51:32 UTC
I can't reproduce it
Version: 6.3.0.0.alpha0+
Build ID: aa51774e6a309f277e71ca3a3b9d5d5b4b3dbf1a
CPU threads: 4; OS: Windows 6.3; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2019-02-18_06:06:03
Locale: nl-NL (nl_NL); UI-Language: en-US
Calc: CL

Reports are all from 6.0 and prior. The issue is resolved, IMHO https://blog.documentfoundation.org/blog/2018/06/19/image-handling-rework-for-libreoffice-collaboras-tender-results/

I would propose works for me.. It should work fine except for corner cases (bug 123541)
Comment 36 Buovjaga 2019-02-19 18:55:14 UTC
That is a relief. Let's close and celebrate.