Download it now!
Bug 98730 - UI: bring back the old File Save "action button" as an alternative to the new "split button"
Summary: UI: bring back the old File Save "action button" as an alternative to the new...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.1.0.3 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: accessibility
Depends on:
Blocks: Save
  Show dependency treegraph
 
Reported: 2016-03-17 18:30 UTC by Ernest Bywater
Modified: 2017-05-18 22:23 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot of my screen in edit mode showing LO (2.54 MB, image/jpeg)
2016-03-18 07:10 UTC, Ernest Bywater
Details
LO screenshot after saving changes (1.67 MB, image/jpeg)
2016-03-18 07:35 UTC, Ernest Bywater
Details
screenshot with list showing, as requested (1.67 MB, image/jpeg)
2016-03-18 07:44 UTC, Ernest Bywater
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ernest Bywater 2016-03-17 18:30:14 UTC
The File Save icon on the toolbar has changed from being a simple action icon to being one with a drop-down list as well. I first noticed this on 5.1.0.3 on Windows. In the past there was an icon that was just File Save, to save over the current file. Can we have that capability added back as an optional icon I can Add to the toolbar. The current icon is a major hassle because I have to either lose work space on the desktop by having very large icons or have the drop-down list pop up due to be accidentally activated when saving the file.
Comment 1 tommy27 2016-03-17 21:31:53 UTC
I think you can record a macro with just the save action and then create a button pointing to that macro to use instead of the new save button with dropdown menu
Comment 2 Ernest Bywater 2016-03-17 23:20:23 UTC
(In reply to tommy27 from comment #1)
> I think you can record a macro with just the save action and then create a
> button pointing to that macro to use instead of the new save button with
> dropdown menu

I probably could. However, apart from me having to learn how to do it, you can be sure more people have the same issue but haven't said anything, and it WAS a capability that was there before, so it should be hard to put back in.
Comment 3 Samuel Mehrbrodt (CIB) 2016-03-18 06:10:36 UTC
(In reply to Ernest Bywater from comment #0)
> The current icon is a major hassle
> because I have to either lose work space on the desktop by having very large
> icons or have the drop-down list pop up due to be accidentally activated
> when saving the file.

I don't get this. Why can't you use small icons with this new widget? Or why is the dropdown accidentally activated?
Comment 4 tommy27 2016-03-18 06:12:11 UTC
I preferred the old save icon too.
but there are probably some reasons that moved the developers to modify it and bring the new one.

however I think that nothing prevents us for asking to have both, so that users could choose the saving icon they prefer.

maybe an extension could be created to do that and simulate the old one.
let's file this as an enhancement request, so I change the summary lines.

@UX-team
the new file save icon proved to be a little controversial, since there are many reports of user complaining about it.

my idea as I wrote in previous line is to bring back the "old save icon action box" and keep the "new save icon dropbown button" in order to let the user choose which one it prefers.

I suppose that it should not be too difficult to restore the code about the old button without replacing the new one.

we could have two "save icons" with slightly different functions but that would please everyone
Comment 5 tommy27 2016-03-18 06:17:52 UTC
(In reply to Samuel Mehrbrodt (CIB) from comment #3)
> (In reply to Ernest Bywater from comment #0)
> > The current icon is a major hassle
> > because I have to either lose work space on the desktop by having very large
> > icons or have the drop-down list pop up due to be accidentally activated
> > when saving the file.
> 
> I don't get this. Why can't you use small icons with this new widget? Or why
> is the dropdown accidentally activated?

@Ernest
click on "Tools/Options/View/Icon size" and choose "small"

@Samuel
the new save icons takes more space than the old one since there's the dropdown triangle next to it... it takes the space of 1 and 1/2 normal button.

so I suppose that those extra pixels may cause annoyance in netbooks with small screen and moreover it may happen that the user clicks on the triangle instead of the icon.

having said that, I think that the best thing would be to have both "save button" methods in LibO. user could easily customize their toolbars with the one they prefer to use.
Comment 6 Ernest Bywater 2016-03-18 06:37:01 UTC
(In reply to Samuel Mehrbrodt (CIB) from comment #3)
> (In reply to Ernest Bywater from comment #0)
> > The current icon is a major hassle
> > because I have to either lose work space on the desktop by having very large
> > icons or have the drop-down list pop up due to be accidentally activated
> > when saving the file.
> 
> I don't get this. Why can't you use small icons with this new widget? Or why
> is the dropdown accidentally activated?

I have a high resolution monitor and I use fairly small icons to be able to get the most actual working space on the screen. For every other icon it's not a problem. For the new 'File Save' icon on the toolbar the drop-down arrow takes up one third of the width of the icon, and the icon is not quite double the size of the cursor. When in the middle of working on a text document I frequently dart the cursor up to click on the save, click, and back down to work. However, if the cursor is even just half a pixel over the drop-down list the list is activated instead of the save action. The list drops and I have to go back to the icon and click on the body of the icon twice to get the wanted action done. The time taken to do it is significantly longer than it used to be.
Comment 7 Samuel Mehrbrodt (CIB) 2016-03-18 06:45:08 UTC
(In reply to Ernest Bywater from comment #6)
> I have a high resolution monitor and I use fairly small icons to be able to
> get the most actual working space on the screen. For every other icon it's
> not a problem. For the new 'File Save' icon on the toolbar the drop-down
> arrow takes up one third of the width of the icon, and the icon is not quite
> double the size of the cursor. When in the middle of working on a text
> document I frequently dart the cursor up to click on the save, click, and
> back down to work. However, if the cursor is even just half a pixel over the
> drop-down list the list is activated instead of the save action. The list
> drops and I have to go back to the icon and click on the body of the icon
> twice to get the wanted action done. The time taken to do it is
> significantly longer than it used to be.

Ok, understood.
Are you on Windows? Can you post a screenshot of your LO Window please?
At least on Linux the icons are not smaller when they have the dropdown (it's placed next to the icon). Maybe we need to add some spacing in Windows between the icon and the dropdown.
Comment 8 Samuel Mehrbrodt (CIB) 2016-03-18 06:51:32 UTC
(Btw, why don't you use the shortcut Ctrl-S to save the document?)
Comment 9 Ernest Bywater 2016-03-18 07:10:13 UTC
Created attachment 123682 [details]
screenshot of my screen in edit mode showing LO

The screenshot shows me in my usual edit mode with two files open, one is the master file and the other is the copy back from an editor.
Comment 10 Ernest Bywater 2016-03-18 07:11:28 UTC
(In reply to Samuel Mehrbrodt (CIB) from comment #7)
> (In reply to Ernest Bywater from comment #6)
> > I have a high resolution monitor and I use fairly small icons to be able to
> > get the most actual working space on the screen. For every other icon it's
> > not a problem. For the new 'File Save' icon on the toolbar the drop-down
> > arrow takes up one third of the width of the icon, and the icon is not quite
> > double the size of the cursor. When in the middle of working on a text
> > document I frequently dart the cursor up to click on the save, click, and
> > back down to work. However, if the cursor is even just half a pixel over the
> > drop-down list the list is activated instead of the save action. The list
> > drops and I have to go back to the icon and click on the body of the icon
> > twice to get the wanted action done. The time taken to do it is
> > significantly longer than it used to be.
> 
> Ok, understood.
> Are you on Windows? Can you post a screenshot of your LO Window please?
> At least on Linux the icons are not smaller when they have the dropdown
> (it's placed next to the icon). Maybe we need to add some spacing in Windows
> between the icon and the dropdown.

Multiple answers to posts

1.- I currently use the small icon option. The problem is an accidental click on or near the arrow activates it and then I've got to take more actions to close it and do what I want. With the old icon if I missed the icon itself nothing happened and I just moved a little and click to action the save.

I'm an independent author and I write a lot of stories, to have enough room on the screen to have both pages of the book open side by side I use small icons. Generally this isn't an issue with the toolbar. But it is with this icon because it's a change in function and I can no longer do a quick up and save action, I have to divert my full attention to watch the cursor and ensure I don't hit the wrong part of the icon by accident.

I use a desktop with a large monitor on a very high resolution setting to view the text well. To save space I also have a personalised 'Standard' toolbar which is smaller than the usual one, despite having many of the 'Format' toolbar icons on it - the ones I don't use are deactivated.

2. Screenshot attached, for some reason the cursor doesn't show on it. But the cursor can just fit in the File Save icon - that's how close in size they are.

2.a. I'm using Windows 7 Pro. Recently had to switch from Zorin Linux due to new hardware and can't find a release version of Linux that uses the 43 or 44 kernel.

3. I have a physical ability issue and find it a lot easier to use the mouse with my right hand and just type with my left hand. Thus using the mouse to click the icon is a lot easier for me than trying to get Ctrl-S with my left hand by itself. I use a modified touch typing process, not the usual one.
Comment 11 Heiko Tietze 2016-03-18 07:22:55 UTC
The icon has changed to reflect the document status about unsaved changes which was disabled or not before. As Samuel asked it would be helpful to get a screenshot how it looks on a high res display.
You may be aware of the customization options. Right click the toolbar, go to "visible buttons" and disable Save to remove this one. However there is no legacy Save button.

BTW: This toolbar button with multiple entries is called a split-button because it has a default action along with a menu of options. There are also menu-buttons that do not have a default action but open just the menu (e.g. insert table).
Comment 12 Ernest Bywater 2016-03-18 07:35:24 UTC
Created attachment 123683 [details]
LO screenshot after saving changes

The original was when I was about to save a change, and this is after saving a file
Comment 13 Ernest Bywater 2016-03-18 07:37:34 UTC
(In reply to Heiko Tietze from comment #11)
> The icon has changed to reflect the document status about unsaved changes
> which was disabled or not before. As Samuel asked it would be helpful to get
> a screenshot how it looks on a high res display.
> You may be aware of the customization options. Right click the toolbar, go
> to "visible buttons" and disable Save to remove this one. However there is
> no legacy Save button.
> 
> BTW: This toolbar button with multiple entries is called a split-button
> because it has a default action along with a menu of options. There are also
> menu-buttons that do not have a default action but open just the menu (e.g.
> insert table).

I know how to customise the toolbar, and have heavily customised the one in the screenshot. I've saved a screenshot before I saved the file, a second having saved the file. And I now go and save one with the drop-down list open and showing. I only just thought of that, because I don't use the list at all.
Comment 14 tommy27 2016-03-18 07:39:10 UTC
as pointed out before, I'm not against the new "split button" and I'm sure many users like it, but consider that a lot of other users are more confortable with the old one.

so, bottomline is: why can't we have both?

our UI already has some buttons about the same functionality but with little variants...  i.e. the "directly export to PDF" and the "export to PDF" button

so, having the old save button with the "greyed out" effect would be a nice addition to the UI.

I always think that is better to offer an alternative rather than replacing an already existing and working function

this reminds me when Windows changed the "show desktop" taskbar icon from the left side to the right side... why they did not let the user choose where to place it? (now you can workaround this in many ways but it's annoying)
Comment 15 Ernest Bywater 2016-03-18 07:44:31 UTC
Created attachment 123684 [details]
screenshot with list showing, as requested

screenshot with the drop-down list showing.

Monitor is a 28 inch unit set to 3840 x 2160 pixels resolution.
Comment 16 Ernest Bywater 2016-03-18 07:51:19 UTC
(In reply to tommy27 from comment #14)
> as pointed out before, I'm not against the new "split button" and I'm sure
> many users like it, but consider that a lot of other users are more
> confortable with the old one.
> 
> so, bottomline is: why can't we have both?
> 
> our UI already has some buttons about the same functionality but with little
> variants...  i.e. the "directly export to PDF" and the "export to PDF" button
> 
> so, having the old save button with the "greyed out" effect would be a nice
> addition to the UI.
> 
> I always think that is better to offer an alternative rather than replacing
> an already existing and working function
> 
> this reminds me when Windows changed the "show desktop" taskbar icon from
> the left side to the right side... why they did not let the user choose
> where to place it? (now you can workaround this in many ways but it's
> annoying)

I agree. I've nothing against the 'split button' (thanks for telling me what it's called) but wish for, and asked for, the old icon to be available as an option in the Customise Toolbars section so I can select it and use it instead - the way I have with the rest of the toolbar.
Comment 17 Buovjaga 2016-03-18 08:22:41 UTC
Ernest: would it be enough, if the split button also had a split highlighting, when you move your mouse over it? Meaning that it would only highlight the dropdown part, if you are over its hit area and likewise for the direct Save area.
Comment 18 tommy27 2016-03-18 08:27:33 UTC
I think it wouldn't resolve two issues:
- icon space (he doesn't need the split button functions and me too)
- accidental fast clicking 

IMHO the easiest way to solve problem is not to modify the split button, but to bring back the old button that worked fine.

they can both exist an alternative to each one.

the error was not to create the "split button" but to remove the "action button"

P.S. is "action button" a proper term to describe the old behaviour which gave a visual hint about the state of the document (greyed in or greyed out)
Comment 19 Ernest Bywater 2016-03-18 08:33:42 UTC
(In reply to Buovjaga from comment #17)
> Ernest: would it be enough, if the split button also had a split
> highlighting, when you move your mouse over it? Meaning that it would only
> highlight the dropdown part, if you are over its hit area and likewise for
> the direct Save area.

Not really, because it will still require me to transfer my attention the icon. In the past I could use the cursor to move up and save while most of my attention was still on the page. I didn't need to look up, just catch the movement in the corner of my eye, because I set the 'Save File' icon as the one on the far right. If I missed nothing happened, and I'd move the cursor and click again. It got so automatic I rarely missed. But now, I have to give it my full attention to make sure I get it right. I don't want the split option at all. Which is why I asked about making the old code and icon available as an optional one, that way I can set it up to use whichever I want. I figured it would be easy to just put the existing code back in.

The number of times I accidentally get the split function is now so often I'm seriously considering removing the 'File Save' icon and use the Menu options to save in future. The split button is annoying the hell out of me. I don't want to go to the large icons to make it work and lose the work area.
Comment 20 Ernest Bywater 2016-03-18 08:34:59 UTC
(In reply to tommy27 from comment #18)
> I think it wouldn't resolve two issues:
> - icon space (he doesn't need the split button functions and me too)
> - accidental fast clicking 
> 
> IMHO the easiest way to solve problem is not to modify the split button, but
> to bring back the old button that worked fine.
> 
> they can both exist an alternative to each one.
> 
> the error was not to create the "split button" but to remove the "action
> button"
> 
> P.S. is "action button" a proper term to describe the old behaviour which
> gave a visual hint about the state of the document (greyed in or greyed out)

This is what i asked for, and should be the easiest to do - add back the old code while leaving the new in place. It may require a name change for one to have both there, but that should be minor and easy to do.
Comment 21 tommy27 2016-03-18 10:05:58 UTC
@Samuel
could be this an "easy hack" for you?
Comment 22 Yousuf Philips (jay) (retired) 2016-03-18 10:58:38 UTC
(In reply to tommy27 from comment #4)
> the new file save icon proved to be a little controversial, since there are
> many reports of user complaining about it.

Can you point to any other bug reports that are complaining about this issue? I know joel mentioned this issue a few weeks back in irc.

I had suggested that the original save uno command be kept as is and a new save split command be created for use in the toolbar, but this suggestion was ignored.

https://gerrit.libreoffice.org/#/c/20079/
Comment 23 Heiko Tietze 2016-03-18 13:32:40 UTC
Close this bug report as WONTFIX since neither the fucntionality nor the icon is questionable. The UI lacks of a customization feature and the design team decided to add this as a new feature request.
Comment 24 Ernest Bywater 2016-03-18 15:43:00 UTC
(In reply to Heiko Tietze from comment #23)
> Close this bug report as WONTFIX since neither the fucntionality nor the
> icon is questionable. The UI lacks of a customization feature and the design
> team decided to add this as a new feature request.

Oh great. This isn't a new feature wanted, just the provision of a previous functionality made more difficulty by the introduction of the new feature of the 'split button.' The original functionality of the old 'File Save As' button was left in place while the easier to use 'File Save' button was removed.

Well, if they won't return the previous one click 'File Save' button, please do not mess if with the old 'File Save as' button, because today I found it was safer to go through the wasting of time of to use the extra step and click of the old 'File Save as' button to put up with the problems created by using the 'File Save' split-button which is a decrease in ease of use functionality.
Comment 25 Heiko Tietze 2016-03-18 16:48:42 UTC
In tdf#98745 the old behavior is requested for customization purpose, just as you suggested.
Comment 26 V Stuart Foote 2016-03-18 17:11:52 UTC
The implementation of the stateful Split button for the Standard toolbar is a Design feature and functions as intended. The single action Save button was eliminated by design and split button functions as intended.

The .uno:Save command remains linked to the <Ctrl>+S global shortcut, as well is linked to the File menu with simple accelerator entry <Alt>, F, S--three individual key press sequence.

Wearing my a11y hat here, for users with AT needs or a one hand input preference, should the <Ctrl>+S keybaord shortcut, or the localized accelerator sequence be an impediment--they can easily add an additional Keyboard shortcut customization for the Save command  that is more comfortable for use. Including even the assignment/reassignment of a function key.  Already provided for and this request becomes a usage issue.

Agree with the Resolved -> Wontfix here

And, IMHO there is very weak justification of need for toolbar button customization requiring we implement an additional .uno command to support a single action button widget for the Save command -- but, that is related enhancement bug 98745
Comment 27 Ernest Bywater 2016-03-18 17:34:53 UTC
(In reply to Heiko Tietze from comment #25)
> In tdf#98745 the old behavior is requested for customization purpose, just
> as you suggested.

Thanks for that. I do hope something comes from it, because the old single action button was more functional for a quick save than the new button is. I can see how some people would like the new button on small screen devices, but they aren't the only things people use.
Comment 28 V Stuart Foote 2016-03-19 15:31:13 UTC
Should have thought to check, but Jay pointed out on bug 98745 that while implementing the Split button, an Expert Configuration setting was provided to regain the single action button linked to the .uno:Save action.

Tools -> Options -> Advanced "Expert Configuration" session and searching for "SaveToolbarController"

then edit the "controller" string replacing

"com.sun.star.comp.framework.SaveToolbarController"

with

"com.sun.star.comp.framework.GenericPopupToolbarController"

on LibreOffice restart, restores the non-split button behavior to the Toolbar "Save" button.

Reverse steps to restore the Split button.

Not as convenient as having it available as a checkbox in the customization GUI, but should satisfy those with problems with the Split button and needing the single action button for any reason.
Comment 29 Ernest Bywater 2016-03-19 16:49:18 UTC
(In reply to V Stuart Foote from comment #28)
> Should have thought to check, but Jay pointed out on bug 98745 that while
> implementing the Split button, an Expert Configuration setting was provided
> to regain the single action button linked to the .uno:Save action.
> 
> Tools -> Options -> Advanced "Expert Configuration" session and searching
> for "SaveToolbarController"
> 
> then edit the "controller" string replacing
> 
> "com.sun.star.comp.framework.SaveToolbarController"
> 
> with
> 
> "com.sun.star.comp.framework.GenericPopupToolbarController"
> 
> on LibreOffice restart, restores the non-split button behavior to the
> Toolbar "Save" button.
> 
> Reverse steps to restore the Split button.
> 
> Not as convenient as having it available as a checkbox in the customization
> GUI, but should satisfy those with problems with the Split button and
> needing the single action button for any reason.

Thank you, and thanks Jay,

I've implemented that option and am now fully operational, as long as it doesn't get replaced in a future upgrade and I remember to make the same change on any future installation on other system.

However, this only helps people who are tech savvy enough to come here and look for an answer and also happy to work in that part of the system.
Comment 30 Adolfo Jayme 2016-03-19 22:23:04 UTC
The FIXED resolution is not appropriate in this case.
Comment 31 tommy27 2016-03-20 02:43:12 UTC
even INVALID is not a correct status.

since an expert configuration setting exists to obtain what was originally asked, the correct status is WORKSFORME
Comment 32 Ernest Bywater 2016-03-20 03:24:02 UTC
(In reply to tommy27 from comment #31)
> even INVALID is not a correct status.
> 
> since an expert configuration setting exists to obtain what was originally
> asked, the correct status is WORKSFORME

I don't know enough to have a comment on what is the right setting. I will say the expert configuration does return the basic functionality and I'm using it. However, the icon doesn't change colour or alert in anyway to indicate you should be saving the file, the way the old one did. Nor does it change colour to indicate the file is saved, the way the old one did. But I can live with that. On the other hand, how many users will know enough to find this configuration change and set it - I doubt many will. I'm very tech savvy, if out of date, but needed the step by step instructions to do it.
Comment 33 tommy27 2016-03-20 03:31:21 UTC
it's probably better to open a new bug report about the "old" button non changing color. I can confirm in 5.1.1.3 it's has no greyed out effect like it did in 5.0.x
Comment 34 tommy27 2016-03-20 07:17:06 UTC
(In reply to Ernest Bywater from comment #32)
> ......
> However, the icon doesn't change colour or alert in anyway to
> indicate you should be saving the file, the way the old one did. Nor does it
> change colour to indicate the file is saved, the way the old one did. But I
> can live with that. 

opened a new report at Bug 98779. let's continue discussion over there.


> On the other hand, how many users will know enough to
> find this configuration change and set it - I doubt many will. I'm very tech
> savvy, if out of date, but needed the step by step instructions to do it.

I think we should add that expert configuration tweak instruction in the 5.1.x release notes. https://wiki.documentfoundation.org/ReleaseNotes/5.1

I gave a fast look at them and oddly I realized that the new "split button" wasn't even mentioned... 

kinda strange, isn't it? such a major UI change probably deserves to be described in detail there