Bug 98753 - Find Toolbar does not display "Search key not found"
Summary: Find Toolbar does not display "Search key not found"
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.1.0.3 release
Hardware: All All
: medium major
Assignee: Samuel Mehrbrodt (CIB)
URL:
Whiteboard: target:5.2.0 target:5.1.4
Keywords: bibisected, bisected, regression
: 100263 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-03-18 17:35 UTC by Dan K
Modified: 2016-10-25 19:02 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dan K 2016-03-18 17:35:52 UTC
Find Toolbar will not display the "search key not found" in the placeholder for message.
Comment 1 Dan K 2016-03-18 18:59:34 UTC
Works correctly in LO 5.0.2.2
Comment 2 Dan K 2016-03-18 19:30:24 UTC
Also has the problem in LO 5.1.1.3
Comment 3 Julien Nabet 2016-03-18 21:57:19 UTC
On pc Debian x86-64 with master sources updated today, I could reproduce this.
Comment 4 raal 2016-03-21 06:01:49 UTC
This seems to have begun at the below commit.
Adding Cc: to Samuel Mehrbrodt; Could you possibly take a look at this one? Thanks

250315e534eb4d7621f425ad50aa3691c48db23e is the first bad commit
commit 250315e534eb4d7621f425ad50aa3691c48db23e
Author: Norbert Thiebaud <nthiebaud@gmail.com>
Date:   Wed Nov 18 05:09:38 2015 -0800

    source sha:27bdc70d83d4a4f1ebb89429f61b39084e739aaa

    source sha:27bdc70d83d4a4f1ebb89429f61b39084e739aaa

:040000 040000 ca348118a9e1f097165c245ef3b3523a3e1ce140 772170592389657d98e6e2206800808f9645ca1c M      instdir

author	Samuel Mehrbrodt <Samuel.Mehrbrodt@cib.de>	2015-11-18 12:28:46 (GMT)
committer	Samuel Mehrbrodt <Samuel.Mehrbrodt@cib.de>	2015-11-18 13:07:27 (GMT)
commit	27bdc70d83d4a4f1ebb89429f61b39084e739aaa (patch)
tree	be8f3142cfa115582e6a6ca17e6c0d1d1ec2ed3c
parent	8327a5e162a4d1804286bfdfb4d621b8d2a1d504 (diff)
Toolbar: Refactor insert toolitem code
Comment 5 Cor Nouws 2016-05-20 15:05:16 UTC
@samuel: could you have a look please?
Comment 6 Samuel Mehrbrodt (CIB) 2016-05-23 13:11:28 UTC
(In reply to Cor Nouws from comment #5)
> @samuel: could you have a look please?

Will do.
Comment 7 Commit Notification 2016-05-25 07:53:03 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=3349594bffc1eda4ee1d258be207b40f2f6f9b12

tdf#98753 Find Toolbar does not display "Search key not found"

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Samuel Mehrbrodt (CIB) 2016-05-25 08:06:38 UTC
Thanks a lot for bisecting this!
I just reverted it for now as I don't have the time to investigate here.
Backport to 5-1 is pending.
Comment 9 Commit Notification 2016-05-25 15:38:11 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "libreoffice-5-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=80d01c991d8c9a4f4cf6dfd4370238edbfd870f6&h=libreoffice-5-1

tdf#98753 Find Toolbar does not display "Search key not found"

It will be available in 5.1.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 David H. Gutteridge 2016-05-26 04:54:31 UTC
Adding myself to the CC list. (I tested this myself before I discovered this had already been reported.) This issue can be kind of annoying when searching large documents, so it's good to know it's fixed, thanks.
Comment 11 David H. Gutteridge 2016-06-02 21:29:29 UTC
Confirming this is fixed in 5.1.4 RC 1.
Comment 12 sworddragon2 2016-06-09 19:07:34 UTC
*** Bug 100263 has been marked as a duplicate of this bug. ***