Bug 98815 - {tab} character in cells is not saved
Summary: {tab} character in cells is not saved
Status: RESOLVED DUPLICATE of bug 103829
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2 all versions
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, regression
Depends on:
Blocks: Calc-Cells
  Show dependency treegraph
 
Reported: 2016-03-22 04:25 UTC by tomimatsu
Modified: 2017-06-12 21:47 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description tomimatsu 2016-03-22 04:25:14 UTC
User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:45.0) Gecko/20100101 Firefox/45.0
Build Identifier: LibreOffice 4.4.7.2

{tab} character is effective in cells when editing.
however,
{tab} character in cells is not saved.

Reproducible: Always

Steps to Reproduce:
in Writer
1.Type aaa + {tab} + BBB
2.Copy above, then Paste to Cell of Calc.
3.{tab} character is effective in cells
4.Save Calc file.
Actual Results:  
After open saved file, {tab} is lost.
aaa + BBB

Expected Results:  
aaa + {tab} + BBB

[Information automatically included from LibreOffice]
Locale: en-US
Module: SpreadsheetDocument
[Information guessed from browser]
OS: Windows (All)
OS is 64bit: no


Reset User Profile?No
Comment 1 raal 2016-03-22 13:16:07 UTC
Hello, after press Enter {tab} disappear. Version: 5.2.0.0.alpha0+, win7

3.{tab} character is effective in cells
3.5   press enter - {tab} disappear
Comment 2 Buovjaga 2016-04-03 11:59:34 UTC
(In reply to raal from comment #1)
> Hello, after press Enter {tab} disappear. Version: 5.2.0.0.alpha0+, win7
> 
> 3.{tab} character is effective in cells
> 3.5   press enter - {tab} disappear

Yep I see the same in 5.2. (Hitting enter, if clicked in the formula input line first. Otherwise not needed). It changes to a space.

However, in 5.1.1, if I click in the formula input line and paste, the TAB remains even after pressing enter. It disappears completely after save & reload. It is not replaced by a space.

Perhaps the change in 5.2 is intentional.

Arch Linux 64-bit, KDE Plasma 5
Version: 5.2.0.0.alpha0+
Build ID: 9b0069c2833313ba9fab91f45edd354ba334f94b
CPU Threads: 8; OS Version: Linux 4.4; UI Render: default; 
Locale: fi-FI (fi_FI.UTF-8)
Built on April 3rd 2016

64-bit, KDE Plasma 5
Build ID: 5.1.1.3 Arch Linux build-2
CPU Threads: 8; OS Version: Linux 4.4; UI Render: default; 
Locale: fi-FI (fi_FI.UTF-8)
Comment 3 tommy27 2016-10-19 20:53:47 UTC
another reported (and probably related issue) regarding the "tab" character is here at Bug 103308
Comment 4 Carlos 2017-04-03 20:05:53 UTC
This is similar to bug 
https://bugs.documentfoundation.org/show_bug.cgi?id=106350
Comment 5 Carlos 2017-04-03 20:07:56 UTC
I can confirm that the bug is present in
Version: 5.3.1.2 (x64)
Build ID: e80a0e0fd1875e1696614d24c32df0f95f03deb2
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; Layout Engine: new; 
Locale: en-US (en_US); Calc: group

The bug is not present in Google spreadsheets.
Comment 6 Buovjaga 2017-04-04 04:21:18 UTC
*** Bug 106350 has been marked as a duplicate of this bug. ***
Comment 7 Thomas Lendo 2017-06-12 20:42:15 UTC
Set this bug as duplicate of bug 103829 although this bug is older. The other one was bibisected and has more useful information for devs. Please go on in the other bug, thanks.

*** This bug has been marked as a duplicate of bug 103829 ***