Bug 98888 - FILESAVE: Export to mediawiki inserts redundant emptylines in <ref> when before headings
Summary: FILESAVE: Export to mediawiki inserts redundant emptylines in <ref> when befo...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Extensions (show other bugs)
Version:
(earliest affected)
5.1.1.3 release
Hardware: x86-64 (AMD64) Windows (All)
: medium minor
Assignee: Julien Nabet
QA Contact:
URL:
Whiteboard: target:6.0.0 target:5.4.0.1 target:5.3.5
Keywords:
Depends on:
Blocks: MediaWiki
  Show dependency treegraph
 
Reported: 2016-03-25 18:25 UTC by nasos010
Modified: 2017-06-13 11:49 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
File that shows the problem when exported in MediaWiki (12.92 KB, application/vnd.oasis.opendocument.text)
2016-03-25 18:25 UTC, nasos010
Details

Note You need to log in before you can comment on or make changes to this bug.
Description nasos010 2016-03-25 18:25:53 UTC
Created attachment 123850 [details]
File that shows the problem when exported in MediaWiki

When exporting to MediaWiki format, there is an empty line inserted in a footnote, before the </ref> tag, when the footnote is followed by a heading.

** i.e. 

<ref name="ftn7">Wikipedia [https://en.wikipedia.org/
https://en.wikipedia.org/]

</ref>

** instead of 

<ref name="ftn7">Wikipedia [https://en.wikipedia.org/
https://en.wikipedia.org/]</ref>

This is a problem, since it breaks i.e. the pandoc mediawiki parser.
Comment 1 Buovjaga 2016-04-07 10:12:34 UTC
Confirmed.

Win 7 Pro 64-bit Version: 5.2.0.0.alpha0+
Build ID: 7a7be32e5265f897174f3880adc061dac0203f1f
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2016-03-31_07:39:11
Locale: fi-FI (fi_FI)
Comment 2 Julien Nabet 2017-06-06 21:19:39 UTC
Let's give it a try with https://gerrit.libreoffice.org/#/c/38470/
Comment 3 Commit Notification 2017-06-07 05:14:36 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=8a400cfa468655142103f18f722adf1d5cbda9c7

tdf#98888: mediawiki inserts redundant emptylines in <ref>

It will be available in 5.5.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Commit Notification 2017-06-07 05:17:56 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "libreoffice-5-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=6b04e7073a707633531df85ce15d4ad9f3202a2d&h=libreoffice-5-4

tdf#98888: mediawiki inserts redundant emptylines in <ref>

It will be available in 5.4.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Julien Nabet 2017-06-12 20:26:44 UTC
The next major LO release after 5.4.0 will be 6.0.0 not 5.5.0 (marketing decision :-()
Comment 6 Commit Notification 2017-06-13 10:15:36 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "libreoffice-5-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=509fb27b9b630f8506af6104f8230b0efa2ebaaa&h=libreoffice-5-3

tdf#98888: mediawiki inserts redundant emptylines in <ref>

It will be available in 5.3.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.