Bug 98914 - Crash when inserting trend line
Summary: Crash when inserting trend line
Status: RESOLVED DUPLICATE of bug 99069
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
5.2.0.0.alpha0+
Hardware: All All
: medium critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: haveBacktrace
Depends on:
Blocks:
 
Reported: 2016-03-26 21:54 UTC by Laurent BP
Modified: 2016-04-05 18:13 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
zipped backtrace of the crash (4.12 KB, application/gzip)
2016-03-26 22:16 UTC, Laurent BP
Details
console bt (16.17 KB, text/plain)
2016-03-27 10:04 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Laurent BP 2016-03-26 21:54:23 UTC
Description: in master, it is not possible to create a trendline

Steps to reproduce:
1. Create a chart (Column, Bar, Area, Line or XY
2. Right click a series > Insert Trendline

Actual behavior:
crash

Reproduce with fresh master:
- Version: 5.2.0.0.alpha0+
Build ID: 379fb96dbd5ce0fdb0aaf5244d50583dc13d7611
CPU Threads: 4; OS Version: Linux 3.16; UI Render: default; 
Locale: fr-FR (fr_FR.UTF-8)

No problem to edit an existing trendline, but it is not possible to create a new one.
Comment 1 Laurent BP 2016-03-26 22:16:27 UTC
Created attachment 123879 [details]
zipped backtrace of the crash

Backtrace log file
Comment 2 Julien Nabet 2016-03-27 10:04:35 UTC
Created attachment 123887 [details]
console bt

On pc Debian x86-64 with master sources updated today, I could reproduce this.
I attached the same bt with additional console logs.
Comment 3 Maxim Monastirsky 2016-04-04 17:52:26 UTC

*** This bug has been marked as a duplicate of bug 99069 ***
Comment 4 Laurent BP 2016-04-05 18:13:20 UTC
Great! It is now fixed. Thanks Moggi :-)