Bug Hunting Session
Bug 98938 - handout does not print in portrait orientation
Summary: handout does not print in portrait orientation
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.1.1.2 rc
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 99945 116353 (view as bug list)
Depends on:
Blocks: Print-Dialog
  Show dependency treegraph
 
Reported: 2016-03-28 15:25 UTC by stuckyb
Modified: 2019-03-22 18:56 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of error and grayed-out option to rotate paper. (103.56 KB, image/png)
2017-05-27 16:16 UTC, c.rosenfield
Details

Note You need to log in before you can comment on or make changes to this bug.
Description stuckyb 2016-03-28 15:25:52 UTC
When printing slide handouts, Impress refuses to print in portrait orientation, even though the page payout for the handouts specifies portrait orientation.

Steps to reproduce:

1. Open Impress, create a new presentation.
2. Create 1 or more slides.
3. Switch to "Handout Master" view.
4. Go to Slide -> Page/Slide Properties to confirm that the page orientation is set to portrait.
5. Go to File -> Print and choose to print "Handouts" from the "Document" drop-down list.

The print preview will continue to show landscape orientation, as will the actual printout.  This is not a printer-specific issue, because even if I "Print to file", the output is still incorrect.

Thanks!
Comment 1 raal 2016-03-30 07:18:53 UTC
I can not confirm with Version: 5.2.0.0.alpha0+; win7
Comment 2 Buovjaga 2016-04-07 15:01:20 UTC
Repro.

Arch Linux 64-bit, KDE Plasma 5
Version: 5.2.0.0.alpha0+
Build ID: 9b0069c2833313ba9fab91f45edd354ba334f94b
CPU Threads: 8; OS Version: Linux 4.4; UI Render: default; 
Locale: fi-FI (fi_FI.UTF-8)
Built on April 3rd 2016
Comment 3 Buovjaga 2016-05-26 11:10:09 UTC
*** Bug 99945 has been marked as a duplicate of this bug. ***
Comment 4 leon244@comcast.net 2017-03-28 15:36:49 UTC
This is also true for me in LO 5.3.0.2 
Build ID: 5ad7b2889021c491af62f7930a4b1cb631392f16
CPU Threads: 8; OS Version: Linux 4.4; UI Render: default; VCL: kde4; Layout Engine: new; 
Locale: en-US (en_US.UTF-8); Calc: group 
using distro Mageia 5 x86_64

I am unable to change to portrait orientation from landscape when printing handouts page. There is no "page" option under the Format Menu. Changing the orientation is not possible using the "properties" button under "Printer Settings" as the choices are greyed out. Changing from "Landscape" to "Portrait" under the Page Setup dialog also fails to change the printer orientation.
Comment 5 c.rosenfield 2017-05-27 16:16:01 UTC
Created attachment 133650 [details]
Screenshot of error and grayed-out option to rotate paper.
Comment 6 c.rosenfield 2017-05-27 16:18:04 UTC
Reproduced in LO Impress. See screenshot: Handouts page is in landscape with slides falling off the bottom, option to rotate page is grayed out (across multiple printer installations). 

Version: 5.1.6.2
Build ID: 1:5.1.6~rc2-0ubuntu1~xenial2
CPU Threads: 8; OS Version: Linux 4.4; UI Render: default; 
Locale: en-US (en_US.UTF-8); Calc: group
Comment 7 Telesto 2018-03-13 16:36:38 UTC
*** Bug 116353 has been marked as a duplicate of this bug. ***
Comment 8 Telesto 2018-03-13 16:53:25 UTC
@Buovjaga,
Might be a regression.. However, can't check.. Not able to repro this with my Ubuntu VM
Comment 9 Buovjaga 2018-03-13 19:27:38 UTC
Can't test in 3.6 because it crashes when I go to Handouts (incompatibility with the modern libraries).

Still repro on Linux 6.1, but not on Windows, so Linux-only.

Arch Linux 64-bit
Version: 6.1.0.0.alpha0+
Build ID: c409fd2e8829b00f027070f34a5b743019800c6e
CPU threads: 8; OS: Linux 4.15; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on March 13th 2018

Version: 6.1.0.0.alpha0+
Build ID: 5b87abe06da35ca3a11628674af23460349b439a
CPU threads: 4; OS: Windows 10.0; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-03-12_23:45:38
Locale: fi-FI (fi_FI); Calc: group
Comment 10 Telesto 2018-03-14 15:01:04 UTC
@Buovjaga
This might be a workaround (not 100% sure)
File -> Print -> Impress tab -> select "Fit to printable page" instead of "Original size"
Comment 11 QA Administrators 2019-03-15 03:55:56 UTC Comment hidden (obsolete)
Comment 12 Tommy Trussell 2019-03-18 02:14:31 UTC
I am not the original reporter -- I originally reported Bug #116353 which was marked as a duplicate of this bug.

I just tested this and I am NOT seeing this behavior in Ubuntu 18.04.2 LTS running LibreOffice 6.0.7.3 (from LTS repository) nor in LibreOffice 6.2.1.2 (most recent version installed in Ubuntu as a snap).

SO I am marking this as RESOLVED -- WORKSFORME as suggested.

BY THE WAY the LTS version exhibits a DIFFERENT bug (the slide layout order is not correct -- it doesn't order the slides left to right then down as specified) but that bug, too, seems to be fixed in the newer SNAP version.
Comment 13 Buovjaga 2019-03-18 08:18:22 UTC
(In reply to Tommy Trussell from comment #12)
> BY THE WAY the LTS version exhibits a DIFFERENT bug (the slide layout order
> is not correct -- it doesn't order the slides left to right then down as
> specified) but that bug, too, seems to be fixed in the newer SNAP version.

Yep, it was fixed for 6.1: bug 99301
Comment 14 stuckyb 2019-03-22 18:56:56 UTC
Original bug reporter here.  Thanks for following up on this, everyone.  I just tested this again in LibreOffice 6.0.7.3 Ubuntu 18.04.2 LTS, and I can confirm that the bug appears to be fixed.  Thanks again!