Bug Hunting Session
Bug 98987 - Layout: shapes imported from DOCX handled incorrectly
Summary: Layout: shapes imported from DOCX handled incorrectly
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.2.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Miklos Vajna
URL:
Whiteboard: target:5.2.0 target:5.1.3 target:5.0.6
Keywords:
Depends on:
Blocks:
 
Reported: 2016-03-30 15:54 UTC by Miklos Vajna
Modified: 2019-01-25 03:35 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Reproducer document (19.05 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2016-03-30 15:54 UTC, Miklos Vajna
Details
How it should look like (7.68 KB, image/png)
2016-03-30 15:55 UTC, Miklos Vajna
Details
How it looks like currently (5.98 KB, image/png)
2016-03-30 15:56 UTC, Miklos Vajna
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Miklos Vajna 2016-03-30 15:54:09 UTC
Created attachment 123958 [details]
Reproducer document

See the attached document, the 3rd shape is not supposed to overlap with the other ones, but it does in LO.
Comment 1 Miklos Vajna 2016-03-30 15:55:32 UTC
Created attachment 123959 [details]
How it should look like
Comment 2 Miklos Vajna 2016-03-30 15:56:12 UTC
Created attachment 123960 [details]
How it looks like currently
Comment 3 Miklos Vajna 2016-03-30 15:57:01 UTC
The doc can be opened and saved back without any problem, so this is not a filter issue, but a layout one.
Comment 4 Commit Notification 2016-03-31 17:51:39 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=50223ea6e212b60b7d33839c2753c5601fb50f95

tdf#98987 sw: add AddVerticalFrameOffsets compat mode

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2016-04-04 08:14:25 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-5-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=8b97d64e24721e9df3647b7b1cfde5feff9904e2&h=libreoffice-5-1

tdf#98987 sw: add AddVerticalFrameOffsets compat mode

It will be available in 5.1.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2016-04-04 10:07:38 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-5-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=3e242e732e0aba170870098e4ce51d49f979eab9&h=libreoffice-5-0

tdf#98987 sw: add AddVerticalFrameOffsets compat mode

It will be available in 5.0.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.