Bug 98993 - Paragraph dialog rounds line spacing to full points
Summary: Paragraph dialog rounds line spacing to full points
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.0.4 release
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Michael Stahl
QA Contact:
URL:
Whiteboard: target:5.4.0 target:5.3.1 target:5.2.6
Keywords: regression
: 98967 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-03-31 05:40 UTC by Bruce Byfield
Modified: 2017-02-10 09:34 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bruce Byfield 2016-03-31 05:40:29 UTC
LibreOffice (and OpenOffice.org) used to allow line spacing in paragraph styles to be set to one-tenth of a point. However, for the last few releases, LO automatically rounds off whatever figure is entered.

Although these are small numbers, they mean that a font is displayed in a way contrary to its metrics. For example, an average 12 point font would ordinarily default to 14.4 points of line spacing. However, in the recent releases, it would display as 14 points, which is almost certain to look cramped.

This problem can be worked around by setting line spacing proportionally (that is, as a percentage). However, this workaround requires working back and forth, translating between percentages and points to get an exact setting.

However, if the field was returned to its earlier setting, designers could work directly with the Fixed line spacing setting, instead of juggling two different measurement systems.
Comment 1 raal 2016-03-31 07:41:33 UTC
I can confirm with Version: 5.2.0.0.alpha0+ and Version: 4.5.0.0.alpha0+; win7
regression against 4.0
Comment 2 raal 2016-03-31 14:24:19 UTC
reproducible with Version: 4.2.0.0.alpha1+
Comment 3 Commit Notification 2017-02-09 22:11:34 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d22377ab55675135776d94213ef06f608b71669e

tdf#98993 cui: Paragraph dialog: decimals in Line Spacing spinbox

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Michael Stahl 2017-02-09 22:12:54 UTC
fixed on master
Comment 5 Michael Stahl 2017-02-09 22:22:10 UTC
*** Bug 98967 has been marked as a duplicate of this bug. ***
Comment 6 Commit Notification 2017-02-10 09:09:03 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-5-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=29e18f08e9c8729d285feb992ea2c1f71fb7e618&h=libreoffice-5-3

tdf#98993 cui: Paragraph dialog: decimals in Line Spacing spinbox

It will be available in 5.3.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2017-02-10 09:34:03 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-5-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=01a68ee89809556125077b17a9055038be3a240d&h=libreoffice-5-2

tdf#98993 cui: Paragraph dialog: decimals in Line Spacing spinbox

It will be available in 5.2.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.