Bug Hunting Session
Bug 99004 - TextBox: draw shape and its textbox is out of sync
Summary: TextBox: draw shape and its textbox is out of sync
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.2.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Miklos Vajna
URL:
Whiteboard: target:5.2.0
Keywords:
Depends on:
Blocks:
 
Reported: 2016-03-31 14:44 UTC by Miklos Vajna
Modified: 2016-10-25 19:08 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Reproducer document (18.00 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2016-03-31 14:44 UTC, Miklos Vajna
Details
How it should look like (5.94 KB, image/png)
2016-03-31 14:46 UTC, Miklos Vajna
Details
How it looks like currently (6.51 KB, image/png)
2016-03-31 14:47 UTC, Miklos Vajna
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Miklos Vajna 2016-03-31 14:44:15 UTC
Created attachment 123991 [details]
Reproducer document

See the attached document, the draw shape and its textbox don't have the same position / size. It seems to be specific to a situation when a with-textbox and a without-textbox shape is anchored to the same paragraph.
Comment 1 Miklos Vajna 2016-03-31 14:46:31 UTC
Created attachment 123992 [details]
How it should look like
Comment 2 Miklos Vajna 2016-03-31 14:47:10 UTC
Created attachment 123993 [details]
How it looks like currently
Comment 3 Regina Henschel 2016-03-31 21:47:44 UTC
Please see also bug #84691 with a similar problem.
Comment 4 Miklos Vajna 2016-04-01 10:06:09 UTC
Yes, I can see. It seems to be a different problem though (so not closing this one as a duplicate), as in this document the problem is caused by anchoring multiple shapes to the same paragraph, while there there is only a single shape.
Comment 5 Commit Notification 2016-04-01 14:25:17 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=cd1b2f923e0b0be89a5d1c8cbc647133aac09ed5

tdf#99004 SwAnchoredObjectPosition: handle textboxes when determining surround

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.