Bug 99063 - Viewing UI Powerpoint OpenXML presentation containing animations on second screen choppy with Presenter Console
Summary: Viewing UI Powerpoint OpenXML presentation containing animations on second sc...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.1.1.3 release
Hardware: x86-64 (AMD64) Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Multimonitor
  Show dependency treegraph
 
Reported: 2016-04-03 19:18 UTC by Bryce
Modified: 2018-01-04 13:23 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
File requested (1.16 MB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2016-06-14 00:40 UTC, Bryce
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bryce 2016-04-03 19:18:52 UTC
Presenter Console enabled causes the animation transitions to be choppy. The only time it is enabled is with a second screen. Without the second screen it's smooth and without Presenter Console enabled it's smooth. It doesn't matter if the presenting screen is the main display or the second display it will be choppy if Presenter Console enabled. Disable and animation will work properly on either screen.
Comment 1 Alex Thurgood 2016-06-13 13:05:32 UTC
Bryce : pleae provide a sample Impress file containing the transitions and step by step explanations of how to reproduce the problem, thank you.
Comment 2 Alex Thurgood 2016-06-13 13:07:43 UTC
@Bryce : do you have multiple spaces on your OSX desktop ?
Comment 3 Bryce 2016-06-14 00:34:14 UTC
(In reply to Alex Thurgood from comment #1)
> Bryce : pleae provide a sample Impress file containing the transitions and
> step by step explanations of how to reproduce the problem, thank you.


Actually I am not running multiple spaces unless you consider having a second display (in this case a projector). Sometimes I run a second if I am using Prezi, but not with LibreOffice.
Comment 4 Bryce 2016-06-14 00:40:40 UTC
Created attachment 125643 [details]
File requested

Here is a file that can demonstrate what I am showing.

Problem: When using Presenter Console in Impress the animation is very choppy.

How to reproduce the problem
1. go to preferences and choose impress
2. Click General
3. Check the box for Enable Presenter Console

press F5 or start the presentation. The animation is very choppy on the second screen.

To make the problem go away turn off uncheck Enable Presenter Console and start the presentation and the animation will be very smooth.
Comment 5 Alex Thurgood 2016-09-16 10:14:35 UTC
Your test file is OpenXML, i.e. Powerpoint ?

Do you see the same problem with an Impress (ODP) file ?
Comment 6 Alex Thurgood 2016-09-16 10:33:45 UTC
OKay so tested with 

LO5212

on OSX 10.11.6

with a Thunderbolt display attached to a MacBookPro retina

Confirming

How to reproduce :

1) Load the test file into Impress

2) Keep the Impress window on Macbook screen, do not move it to the separate display.

3) Press fn+F5 on MacbookPro keyboard

4) The slideshow appears on the separate display (Thunderbolt display), and the Presenter Console appears on the Macbook Pro retina screen

5) Now use the arrow keys on the Macbook Pro keyboard to move slides - notice how the transitions become choppy.



Note : I can not reproduce the problem if I drag the Impress window to the separate display first, then launch the slideshow. In those circumstances, the slide transitions remain smooth (at least from my testing), so this could be a workaround. The Presenter Console still gets displayed on the MacbookPro screen irrespectively.
Comment 7 QA Administrators 2017-11-26 17:11:36 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present with the latest version of LibreOffice from https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the information from Help - About LibreOffice.
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a comment that includes the information from Help - About LibreOffice.

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3) from http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to 'inherited from OOo';
4b. If the bug was not present in 3.3 - add 'regression' to keyword


Feel free to come ask questions or to say hello in our QA chat: https://kiwiirc.com/nextclient/irc.freenode.net/#libreoffice-qa

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team

MassPing-UntouchedBug