Bug 99117 - In high-contrast-mode/theming the expandable nodes of the options tree in its dialog are rendered incorrectly
Summary: In high-contrast-mode/theming the expandable nodes of the options tree in its...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.1.0.3 release
Hardware: x86-64 (AMD64) Windows (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: accessibility
Depends on:
Blocks: High-Contrast
  Show dependency treegraph
 
Reported: 2016-04-06 10:15 UTC by Martin Lemburg
Modified: 2017-11-02 11:49 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of the left side of the options dialog showing the tree (16.13 KB, image/png)
2016-04-06 10:15 UTC, Martin Lemburg
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Lemburg 2016-04-06 10:15:40 UTC
Created attachment 124127 [details]
Screenshot of the left side of the options dialog showing the tree

Opening the options of LibreOffice, Writer, etc. while having switched on high-contrast-mode and chosen high-contrast-#1 theme, the clickable areas in front of the nodes of the tree on the left of the options dialog are invisible (seemingly black on black).
Thus the expandable nodes are difficult to identify.
Comment 1 Adolfo Jayme 2016-04-12 18:23:46 UTC
By judging the screenshot, this appears to be a problem only in non-modern versions of Windows (since Windows 8, high-contrast themes have been rewritten and use DWM, just like the regular, default Windows visual styles).
Comment 2 Martin Lemburg 2016-04-13 08:27:53 UTC
Yes - Windows 8+ did change a lot to the good in things of accessibility and high-contrast usage!
But the installation base of Windows 7 is still huge in relation to Windows 8 and the raising Windows 10.

So - no matter how old Windows 7 is, the fact, that a hardcoded color is used to render the clickable node-collapse/expand boxes in the tree points out a bug, since the application or system theming should determine the color to be used!
Comment 3 Buovjaga 2016-04-26 08:39:16 UTC
Confirmed.

Win 7 Pro 64-bit Version: 5.2.0.0.alpha1+
Build ID: d848960a3e77a8608a48f3ba394928c955f1e2d9
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2016-04-25_06:03:51
Locale: fi-FI (fi_FI)
Comment 4 QA Administrators 2017-10-28 17:46:57 UTC Comment hidden (obsolete)
Comment 5 Martin Lemburg 2017-11-02 11:34:16 UTC
I tested with LibreOffice version 5.4.2.2 and the tree in the options window gets rendered correctly in high-contrast mode.

BTW testing in high-contrast on Windows is not that difficult. The hotkey LeftAlt+LeftShift+PrintScr is normally enabled and toggles the high-contrast-mode with its default or last used high-contrast theme/design.
Comment 6 Buovjaga 2017-11-02 11:49:04 UTC
Excellent - one less accessibility issue!