Bug Hunting Session
Bug 99120 - DOC import: first page header shows up when title page is not set
Summary: DOC import: first page header shows up when title page is not set
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.2.2 release
Hardware: All All
: medium normal
Assignee: Miklos Vajna
URL:
Whiteboard: target:5.2.0 target:5.4.0 target:5.3.2
Keywords: regression
Depends on:
Blocks:
 
Reported: 2016-04-06 12:43 UTC by Miklos Vajna
Modified: 2017-03-07 04:44 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Reproducer document (22.50 KB, application/msword)
2016-04-06 12:43 UTC, Miklos Vajna
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Miklos Vajna 2016-04-06 12:43:36 UTC
Created attachment 124130 [details]
Reproducer document

The attached document has the following headers in Word:

- page 1: "Section 1, odd"
- page 2: "Section 1, even"
- page 3: "Section 2, odd"
- page 4: "Section 2, even"

In Writer the page 3 header is empty instead.
Comment 1 Miklos Vajna 2016-04-06 14:23:15 UTC
This was working before 4dc78aee9bcdb6ea5e9dc47ebb4a4b9e590c725a, though I suspect that just made the previously existing problem in the DOC import visible.
Comment 2 Commit Notification 2016-04-07 07:51:40 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=44a3eb37cd982c59f8350d53db3798b675230b35

tdf#99120 DOC import: fix lack of first share after odd section break

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 3 Timur 2016-05-04 07:44:01 UTC
Could it be already backported? Because it's OK also in 5.0.6.
Comment 4 Commit Notification 2017-03-06 09:28:07 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b3afee4b61740b20bb7430bd6bbe25023f705f3a

doc/docx: make unit test for tdf#99120 round-tripable

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2017-03-07 04:44:31 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "libreoffice-5-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b967275f34fbfb86f02937dc35a97defa0c3a996&h=libreoffice-5-3

doc/docx: make unit test for tdf#99120 round-tripable

It will be available in 5.3.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.