Bug Hunting Session
Bug 99160 - changing the ToC deletes 'undo' history
Summary: changing the ToC deletes 'undo' history
Status: RESOLVED DUPLICATE of bug 38703
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-04-08 13:59 UTC by Koen
Modified: 2016-04-12 11:36 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Koen 2016-04-08 13:59:14 UTC
Currently, when adjusting the ToC using the "Insert Index or Table of contents" window, these changes are not recorded for the 'undo' history. If there are items in the undo history, these are even erased! (after changing the ToC, the history list is empty and undo button is greyed-out)

This is very annoying if you make adjustments that don't work out as expected, but cannot easily change back to previous state.

E.g. when trying to adjust tab stop distances, you may accidentally end up with a very ugly ToC (the page number being on the next line). You'd have to know which the tab stop position was previously.

Ubuntu 14.04
Version: 5.1.1.2
Build ID: 1:5.1.1~rc2-0ubuntu1~trusty0
CPU Threads: 4; OS Version: Linux 3.13; UI Render: default; 
Locale: en-GB (en_GB.UTF-8)
Comment 1 Koen 2016-04-08 14:00:38 UTC
I would expect that when I click on 'ok' or 'apply', a new history point is created, as is the case when editing paragraph styles.
Comment 2 Oliver Specht (CIB) 2016-04-12 11:36:26 UTC

*** This bug has been marked as a duplicate of bug 38703 ***