Bug Hunting Session
Bug 99208 - Spreadsheet sort hangs
Summary: Spreadsheet sort hangs
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.1.1.3 release
Hardware: x86-64 (AMD64) All
: high major
Assignee: Markus Mohrhard
URL:
Whiteboard: target:5.2.0 target:5.1.3
Keywords: bibisected, bisected, regression
: 99287 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-04-10 23:13 UTC by Darrell Reich
Modified: 2018-05-06 05:26 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Screen shot of Sort dialing showing options and spreadsheet used (121.45 KB, application/zip)
2016-04-10 23:13 UTC, Darrell Reich
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Darrell Reich 2016-04-10 23:13:23 UTC
Created attachment 124240 [details]
Screen shot of Sort dialing showing options and spreadsheet used

LibreOffice Vanilla from app store 5.1.1.3 iMac OS X El Capitan 10.11.4 tried to sort attached spreadsheet as shown in attached screen shot (what is natural language sort, anyway?) and it hangs--let it run all night and the dreaded bouncing beach ball mouse pointer appears had to force quit and restart good that I saved my work before trying a sort. If the database File New worked (see other bug) then I wouldn't have tried this. I'll copy the data to Numbers then try the ubuntu linux vm version of LibreOffice...or use macports sql database...
Comment 1 raal 2016-04-11 07:09:18 UTC
This seems to have begun at the below commit.
Adding Cc: to Michael Stahl; Could you possibly take a look at this one? Thanks


f19f210a5064bef6e182ceb39247b6a63f37d9dd is the first bad commit
commit f19f210a5064bef6e182ceb39247b6a63f37d9dd
Author: Norbert Thiebaud <nthiebaud@gmail.com>
Date:   Fri Jan 22 04:47:03 2016 -0800

    source sha:fefd1221be844a033e409a18e05e8c6e98f6d1a7

    source sha:fefd1221be844a033e409a18e05e8c6e98f6d1a7

author	Michael Stahl <mstahl@redhat.com>	2016-01-21 17:11:12 (GMT)
committer	Michael Stahl <mstahl@redhat.com>	2016-01-21 18:42:56 (GMT)
commit	fefd1221be844a033e409a18e05e8c6e98f6d1a7 (patch)
tree	ec5ae47d187c9d109633853d058259916312c5df
parent	332a796366b7cb91dff41de4b9ffb17843112a3e (diff)
i18npool: handle non-BMP Unicode in cclass_Unicode::parseText()
Comment 2 Commit Notification 2016-04-12 16:27:34 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=087162b7142cf666478986461cdfa15c3d7fe382

fix infinite loop in text search, tdf#99208

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 3 Commit Notification 2016-04-12 16:32:37 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "libreoffice-5-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c0cbe81caa913fd7bff3a26422b38513020855e7&h=libreoffice-5-1

fix infinite loop in text search, tdf#99208

It will be available in 5.1.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 raal 2016-04-14 09:32:05 UTC
*** Bug 99287 has been marked as a duplicate of this bug. ***
Comment 5 Commit Notification 2018-05-06 05:26:25 UTC
Zdeněk Crhonek committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=98821620c99f66b9e30db225a2d28db7b28ba013

uitest for bug tdf#99208

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.