Bug 99332 - Page changing scrollbars disabled in print preview mode
Summary: Page changing scrollbars disabled in print preview mode
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.7.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, regression
Depends on:
Blocks: Scrollbars
  Show dependency treegraph
 
Reported: 2016-04-15 16:36 UTC by Yousuf Philips (jay) (retired)
Modified: 2018-09-14 12:12 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot 5.2 with both scrollbars (54.21 KB, image/png)
2016-04-15 23:35 UTC, m.a.riosv
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2016-04-15 16:36:08 UTC
Steps:
1) Open Calc
2) Add some text to a few fields so it runs across two pages
3) Enter print preview mode
4) The scrollbars are missing

Regression as they are available in 3.5.7.2.

Version: 5.2.0.0.alpha0+
Build ID: 92d7fef02574051826e46a3a7e3d33a1afa062d7
CPU Threads: 2; OS Version: Linux 4.2; UI Render: default; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2016-04-14_03:19:54
Locale: en-US (en_US.UTF-8)
Comment 1 raal 2016-04-15 17:19:40 UTC
It's regression in old version, so bibisected with 43-all. It can be any of these commits:
http://cgit.freedesktop.org/libreoffice/core/log/?qt=range&q=18c661f715a0b6850d30b374e5556dc14a377d2b..eab7e131ecebe4cdefcdcb1ad176bbdce83cb467

git bisect log
# bad: [423a84c4f7068853974887d98442bc2a2d0cc91b] source-hash-c15927f20d4727c3b8de68497b6949e72f9e6e9e
# good: [65fd30f5cb4cdd37995a33420ed8273c0a29bf00] source-hash-d6cde02dbce8c28c6af836e2dc1120f8a6ef9932
git bisect start 'latest' 'oldest'
# bad: [e02439a3d6297a1f5334fa558ddec5ef4212c574] source-hash-6b8393474974d2af7a2cb3c47b3d5c081b550bdb
git bisect bad e02439a3d6297a1f5334fa558ddec5ef4212c574
# bad: [8f4aeaad2f65d656328a451154142bb82efa4327] source-hash-1885266f274575327cdeee9852945a3e91f32f15
git bisect bad 8f4aeaad2f65d656328a451154142bb82efa4327
# good: [369369915d3582924b3d01c9b01167268ed38f3b] source-hash-45295f3cdceb4c289553791071b5d7f4962d2ec4
git bisect good 369369915d3582924b3d01c9b01167268ed38f3b
# bad: [6fce03a944bf50e90cd31e2d559fe8705ccc993e] source-hash-47e4a33a6405eb1b5186027f55bd9cb99b0c1fe7
git bisect bad 6fce03a944bf50e90cd31e2d559fe8705ccc993e
# bad: [8a39227e344637eb7154a10ac825d211e64d584c] source-hash-f5080ebb7022c9f5d7d7fdca4fe9d19f9bb8cabf
git bisect bad 8a39227e344637eb7154a10ac825d211e64d584c
# bad: [e8bc60acad752e284db73fc4d8ad383ac055361c] source-hash-7e6e16ba6de2d3ef2b130d1ad5ffeabfdb37918e
git bisect bad e8bc60acad752e284db73fc4d8ad383ac055361c
# bad: [19b8950109d519c0dba847f94d5d166044c1db15] source-hash-ff9cca69744b54ca84d98476a9a969d1aa0ff2d3
git bisect bad 19b8950109d519c0dba847f94d5d166044c1db15
# good: [f23b0ac1f569b0e043ebc0d0fe08ec76ea23d656] source-hash-552ba413bc95b1a14638558d9436141825100c52
git bisect good f23b0ac1f569b0e043ebc0d0fe08ec76ea23d656
# bad: [f3986117cf91f1976749922e435915354389c4f1] source-hash-eab7e131ecebe4cdefcdcb1ad176bbdce83cb467
git bisect bad f3986117cf91f1976749922e435915354389c4f1
# good: [cef0750df9186e2523a1a2d1ddb4c1ddbb85c19d] source-hash-18c661f715a0b6850d30b374e5556dc14a377d2b
git bisect good cef0750df9186e2523a1a2d1ddb4c1ddbb85c19d
# first bad commit: [f3986117cf91f1976749922e435915354389c4f1] source-hash-eab7e131ecebe4cdefcdcb1ad176bbdce83cb467
Comment 2 m.a.riosv 2016-04-15 23:35:07 UTC
Created attachment 124378 [details]
Screenshot 5.2 with both scrollbars

Scrollbar(s) is(are) hidden when page fits in the preview. 

Attached screenshot with both bars.

Win10x64
Version: 5.2.0.0.alpha0+
Build ID: ef34535ceb60d7d63b8d8671e4c6e9e43ffbd17d
CPU Threads: 4; OS Version: Windows 6.19; UI Render: GL; 
TinderBox: Win-x86@39, Branch:master, Time: 2016-03-27_09:52:41
Comment 3 Yousuf Philips (jay) (retired) 2016-04-16 14:49:43 UTC
So there are two sets of scrollbars. One for page-to-page scrolling when the page size fits in the viewable area (these are the ones that are missing) and one for scrolling within the page when the size doesnt fit within the viewable area (these are available).
Comment 4 m.a.riosv 2016-04-18 08:46:00 UTC
I can't see the problem here, getting automatically free space for visualization. A very nice behaviour from my point of view.
Comment 5 QA Administrators 2018-09-14 02:46:26 UTC Comment hidden (obsolete)
Comment 6 Roman Kuznetsov 2018-09-14 09:24:10 UTC
still repro in 6.1.1.1 but, IMHO it is WONTFIX, because all people scrolling page uses mouse scroll
Comment 7 m.a.riosv 2018-09-14 12:12:39 UTC
Look like.