Bug 99397 - Cannot open LibreOffice. It crashes the entire system on verification before first time opening (OSX 10.10)
Summary: Cannot open LibreOffice. It crashes the entire system on verification before ...
Status: RESOLVED DUPLICATE of bug 97530
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.1.1.3 release
Hardware: x86-64 (AMD64) Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-04-19 13:38 UTC by caraffande
Modified: 2016-10-23 10:01 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
OS dialog showing the verification progress (24.59 KB, image/png)
2016-04-20 09:06 UTC, caraffande
Details
Same dialog at 100% (24.47 KB, image/png)
2016-04-20 09:07 UTC, caraffande
Details

Note You need to log in before you can comment on or make changes to this bug.
Description caraffande 2016-04-19 13:38:18 UTC
After downloading and copying the .app file in the Application folder, I cannot open the application because the "verifying..." dialog hangs.
I've also verified in the Resource Monitor. The verification process uses up the ENTIRE system RAM, which eventually blocks the whole system.

My hardwar is 

iMac 7.1
4GB ram
Comment 1 Julien Nabet 2016-04-19 19:18:02 UTC
What's your MacOS version? Minimum requirement is 10.8

Did you download dmg file from official website (https://www.libreoffice.org/download/libreoffice-fresh/)?
Did you check integrity of the dmg (see http://download.documentfoundation.org/libreoffice/stable/5.1.2/mac/x86_64/LibreOffice_5.1.2_MacOS_x86-64.dmg.mirrorlist)

Also, do you have another LO version already installed? if yes, could you uninstall and give it a new try?
Finally, rename your LO directory profile (see https://wiki.documentfoundation.org/UserProfile#Mac_OS_X) and give a new try.
Comment 2 caraffande 2016-04-20 08:43:50 UTC
(In reply to Julien Nabet from comment #1)
> What's your MacOS version? Minimum requirement is 10.8

10.10

> 
> Did you download dmg file from official website
> (https://www.libreoffice.org/download/libreoffice-fresh/)?

Yes

> Did you check integrity of the dmg (see
> http://download.documentfoundation.org/libreoffice/stable/5.1.2/mac/x86_64/
> LibreOffice_5.1.2_MacOS_x86-64.dmg.mirrorlist)

Yes. OSX verifies each dmg downloaded from the web automatically by default

> 
> Also, do you have another LO version already installed? if yes, could you
> uninstall and give it a new try?

If you mean, some older version I'm keeping for some compatibilty reason, then no, i don't have any. If you mean that I need to manually delete the previous version of LO before updating LO (by copy the app to the /Application folder), then yes. I've tried first by simply overwriting the LibreOffice.app, then also by using CleanMyMac which deletes every remnant of the application, like prefs, ApplicationSupport, ecc. 
All this with no luck.
Upon launching the app, the "Verifing..." OS dialog appears and as soon as the progress bar hits 100% the SystemCoreServicesUI process starts devouring RAM, till it consumes it all up, crashing the entire system.

> Finally, rename your LO directory profile (see
> https://wiki.documentfoundation.org/UserProfile#Mac_OS_X) and give a new try.

As said, I've completely deleted everything. Useless.
The only workaround is to delete the xattr org.apple.quarantine which skips the entire verification process entirely, but this is only a workaround, not a solution.

Thank you
Comment 3 steve -_- 2016-04-20 08:53:14 UTC
Have you tried right click > open?

If so, please attach a screenshot of the error message you are seeing or, if you run into a hang and force quit, attach the crash log. Thanks.
Comment 4 caraffande 2016-04-20 09:06:28 UTC
Created attachment 124521 [details]
OS dialog showing the verification progress
Comment 5 caraffande 2016-04-20 09:07:37 UTC
Created attachment 124522 [details]
Same dialog at 100%
Comment 6 caraffande 2016-04-20 09:14:40 UTC
(In reply to steve -_- from comment #3)
> Have you tried right click > open?

Yes. No difference since the problem is not how you open the app. OSX, by default, marks each new application downloaded via web with the xattr com.apple.quarantine, and the very presence of this attribute triggers the OS verification process each time you try and launch the application, no matter how, wether by right-clicking or via the Dock Icon, or whatever.
The verification starts but never ends

> 
> If so, please attach a screenshot of the error message you are seeing or, if
> you run into a hang and force quit, attach the crash log. Thanks.

See the above. As said, the entire system hangs, freezes. I can only turn the power off.
Comment 7 tommy27 2016-04-20 19:38:00 UTC
LiO 5.1.2.2 is out. 
try that one and tell if issue is gone
Comment 8 Buovjaga 2016-04-29 11:22:02 UTC
Set to NEEDINFO.
Change back to UNCONFIRMED, if the problem persists with 5.1.2 or 5.1.3. Change to RESOLVED WORKSFORME, if the problem went away.
Comment 9 caraffande 2016-04-29 14:25:36 UTC
Tried with 5.1.2 and 5.1.3.1.
No luck
Comment 10 Alex Thurgood 2016-05-09 06:47:53 UTC
(In reply to caraffande from comment #9)
> Tried with 5.1.2 and 5.1.3.1.
> No luck

What are your Gatekeeper settings ? You must override these to allow installation of software from non-official sources, at least for the very first time you install LO.
Comment 11 Alex Thurgood 2016-05-09 06:50:01 UTC
Also note that if you do finally manage to install LO, you need an Oracle *JDK* in order to reduce spurious random crashes and avoid an annoying popup message that says that no JRE can be detected.
Comment 12 caraffande 2016-05-09 08:01:33 UTC
(In reply to Alex Thurgood (retired) from comment #10)
> (In reply to caraffande from comment #9)
> > Tried with 5.1.2 and 5.1.3.1.
> > No luck
> 
> What are your Gatekeeper settings ? You must override these to allow
> installation of software from non-official sources, at least for the very
> first time you install LO.

It is set to "app store and identified developers". 
No, that's definitely not the problem. If the problem was with GateKeeper settings, i'd not be able to even start the application. Actually that's what happens with the LangPack installer. The first time i try to launch the installer, a message pops up saying that the application is not from a certified source. Then i go to GateKeeper settings and i click "Allow this application for this time only", and then it fires.
But it's not the case with LO itself. I repeat, if delete the com.apple.quarantine xattr (sudo xattr -d -r com.apple.quarantine LibreOffice.app), the operating system does skip the verification process entirely and the application opens up.
I repeat, it is not the FIRST check, when the operating system is looking for a developer's signature of the app. I'm beyond that. It's when, AFTER this first check, the operating system verifies the entire application (CRC? I don't know)
Comment 13 Alex Thurgood 2016-09-02 08:02:51 UTC
Sounds like a problem that is specific to 10.10. I have two 10.11.x installations and unfortunately have never seen this problem.
Comment 14 Alex Thurgood 2016-09-02 08:09:03 UTC
@caraffande : I've just had a thought :

When you installed LO, how did you proceed :

1) Install main app, then
2) Install lang-pack (italian, I'm guessing, from the screenshot).


or did you (1a) start LO app at least once before installing the lang-pack ?

Until very recently, step (1a) was required in order to avoid that the lang-pack corrupted the main app bundle installation. If you didn't, this may be the cause of the xattr setting.

I'm also wondering if the IT lang-pack is the cause of the problem. Have you tried with other lang-packs ?
Comment 15 caraffande 2016-09-02 08:23:08 UTC
Well, I cannot remember because right now some time has passed since my fight with this installation problem.
I could be wrong but I think I've tried both, both with Langpack and without it.
But I cannot be sure, I'll give a try according to your guidelines as soon as a new release of LO is available.
Comment 16 Buovjaga 2016-09-02 08:27:54 UTC
(In reply to caraffande from comment #15)
> But I cannot be sure, I'll give a try according to your guidelines as soon
> as a new release of LO is available.

Stable releases 5.1.5 and 5.2.0 can be tested right now, assuming you are using an older version currently.
Comment 17 caraffande 2016-09-02 09:31:45 UTC
(In reply to Alex Thurgood from comment #15)
> or did you (1a) start LO app at least once before installing the lang-pack ?
I cannot open LO before installing the LangPack. As said, after having copied LO to the Applications folder, when you first try to open it, the "Verifing application..." dialog appears and when it reaches 100% progress the CoreServicesUIAgent starts eating up RAM memory indefinitely.   

(In reply to Buovjaga from comment #16)
> (In reply to caraffande from comment #15)
> > But I cannot be sure, I'll give a try according to your guidelines as soon
> > as a new release of LO is available.
> 
> Stable releases 5.1.5 and 5.2.0 can be tested right now, assuming you are
> using an older version currently.


Tried with version 5.2. Nope. Same issue.
Steps I follow:
1) Download dmg.
2) Open it (OS verifies Disk Image. Everything goos smooth)
3) Drag LO app to the Applications folder.
4) Double click LO icon. (no LangPack installed yet)
5) Verification dialog pops up.
6) Progress bar reaches 100%
7) System hangs
Comment 18 Alex Thurgood 2016-09-02 15:44:12 UTC
(In reply to caraffande from comment #17)


> 
> Tried with version 5.2. Nope. Same issue.
> Steps I follow:
> 1) Download dmg.
> 2) Open it (OS verifies Disk Image. Everything goos smooth)
> 3) Drag LO app to the Applications folder.
> 4) Double click LO icon. (no LangPack installed yet)
> 5) Verification dialog pops up.
> 6) Progress bar reaches 100%
> 7) System hangs

I have experienced this behaviour once, but from memory I got around the problem, by deleting everything, including my user profile, and re-installing.

Instead of double-clicking in step 4 above, I opened the Applications folder, and right mouse button clicked and chose Open. I honestly can't say whether this will solve the problem for you, but it did for me, however we are running different versions of OSX, so maybe there is an extra spanner in the works there.

I have seen another report on BZ that is very similar to yours, it is also in NEEDINFO status, but the person hasn't responded yet. Let me see if I can find it again.
Comment 19 Alex Thurgood 2016-09-02 15:45:20 UTC
*** Bug 101739 has been marked as a duplicate of this bug. ***
Comment 20 Alex Thurgood 2016-09-02 15:45:51 UTC
Found it, marked as DUP. Confirming this one as a result.
Comment 21 Alex Thurgood 2016-09-02 15:46:53 UTC
Note that in the DUP, that person is also using OSX 10.1O
Comment 22 Alex Thurgood 2016-10-23 10:01:34 UTC

*** This bug has been marked as a duplicate of bug 97530 ***