Bug Hunting Session
Bug 99398 - Table and Illustration cross-refs ;lost when saving as DOCX
Summary: Table and Illustration cross-refs ;lost when saving as DOCX
Status: RESOLVED DUPLICATE of bug 42346
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.1.0.3 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:docx
Depends on:
Blocks:
 
Reported: 2016-04-19 13:49 UTC by kc.okane
Modified: 2016-04-19 16:37 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
example DOCX rendering shown in libreoffice writer (248.16 KB, image/jpeg)
2016-04-19 13:49 UTC, kc.okane
Details
sample odt file (28.18 KB, application/vnd.oasis.opendocument.text)
2016-04-19 15:07 UTC, kc.okane
Details
broken MS ODCX file (11.14 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2016-04-19 15:08 UTC, kc.okane
Details
fodt version (109.40 KB, application/vnd.oasis.opendocument.text-flat-xml)
2016-04-19 15:08 UTC, kc.okane
Details

Note You need to log in before you can comment on or make changes to this bug.
Description kc.okane 2016-04-19 13:49:59 UTC
Created attachment 124504 [details]
example DOCX rendering shown in libreoffice writer

An ODT file with many references to tables and illustrations when saved as a DOCX file (either form), the numeric references are replaced by the words 'table' or 'illustration'. Example "as can be seen in Table 123" becomes "As can be seen in Table table".
Comment 1 V Stuart Foote 2016-04-19 14:44:42 UTC
The JPEG clip is OK, but please provide an extract of a couple pages from source in ODT as a document, and then the same extract as saved to OOXML .docx that replicates the loss of annotation.

Need that to be able to duplicate.

Also, what distro/release of Linux and which desktop environment are you working with?
Comment 2 kc.okane 2016-04-19 15:07:50 UTC
Created attachment 124507 [details]
sample odt file
Comment 3 kc.okane 2016-04-19 15:08:25 UTC
Created attachment 124508 [details]
broken MS ODCX file
Comment 4 kc.okane 2016-04-19 15:08:57 UTC
Created attachment 124509 [details]
fodt version
Comment 5 kc.okane 2016-04-19 15:10:32 UTC
Linux Mint 17.3 Mate( (1.12.0) 
Linux 3.13.0-24
Comment 6 Cor Nouws 2016-04-19 16:36:51 UTC
Thanks for reporting.
I expect it to be the same as bug 42346.
Cor

*** This bug has been marked as a duplicate of bug 42346 ***