Bug 99446 - Garbled text characters / glyphs in some dialogs in Linux
Summary: Garbled text characters / glyphs in some dialogs in Linux
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
5.1.1.3 release
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard: target:5.1.5
Keywords: bibisectRequest
: 99636 99728 99782 100063 100124 100912 101367 101391 101392 101600 105757 (view as bug list)
Depends on:
Blocks: VCL-OpenGL
  Show dependency treegraph
 
Reported: 2016-04-22 05:08 UTC by Jean-François Fortin Tam
Modified: 2017-10-28 18:23 UTC (History)
15 users (show)

See Also:
Crash report or crash signature:


Attachments
screencast (439.19 KB, video/webm)
2016-04-22 05:08 UTC, Jean-François Fortin Tam
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jean-François Fortin Tam 2016-04-22 05:08:41 UTC
Created attachment 124561 [details]
screencast

Running the open-source "radeon" gallium X.org drivers with a Radeon HD 7770 (radeonsi chipset) on Fedora 23 64-bit, with LibreOffice 5.1.1.x and 5.1.2.x downloaded from the LibreOffice website, some of the LibreOffice dialogs show broken text glyphs. See attached screencast.

This is with experimental features turned off, and the traditional UI backend (not the GTK3 one). Couldn't find a way to try out the GTK3 version from the RPMs downloaded from the LibreOffice website (even if I check "Enable experimental features")
Comment 1 Walter Garcia-Fontes 2016-04-26 07:41:40 UTC
I'm getting this bug with the following graphics:
  *-display               
       description: VGA compatible controller
       product: Bonaire [FirePro W5100]
       vendor: Advanced Micro Devices, Inc. [AMD/ATI]
       physical id: 0
       bus info: pci@0000:03:00.0
       version: 00
       width: 64 bits
       clock: 33MHz
       capabilities: vga_controller bus_master cap_list rom
       configuration: driver=radeon latency=0

The OS is:
Description:	Ubuntu 16.04 LTS
Release:	16.04
Codename:	xenial

See:
https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-ati/+bug/1575000
Comment 2 D 2016-04-27 12:11:12 UTC
I also can confirm this. 

I run Debian Testing/Stretch, with LibreOffice 5.1.2.2 from the repos. 

  *-display               
       description: VGA compatible controller
       product: Kaveri [Radeon R7 Graphics]
       vendor: Advanced Micro Devices, Inc. [AMD/ATI]
       physical id: 1
       bus info: pci@0000:00:01.0
       version: d6
       width: 64 bits
       clock: 33MHz
       capabilities: pm pciexpress msi vga_controller bus_master cap_list rom
       configuration: driver=radeon latency=0

So far I observed this problem only in LibreOffice, no other software. 

The issue disappears when OpenGL is switched on.
Comment 3 raal 2016-04-28 06:30:20 UTC
confirmed in comment 2
Comment 4 D 2016-04-28 11:07:55 UTC
I just installed 5.2.0.0.alpha1 (Build ID: 902b28a39528b6c92602e9b521a1d0861be1caf9) and I cannot reproduce this bug there.

It would be great if someone could confirm this.
Comment 5 raal 2016-04-28 11:34:07 UTC
Jean, Walter,
please could you test it with dev version?  You can download it here: http://dev-builds.libreoffice.org/daily/master/
Thank you
Comment 6 Walter Garcia-Fontes 2016-05-02 11:36:29 UTC
raal, I installed LibreOffice 5.2.0.0.alpha1 in my affected system and the artifact is gone, no font glyph corruption any more.
Comment 7 raal 2016-05-02 11:43:27 UTC
Walter and "D" thanks for testing. Closing the bug.
Comment 8 Adolfo Jayme 2016-05-03 01:47:38 UTC
*** Bug 99636 has been marked as a duplicate of this bug. ***
Comment 9 Adolfo Jayme 2016-05-11 22:06:55 UTC
*** Bug 99728 has been marked as a duplicate of this bug. ***
Comment 10 Adolfo Jayme 2016-05-11 22:07:08 UTC
*** Bug 99782 has been marked as a duplicate of this bug. ***
Comment 11 Aron Budea 2016-05-26 18:16:52 UTC
*** Bug 100063 has been marked as a duplicate of this bug. ***
Comment 12 Aron Budea 2016-05-26 18:18:33 UTC
Just a question, do we know if this is fixed in the 5.1 branch?
Comment 13 robsn5 2016-05-27 08:36:25 UTC
I have the very same issue on an intel skylake system under openSUSE Tumbleweed. My Libreoffice version is: 
Version: 5.1.3.1
Build ID: 10m0(Build:1)
CPU Threads: 4; OS Version: Linux 4.6; UI Render: default; 
Locale: en-US (en_US.UTF-8)
Comment 14 robsn5 2016-05-27 08:37:35 UTC
Is there a specific patch I could refer to, which could be applied for 5.1 series?
Comment 15 robsn5 2016-05-27 13:27:07 UTC
with 5.2 beta1 issue is resolved here for intel skylake too.
Thanks.
Comment 16 Aron Budea 2016-05-29 17:56:05 UTC
*** Bug 100124 has been marked as a duplicate of this bug. ***
Comment 17 Buovjaga 2016-05-29 18:53:52 UTC
If someone wants to verify the fix is in 5.1 branch: http://dev-builds.libreoffice.org/daily/libreoffice-5-1/?C=M;O=A
Comment 18 Aron Budea 2016-06-07 10:34:14 UTC
The bug is still there in 5.1.4.1 according to this comment:
https://www.reddit.com/r/libreoffice/comments/4ljqr8/i_have_strange_unreadable_fonts_in_some_of_los/d3z9gwp
Comment 19 Joseph A. Sochet 2016-06-08 03:37:40 UTC
So I solved my problem by removing a faulty Tahoma font, as I think it gets some priority for UI font if available.
Comment 20 Aron Budea 2016-06-08 11:31:47 UTC
Caolán, any thoughts on how this could still be occurring in 5.1.4.1?
Comment 21 Caolán McNamara 2016-06-09 08:45:44 UTC
Looking into my history of a very similar sounding bug we had in fedora, then I debugged this for ages and I think its a bug somewhere else outside of LibreOffice, and its only happening on the X+cairo route. I have a bodge for it which I see didn't make it back to 5.1 but did to 5.2.

What worked for me in Fedora is available for review for backporting to 5-1 at https://gerrit.libreoffice.org/#/c/26087/
Comment 22 Commit Notification 2016-06-11 10:15:14 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-5-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c55d703ea00de67793765f8da7ca17dfb54281fc&h=libreoffice-5-1

Related: tdf#99446 cairo text + xrender bodge

It will be available in 5.1.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 23 Aron Budea 2016-07-14 21:49:52 UTC
*** Bug 100912 has been marked as a duplicate of this bug. ***
Comment 24 Aron Budea 2016-08-08 00:11:08 UTC
*** Bug 101367 has been marked as a duplicate of this bug. ***
Comment 25 Adolfo Jayme 2016-08-09 11:13:39 UTC
*** Bug 101392 has been marked as a duplicate of this bug. ***
Comment 26 Aron Budea 2016-08-18 23:34:06 UTC
*** Bug 101600 has been marked as a duplicate of this bug. ***
Comment 27 Aron Budea 2017-02-04 21:21:44 UTC
*** Bug 105757 has been marked as a duplicate of this bug. ***
Comment 28 Xisco Faulí 2017-10-28 18:23:40 UTC
*** Bug 101391 has been marked as a duplicate of this bug. ***