Bug 99456 - DIALOG:Similarities & Sounds buttons too small in dialog Find & Replace
Summary: DIALOG:Similarities & Sounds buttons too small in dialog Find & Replace
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.0.0.5 release
Hardware: All All
: medium normal
Assignee: Heiko Tietze
URL:
Whiteboard: target:5.4.0
Keywords:
: 100816 101585 (view as bug list)
Depends on:
Blocks: Find-Search
  Show dependency treegraph
 
Reported: 2016-04-22 16:00 UTC by pierre-yves samyn
Modified: 2017-08-24 17:09 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Find & replace screenshot (13.44 KB, image/png)
2016-04-22 16:00 UTC, pierre-yves samyn
Details
Similarities button LO 5.2.1.1 in Win7 (20.55 KB, image/png)
2016-08-17 11:51 UTC, brucehohl
Details

Note You need to log in before you can comment on or make changes to this bug.
Description pierre-yves samyn 2016-04-22 16:00:01 UTC
Created attachment 124573 [details]
Find & replace screenshot

Hi

The height of the "Similarities" & "Sounds" buttons is too small (see the attached screenshot).

Steps to reproduce:
1. File> New> Text (or Spreadsheet, etc.)
2. Edit> Find & Replace> click Other options to expand

Platform windows 7/64 & Version: 5.2.0.0.alpha1 (x64)
Build ID: 902b28a39528b6c92602e9b521a1d0861be1caf9
CPU Threads: 2; OS Version: Windows 6.1; UI Render: default; 
Locale: fr-FR (fr_FR)

Regards
Pierre-Yves
Comment 1 pierre-yves samyn 2016-04-22 16:03:38 UTC
To be continued ...

Problem occurs on windows with Version: 5.1.2.2 *and* also in the new dialog of 5.2.0.0.alpha1 (screenshot)

Regards
Pierre-Yves
Comment 2 Adolfo Jayme 2016-04-23 18:27:19 UTC
There’s no reason why these buttons shouldn’t be placed below their respective checkboxes and avoid the cramped appearance.
Comment 3 Adolfo Jayme 2016-04-26 04:08:45 UTC
Hm, it’s not enough with moving the buttons downwards in the .ui file; this needs tweaks to the code…
Comment 4 Adolfo Jayme 2016-07-10 23:01:31 UTC
*** Bug 100816 has been marked as a duplicate of this bug. ***
Comment 5 brucehohl 2016-08-17 11:51:34 UTC
Created attachment 126873 [details]
Similarities button LO 5.2.1.1 in Win7

Screen shot of "Find & Replace" from Calc LO 5.2.1.1 with ill-sized Similarities button.  Also, this button appears to push down the Comments check box (Writer) and the Wildcards check box (Calc) such that the grid layout if not maintained.  Perhaps Similarities button should be positioned in the second column or in the first column but with no Control to its right.
Comment 6 Roeland 2016-08-28 19:28:35 UTC
*** Bug 101585 has been marked as a duplicate of this bug. ***
Comment 7 Telesto 2017-01-12 19:48:41 UTC
Still a repro with:
Version: 5.4.0.0.alpha0+
Build ID: 88f561204d7cee25633df8117cc8d7e1ebd8e9ad
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-01-11_23:07:37
Locale: nl-NL (nl_NL); Calc: CL

also found in:
Version: 5.0.0.5
Build ID: 1b1a90865e348b492231e1c451437d7a15bb262b
Locale: en-US (nl_NL)
Comment 8 Heiko Tietze 2017-01-23 22:06:30 UTC
This issue will be changed with bug 105371.
Comment 9 Commit Notification 2017-02-03 01:08:52 UTC
heiko tietze committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=789ed159fb03eef26c991f361380d0eb7b509cd9

tdf#105371, tdf#99456 Alignment in find & replace dialog

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Xisco Faulí 2017-04-13 09:10:21 UTC
Hello,
Is this bug fixed?
If so, could you please close it as RESOLVED FIXED?