Bug 99483 - Marque cell selection should be removed after paste
Summary: Marque cell selection should be removed after paste
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.2.0.0.alpha1
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: target:6.1.0
Keywords: needsDevEval, topicUI
: 54485 (view as bug list)
Depends on:
Blocks: HelpGaps-NewFeatures Paste
  Show dependency treegraph
 
Reported: 2016-04-24 14:50 UTC by Yousuf Philips (jay) (retired)
Modified: 2018-03-15 17:17 UTC (History)
11 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2016-04-24 14:50:42 UTC
When a cell, column or row are cut or copied, a marque appears around the cells to indicate what was being selected during the clipboard operation (this was introduced in LO 3.5). But when they are pasted elsewhere, the marque still remains around the cells, and i think it should be disabled at this point.
Comment 1 Yousuf Philips (jay) (retired) 2016-04-24 15:03:24 UTC
I've checked some spreadsheet apps that have the marque (Excel, Google Docs, Gnumeric, WPS) and they all disable the marque after paste.
Comment 2 Heiko Tietze 2016-04-24 17:46:56 UTC
But the cell state remains as the clipboard source until any input. You can copy once and paste repeatedly. Good to know where the source was.
(Escape clears the selection/marque but not the clipboard.)
Comment 3 Yousuf Philips (jay) (retired) 2016-04-24 21:06:04 UTC
(In reply to Heiko Tietze from comment #2)
> But the cell state remains as the clipboard source until any input.

It will remain in the clipboard even after an input.

> You can
> copy once and paste repeatedly. Good to know where the source was.
> (Escape clears the selection/marque but not the clipboard.)

Not so useful after you paste the first time and when you paste at a location that isnt near the original copy. It isnt useful at all when you cut and paste.
Comment 4 Heiko Tietze 2016-04-24 21:28:50 UTC
(In reply to Yousuf (Jay) Philips from comment #3)
> It isnt useful at all when you cut and paste.

You know where the pasted content comes from, perhaps to move it back without undo. I have to admit that my arguments are dragged in by head and shoulders. But what is the advantage of clearing the marque? Users know what it means, so the confusion reduces to inconsistency in the state. And I'm not sure that this is true.
Comment 5 Cor Nouws 2016-04-24 21:36:26 UTC
Talking about 'head and shoulders': this behaviour is here since 2011 or so. And can hardly be missed. So if it is nasty, people would have complained. Or did I miss that?
Comment 6 Yousuf Philips (jay) (retired) 2016-04-24 22:56:33 UTC
(In reply to Heiko Tietze from comment #4)
> You know where the pasted content comes from, perhaps to move it back
> without undo.

I would assume the content disappearing from that location is more than sufficient indication where the content moved from. We dont have any particular indication of where content moved from in writer.

> I have to admit that my arguments are dragged in by head and
> shoulders. But what is the advantage of clearing the marque?

The first advantage would be that users wouldnt have to press Escape to disable it. Secondly the behaviour would mimic all other apps that have marque.

> Users know what
> it means, so the confusion reduces to inconsistency in the state. And I'm
> not sure that this is true.

Yes users can understand its meaning when they copy and cut, primarily when they cut as the contents arent actually being cut out of the sheet until you paste, unlike other apps where when you cut the contents do disappear. But once you've pasted, especially when you cut, it has very little meaning and users seeing the marque would assume that the action isn't completed.

(In reply to Cor Nouws from comment #5)
> Talking about 'head and shoulders': this behaviour is here since 2011 or so.
> And can hardly be missed. So if it is nasty, people would have complained.
> Or did I miss that?

Well as a new user to Calc in 2014/2015 when i worked on the user stats, it was a major annoyance to me that i never reported and stuck with pressing Esc each time. Came to mind again today when someone else brought it up.
Comment 7 Cor Nouws 2016-04-25 07:00:04 UTC
Mind that as long as the selection is active, Enter pastes it.
And using Enter stops the selection.
I'm not sure if this has been documented or discussed by Kohei. but maybe it is good to ask.
Comment 8 Yousuf Philips (jay) (retired) 2016-04-25 19:20:00 UTC
(In reply to Cor Nouws from comment #7)
> Mind that as long as the selection is active, Enter pastes it.
> And using Enter stops the selection.

Interesting behaviour and it also clears the paste clipboard.

> I'm not sure if this has been documented or discussed by Kohei. but maybe it
> is good to ask.

Not documented but definitely should be - https://help.libreoffice.org/Common/Paste
Comment 9 Cor Nouws 2016-04-26 14:17:12 UTC
currently not confirmed.
Comment 10 Yousuf Philips (jay) (retired) 2016-04-26 19:54:15 UTC
(In reply to Cor Nouws from comment #9)
> currently not confirmed.

We dont leave ux-advise enhancements as unconfirmed as that causes problems for QA.
Comment 11 Heiko Tietze 2016-09-27 06:52:13 UTC
The idea didn't received acceptance. So lets close it as WONTFIX. But not before Olivier acknowledge the documentation need. So just removing UX for now.
Comment 12 Dave Barton 2016-09-27 07:52:59 UTC
I and a number of my users find this to be an irritating distraction and do not understand why Calc has to function differently to most other spreadsheet software in this respect.

In _MOST_ instances, it serves no useful purpose and adds yet another step (pressing Esc or Enter key) to the cut/copy paste operation.

Rather than disabling this (feature?) completely, could we not make it a user definable/selectable option?
Comment 13 Yousuf Philips (jay) (retired) 2016-09-28 08:49:08 UTC
If this behaviour is the preferred default, then we should provide a means of disabling it for those who dont want it.

Checked Calligra Sheets and they dont have a marque during the copying or pasting. :D

@Eike: Any thoughts on this issue?
Comment 14 Samuel Mehrbrodt (CIB) 2016-09-28 10:47:54 UTC
Personally I always found that selection weird. I would remove it.

Any idea what was the intention when this was introduced?
Comment 15 mahfiaz 2016-09-28 10:54:09 UTC
This marquee distracts and annoys me so much that after copying any larger range I always copy again single cell somewhere in the corner to get rid of that marquee. I'd say good riddance.
Comment 16 Cor Nouws 2016-09-28 10:57:20 UTC
I should have explained that this behavior is exactly what Excel users expect.

After Copy/Cut, you can paste with Ctrl+V - leaving the 'walking ants'.
But when you paste with Enter, they disappear right away.
Comment 17 Cor Nouws 2016-09-28 11:06:23 UTC
(In reply to mahfiaz from comment #15)
> This marquee distracts and annoys me so much that after copying any larger
> range I always copy again single cell somewhere in the corner to get rid of
> that marquee. 

ESC will help for that too
Comment 18 Eike Rathke 2016-09-28 12:33:58 UTC
As long as the ants are marching one can paste the selection with Enter after which the clipboard is cleared and the ants stop marching. The ants are the indicator that the selection can still be pasted. Yes this behavior (paste with Enter) is from Excel times where no clipboard existed. Yes this behavior was requested by users. Note that Excel does not clear the ants when using Ctrl+V or the menu to paste, contrary to what comment 1 said.

I recommend to not change this behavior.
Comment 19 Eike Rathke 2016-09-28 12:51:33 UTC
(In reply to Eike Rathke from comment #18)
> Note that Excel does not clear the ants
> when using Ctrl+V or the menu to paste, contrary to what comment 1 said.
It does clear the ants after cut&paste, but that is because in Excel a cut can be pasted only once.
Comment 20 Yousuf Philips (jay) (retired) 2016-09-28 23:07:04 UTC
So i asked Kohei about this on twitter and here is his response.

@kohei_yoshida: That's a feature. While that's visible, you can hit enter to paste it. It's an indicator that you are in paste mode.

@kohei_yoshida: and hitting ESC will let you exit out of paste mode.

@jphilipz: is it possible to cancel the marque and still be in paste mode? any link to the discussion about implementing this feature?

@kohei_yoshida: yes to the first and not that I'm aware of to the second. Why would you want to do that?

@jphilipz: marque is distracting and unless you knew about pressing enter (not even documented in help), users press Esc to disable it

@kohei_yoshida: Excel has the same behavior, and that's where it originally came from. Surely not everyone thinks it's distracting?

@kohei_yoshida: My advice would be to re-design the paste range mark to make it less distracting. You need some visual clue for paste mode.

@kohei_yoshida: And check more recent version of Excel and see if how it behaves there for additional data point.

@jphilipz: it is understandable to have a visual clue of where the source of the cut/copy is so you can recheck, but why after pasting?

@jphilipz: checked 2010 and it wasnt much different, so i'll check 2013 when i get a chance.

Complete discussion: https://twitter.com/jphilipz/status/781113006788935681
Comment 21 Yousuf Philips (jay) (retired) 2016-09-29 00:00:55 UTC
(In reply to Eike Rathke from comment #18)
> As long as the ants are marching one can paste the selection with Enter
> after which the clipboard is cleared and the ants stop marching.

Is it important to clear the clipboard?

> The ants are the indicator that the selection can still be pasted.

If a user has pasted something once, why would they need an indicator that they can paste it again, because the user can paste to a cell that isnt in the view area, or on a different sheet, or from outside of calc. A user could also copy, press Esc and then go around pasting as they like.

> Yes this behavior
> (paste with Enter) is from Excel times where no clipboard existed. Yes this
> behavior was requested by users.

Is a feature that was created at a time when no clipboard existed useful in this day and would it be useful for users who never used Excel or never used Excel when there wasnt a clipboard?

> Note that Excel does not clear the ants
> when using Ctrl+V or the menu to paste, contrary to what comment 1 said.

Guess i was mistaken about this, as i just double checked and it did stay.

(In reply to Eike Rathke from comment #19)
> It does clear the ants after cut&paste, but that is because in Excel a cut
> can be pasted only once.

Interesting approach for Excel to choose and glad we dont follow pasting only once.
Comment 22 mahfiaz 2016-09-29 02:05:00 UTC
> Interesting approach for Excel to choose and glad we dont follow pasting only once.

yousuf, not true. Try Ctrl+C, paste using Enter, and try to paste again with Ctrl+V. Clipboard is empty.

Also pasting using Ctrl+V is strong indicator that ínferior pasting with Enter is not going to be used.

So I think we should:
1) clear marquee whenever non-Enter pasting is used (ctrl+V, menu, whatever)
2) not clear clipboard after pasting with Enter
Comment 23 Heiko Tietze 2016-09-29 08:15:56 UTC
(In reply to mahfiaz from comment #22)
> yousuf, not true. Try Ctrl+C, paste using Enter, and try to paste again with
> Ctrl+V. Clipboard is empty.

Do not mix things up: Both copy or cut lets me paste infinitely with shift+insert and ctrl+V. But the ants fall asleep after Enter. (Version: 5.2.1.2 @Linux)

Interesting fact: The area/clipboard indicator becomes a "bug" with random values. Fill an area with "=rand()", copy all, and _paste as number_ somewhere. Random values are scrambled after each operation with the sheet but the clipboard remains what it was.

Comparing the behavior with other tools beyond Excel it turns out that Calligra Sheets has no ants at all and the clipboard is never cleared. Paste per enter is not available.
Gnumeric has ants that march until escape is pressed. After pasting the clipboard is still valid. There is no paste per enter. The "=rand()" test copy/pastes the function meaning the original is never changed and the pasted content has new numbers (same in Calligra). When I paste as number a dialog pops up and stops the ants. Clipboard is not cleared in this situation.

Personally I would keep the current behavior since the benefit of the indication outweigh the minor annoyances to press escape (yes, I do this too).
Comment 24 mahfiaz 2016-09-29 14:07:12 UTC
Heiko, I don't think I am mixing anything up. Try this:

1) Copy a range with Ctrl+C
2) Paste with Ctrl+V (works)
3) Paste again with Ctrl+V just to be sure (works)
4) Paste with enter (works)
5) Paste with Ctrl+V again, doesn't work, because clipboard is cleared.

I think 5) should work as well.
Comment 25 Yousuf Philips (jay) (retired) 2016-10-04 05:35:29 UTC
(In reply to mahfiaz from comment #22)
> yousuf, not true. Try Ctrl+C, paste using Enter, and try to paste again with
> Ctrl+V. Clipboard is empty.

The issue me and eike were talking about was cut and paste and our behaviour is different to excel, meaning excel only allows a single paste.
Comment 26 Yousuf Philips (jay) (retired) 2017-06-30 15:42:26 UTC
*** Bug 54485 has been marked as a duplicate of this bug. ***
Comment 27 Commit Notification 2018-03-15 12:58:05 UTC
Olivier Hallot committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=71c51c931a99039b3bd4944dbce56ee53be29867

tdf#99483 Clarify Calc paste operation