Download it now!
Bug 99490 - After upgrading, spell checker no longer works
Summary: After upgrading, spell checker no longer works
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.1.2.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Spell-Checking
  Show dependency treegraph
 
Reported: 2016-04-25 01:57 UTC by Todd
Modified: 2017-06-01 07:52 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
offending registrymodifications that kill spell check (942.91 KB, application/xml)
2016-05-06 23:29 UTC, Todd
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Todd 2016-04-25 01:57:17 UTC
LibreOffice_5.1.2_Linux_x86-64_rpm.tar.gz

Hi All,

Would one of our intrepid heroes please fix this for me?

After each 5.1 upgrade, I loose my dictionary (spell check says "none") and I can no longer spell check or spell as I type.  AND I WENT TO PUBLIK SKOL !!!

This symptom includes a fresh .config/libreoffice

This is getting really really A-N-N-O-Y-I-N-G.

Please fix. And fix for subsequent upgrades as well.

Many thanks,
-T

I will see if anyone on the forums knows how to get my spell checker back.  I have been pasting into Thunderbird, correcting my spelling, then pasting back into Libre Office.  :'(  :'(  :'(
Comment 1 Todd 2016-04-25 02:02:05 UTC
The toolbar at the bottom says (USA English).  Spell check dialog says "none" and there is nothing in the drop down.
Comment 2 Todd 2016-04-30 01:41:33 UTC
This did not work:
https://forum.openoffice.org/en/forum/viewtopic.php?f=74&t=16512

This did:
https://forum.openoffice.org/en/forum/viewtopic.php?p=58403#p58403

Would you guys please come up with a way to stop this from happening every upgrade?
Comment 3 Todd 2016-04-30 01:43:57 UTC
I have my old profile still kicking around if you guys want it for troubleshooting.
Comment 4 Todd 2016-04-30 02:08:38 UTC
Found the offender.  It is "registrymodifications.xcu".  Would you like me to upload it.
Comment 5 Buovjaga 2016-05-06 12:07:52 UTC
(In reply to Todd from comment #4)
> Found the offender.  It is "registrymodifications.xcu".  Would you like me
> to upload it.

Sure.
Comment 6 Todd 2016-05-06 23:29:21 UTC
Created attachment 124888 [details]
offending registrymodifications that kill spell check
Comment 7 Buovjaga 2016-05-07 09:27:45 UTC
(In reply to Todd from comment #6)
> Created attachment 124888 [details]
> offending registrymodifications that kill spell check

Doesn't kill spell check for me, though.

64-bit, KDE Plasma 5
Build ID: 5.1.2.2 Arch Linux build-1
CPU Threads: 8; OS Version: Linux 4.5; UI Render: default; 
Locale: fi-FI (fi_FI.UTF-8)
Comment 8 Todd 2016-05-08 04:34:44 UTC
(In reply to Buovjaga from comment #7)
> (In reply to Todd from comment #6)
> > Created attachment 124888 [details]
> > offending registrymodifications that kill spell check
> 
> Doesn't kill spell check for me, though.
> 
> 64-bit, KDE Plasma 5
> Build ID: 5.1.2.2 Arch Linux build-1
> CPU Threads: 8; OS Version: Linux 4.5; UI Render: default; 
> Locale: fi-FI (fi_FI.UTF-8)

Since your's works, would there be any tests you'd like me to run on mine?
Comment 9 Buovjaga 2016-05-08 08:36:49 UTC
(In reply to Todd from comment #8)
> Since your's works, would there be any tests you'd like me to run on mine?

I can't think of anything.
Comment 10 Todd 2016-05-08 09:11:12 UTC
(In reply to Buovjaga from comment #9)
> (In reply to Todd from comment #8)
> > Since your's works, would there be any tests you'd like me to run on mine?
> 
> I can't think of anything.

Were you guys able to do a visual inspection of the file to see if anything was out of place?
Comment 11 Buovjaga 2016-05-08 10:04:20 UTC
(In reply to Todd from comment #10)
> Were you guys able to do a visual inspection of the file to see if anything
> was out of place?

I hope some other guys can.
Comment 12 Todd 2016-05-27 19:03:16 UTC
It did it again on 

LibreOffice_5.1.3_Linux_x86-64_rpm.tar.gz

Ggggrrrrr !!!!
Comment 13 Todd 2016-07-27 04:23:19 UTC
And AGAIN on 

LibreOffice_5.1.4_Linux_x86-64_rpm.tar.gz

Please fix this before I go out of my mind!
Comment 14 Todd 2016-08-03 19:47:40 UTC
Seems to be fixed in LibreOffice_5.2.0_Linux_x86-64_rpm.tar.gz

But then again, I had only deleted registrymodifications.xcu a week ago

Did you guys work on this?
Comment 15 Buovjaga 2016-08-03 20:36:33 UTC
(In reply to Todd from comment #14)
> Did you guys work on this?

I checked on the dev IRC channel about one fix I suspected, but was told it is not related to this.

I guess we could set this to WFM and if it comes back, change to unconfirmed again.
Comment 16 Todd 2016-08-03 20:53:13 UTC
oops.. Not resolved.

I was STUNG by bug 38171, which you guys are dragging your feet on fixing.  mumble, mumble, mumble

I now have TWO installations of LO: 5.1 and 5.2.

I did realize I was testing a version that had not changed.

I will let you know if this is fixed after scrubbing out 5.1 and updating all my launchers.   mumble, mumble, mumble
Comment 17 Todd 2016-08-05 01:06:41 UTC
(In reply to Todd from comment #16)
> oops.. Not resolved.
> 
> I was STUNG by bug 38171, which you guys are dragging your feet on fixing. 
> mumble, mumble, mumble
> 
> I now have TWO installations of LO: 5.1 and 5.2.
> 
> I did realize I was testing a version that had not changed.
> 
> I will let you know if this is fixed after scrubbing out 5.1 and updating
> all my launchers.   mumble, mumble, mumble


Okay, everything is now on 5.2.0.4.  The issue does not occur.

Do not close this issue until we verify that it is no longer a problem when 5.2.1 hits
Comment 18 Aron Budea 2016-11-24 05:46:33 UTC
Have you verified with 5.2.1/5.2.2/5.2.3?
Comment 19 QA Administrators 2017-05-31 10:50:42 UTC Comment hidden (obsolete)
Comment 20 Todd 2017-05-31 21:34:24 UTC
unable to reproduce on 5.3.3.2
Comment 21 Buovjaga 2017-06-01 07:52:46 UTC
(In reply to Todd from comment #20)
> unable to reproduce on 5.3.3.2

Thanks, let's close.