Bug 99493 - TRACK CHANGES: 'Record Changes' shortcut should be defined at module level
Summary: TRACK CHANGES: 'Record Changes' shortcut should be defined at module level
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.7.2 release
Hardware: All All
: medium normal
Assignee: Yousuf Philips (jay)
URL:
Whiteboard: target:5.4.0
Keywords:
Depends on:
Blocks: Track-Changes Shortcuts-Accelerators Customize-Dialog
  Show dependency treegraph
 
Reported: 2016-04-25 10:22 UTC by Wolfgang Jäger
Modified: 2017-04-18 21:36 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Where Ctrl+Shift+E is in Customize. (26.49 KB, image/png)
2016-04-25 12:02 UTC, m.a.riosv
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Wolfgang Jäger 2016-04-25 10:22:18 UTC
See Summary!
I tested on Win 10 with 

V4.4.7: showed the issue.
V5.1.2: showed the issue in the same way.

V4.2.8: did not show the issue (Menu items also captured differently as compared with more recent versions.)

Calc is not afflicted. (No default shortcut insofar.) 

(I was bumped to check the issue by this askbot thread: https://ask.libreoffice.org/en/question/68776/libreoffice-ticket-procedures/ . In fact activation of features via shortcuts by accident is sometimes an annoying experience. A user may rightfully expect to be able to abandon a shortcut setting. If not listed at all it cannot be deleted. I did not investigate possible workarounds.)
Comment 1 m.a.riosv 2016-04-25 12:02:35 UTC
Created attachment 124626 [details]
Where Ctrl+Shift+E is in Customize.

Hi Wolfgang, thanks for reporting.

It is in customize, but you need to select [LibreOffice],
please see attached screenshot.

Resolved as not a bug, please if you are not agree, reopenit.
Comment 2 Wolfgang Jäger 2016-04-25 12:58:04 UTC
(In reply to m.a.riosv from comment #1)
> ...
> It is in customize, but you need to select [LibreOffice],
> ...
> 
> Resolved as not a bug, please if you are not agree, reopenit.

The feature itself and also its activation/toggling are handled differently for Writer and for Calc. 

For Writer the Shortcut is working by default, for Calc it is not. 

Thus to list the shortcut for 'LibreOffice' is a bug.
To NOT list it for Writer is another (related) bug IMO.

I will reopen the bug therefore resetting it to UNCONFIRMED. 

Again: No "flamewar" intended. If someone will set the bug RESOLVED again I will keep silent.
Comment 3 m.a.riosv 2016-04-25 15:36:01 UTC
The issue is that for calc it's not properly established, and when customizing for calc as edit/Record changes, change the state going to customize from writer.

But in any case it is delectable.

So for me the bug here is that it should be set up by default for every app not for LibreOffice.

Please adapt the title.
Comment 4 Wolfgang Jäger 2016-04-26 20:37:17 UTC
Sorry! I feel lost now.  

To avoid getting into the next discussion about the ifs and hows, used the 'Tools' > 'Customize...' dialog to delet the one assignment of the shortcut Ctrl+Shift+E: 'Record Changes' FOR LibreOffice, not just for Writer. 
Thee setting seemed to be successfully deleted, but is still active in Writer, and shown as the shortcut under 'Edit' > 'Track Changes' > 'Record Changes'. It is still not shown as assigned in the above mentioed dialog for Writer. (Also not for Calc; unchanged).
Assigning the shortcut to another action ('Edit Macros' e.g.) overlayed the working of Ctrl+Shift+E as 'Record Changes' which was nonetheless still shown for the menu item. Deleting this assignment again led back to Ctrl+Shift+E for 'Record Changes'. 

Further experiments showed me e.g. that Ctrl+Sift+V, assigned to 'Paste Special...' also is behaving erroneous: 
It IS shown among the asignments for Writer in 'Customize'. (Also for Calc, NOT for LibreOffice)
If deleted there it is still active.
If deleted there it is still shown as the shortcut for the menu item >Edit' > 'Paste Special...' 
If assigned to another action the assignment is accepted and working while 'Edit' > 'Paste Special...' still is showing it as the shortcut to use. 

There obvious is no clear concept and no specification concerning the relations of shortcuts, menu captures, actions and the 'Custimize' tool. Somebody did just something to some effect most likely nobody wanted. 

I have to give in. I cannot find a reasonanble title nor a reasonable description of the issue. Writing "It's a mess" or "Concept missing" won't lead us anywhere. Just feel kind of unhappy having wasted some hours with the issue here and in the related askbot thread. 
Ciao. 
May somebody mark the bug RESOLVED WONTFIX, please.
Comment 5 m.a.riosv 2016-04-26 21:27:26 UTC
Don't worry, and thanks for the effort, please let the bug as new. Maybe somebody could take it.:)
Comment 6 Yousuf Philips (jay) 2017-04-16 17:00:57 UTC
Submitted patch for the issue.

https://gerrit.libreoffice.org/36583
Comment 7 Commit Notification 2017-04-18 21:36:37 UTC
Yousuf Philips committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=4105862b03b78ff5d80d5e1f5a48f15015f79d3c

tdf#99493 Set record changes shortcut at module level

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.