Bug 99557 - TOOLBAR: Paste special drop down gets removed after clipboard cleared
Summary: TOOLBAR: Paste special drop down gets removed after clipboard cleared
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-04-28 17:21 UTC by Yousuf Philips (jay) (retired)
Modified: 2018-11-06 20:32 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2016-04-28 17:21:57 UTC
Steps:
1) open calc and notice the paste special drop down button is available
2) type 'abc' in a1
3) copy a1
4) move cursor to b1 and press enter
5) clipboard is cleared and paste button is dimmed and paste special drop down button is missing

Not inherited from OOo as it didnt have this paste method by pressing enter.

Version: 5.2.0.0.alpha0+
Build ID: b19ac3c4c6b4a41a1f3acac68b299fd676428a87
CPU Threads: 2; OS Version: Linux 4.2; UI Render: default; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2016-04-21_08:41:08
Locale: en-US (en_US.UTF-8)
Comment 1 Julien Nabet 2016-04-29 10:04:48 UTC
It seems the state of Paste special is retained when you close LO.
I explain:
with master sources updated today + brand new profile, if I launch Calc, Paste special is disabled.

If I type 'abc' in A1 and copy this cell => Paste special is enabled (as expected)
Now, I close LO and relaunch Calc, "Paste special" is enabled.

So perhaps, it's rather this behavior which is unexpected.
Comment 2 Maxim Monastirsky 2016-05-02 09:10:50 UTC
Same root cause as Bug 98335.
Comment 3 QA Administrators 2017-05-22 13:39:00 UTC Comment hidden (obsolete)
Comment 4 Thomas Lendo 2018-11-06 20:32:11 UTC
Can't reproduce with 

Version: 6.2.0.0.alpha1+
Build ID: fff34169fa912ad5096f1652172ea2455e5cb4d3
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: de-DE (de_DE.UTF-8); Calc: threaded

Therefore I set this issue to RESOLVED WORKSFORME.

If you still see this problem, please reopen as NEW.