Bug 99604 - Draw: Modify --> Convert --> "To curve" or "To contour" does not work properly
Summary: Draw: Modify --> Convert --> "To curve" or "To contour" does not work properly
Status: RESOLVED DUPLICATE of bug 96450
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
5.1.2.2 release
Hardware: x86-64 (AMD64) Mac OS X (All)
: medium minor
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-05-01 12:09 UTC by Sergio
Modified: 2017-08-27 19:09 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
LibreDraw produce incorrect text-to-curve results (42.17 KB, image/png)
2016-05-01 12:17 UTC, Sergio
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sergio 2016-05-01 12:09:43 UTC
User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10_11_4) AppleWebKit/601.5.17 (KHTML, like Gecko) Version/9.1 Safari/601.5.17
Build Identifier: LibreOffice 5.1.2.2

When I try to modify text box in LibreDraw (Modify --> Convert --> "To curve" or "To contour") I get broken text with bad size and position.

Reproducible: Always

Steps to Reproduce:
1.Type any text with spaces between words. Select this box.
2.Then modify the selected text with command "Modify"-->"Convert"-->"To curve" (or "To contour"
3.Get broken text in screen
Actual Results:  
the letters are small and narrow

Expected Results:  
The same text as I typed, but converted in curves

[Information automatically included from LibreOffice]
Locale: en-US
Module: DrawingDocument
[Information guessed from browser]
OS: Mac OS X (El Captain)
OS is 64bit: yes


Reset User Profile?Yes
Comment 1 Sergio 2016-05-01 12:17:19 UTC
Created attachment 124760 [details]
LibreDraw produce incorrect text-to-curve results
Comment 2 Buovjaga 2016-05-06 13:44:23 UTC
OS X -only. Could not reproduce on Linux.

Version: 5.1.2.2
Build ID: d3bf12ecb743fc0d20e0be0c58ca359301eb705f
CPU Threads: 4; OS Version: Mac OS X 10.11.4; UI Render: default; 
Locale: en-US (en.UTF-8)
Comment 3 QA Administrators 2017-05-22 13:40:40 UTC Comment hidden (obsolete)
Comment 4 eisa01 2017-08-27 19:09:26 UTC
Works for me in latest release. Very likely the same underlying issue as bug 96450

Version: 5.4.0.3
Build ID: 7556cbc6811c9d992f4064ab9287069087d7f62c
CPU threads: 2; OS: Mac OS X 10.12.6; UI render: default; 
Locale: en-US (en_US.UTF-8); Calc: group

*** This bug has been marked as a duplicate of bug 96450 ***