Download it now!
Bug 99626 - Crash a LibreOffice when close main window with Wizard dialog
Summary: Crash a LibreOffice when close main window with Wizard dialog
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.2.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:5.3.0 target:5.2.3 target:5.1.6
Keywords:
Depends on:
Blocks:
 
Reported: 2016-05-02 11:49 UTC by baffclan
Modified: 2017-02-16 15:25 UTC (History)
1 user (show)

See Also:
Crash report or crash signature: ["SwModule::GetRedlineMarkPos()", "_RtlUserThreadStart"]


Attachments
Backtrace? (3.17 KB, text/plain)
2016-05-03 05:52 UTC, baffclan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description baffclan 2016-05-02 11:49:33 UTC
Steps to Reproduce:
1. Start LibreOffice
2. File -> Wizards -> Letter...
3. appear Letter Wizard dialog
4. Click [X] in Title bar on LibreOffice main window
5. Nothing happened
6. Click [X] in Title bar on LibreOffice main window, again
7. LibreOffice has crashed


Windows 7 Pro(x64)

Version: 5.1.3.1 (x64)
Build ID: 115e0e13d3c8ac1452186ad2394abce2dd5c2b57
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
Locale: en-US (ja_JP)

Version: 5.2.0.0.alpha0+ (x64)
Build ID: e8425c48102321d4f5a8bd687c8ca1ac7bae797e
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86_64@62-TDF, Branch:MASTER, Time: 2016-04-20_16:47:56
Locale: ja-JP (ja_JP)
Comment 1 Julien Nabet 2016-05-02 21:36:09 UTC
On pc Debian x86-64 with master sources updated today, I don't reproduce this (nor with LO Debian package 5.1.2)
Comment 2 baffclan 2016-05-03 05:52:02 UTC
Created attachment 124807 [details]
Backtrace?

Steps to Reproduce(2):
1. Start LibreOffice
2. Create Writer Document
3. And type "0123" in Writer
4. File -> Wizards -> Letter...
5. Appear Letter Wizard dialog
6. Click [X] in Title bar on LibreOffice main window
7. Appear "Save Document?" Dialog, Click a [Don't Save]
8. Click [X] in Title bar on LibreOffice main window, again
7. LibreOffice has close
   (crash?)
8. Start LibreOffice
9. Appear "Document Recovery" Dialog
Comment 3 baffclan 2016-05-04 11:53:31 UTC

*** This bug has been marked as a duplicate of bug 99464 ***
Comment 4 Caolán McNamara 2016-05-11 20:18:54 UTC
I think this is not quite the same as 99464. Its the same sort of problem, but I think for a different reason, perhaps the python-ization of the letter wizard changed who the parent of the letter wizard is or something of that nature.
Comment 5 baffclan 2016-05-27 11:02:38 UTC
(In reply to Caolán McNamara from comment #4)
> I think this is not quite the same as 99464.
Reproduce with Newest Master.
It is not Dup of bug 99464.

Windows 7 Pro(x64)
Version: 5.3.0.0.alpha0+ (x64)
Build ID: e10a4c1cc9f8b2033997c7f032255071aafab9c9
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86_64@62-TDF, Branch:MASTER, Time: 2016-05-27_00:12:19
Locale: ja-JP (ja_JP)
Comment 6 baffclan 2016-06-27 09:58:55 UTC
http://crashreport.libreoffice.org/stats/crash_details/7fc9eaa3-847a-404e-ad87-495ee16fd8c7
["SwModule::GetRedlineMarkPos()"]

OS: Windows 7 Pro(x64)
Version: 5.2.0.1 (x64)
Build ID: fcbcb4963bda8633ba72bd2108ca1e802aad557d
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
Locale: ja-JP (ja_JP)


http://crashreport.libreoffice.org/stats/crash_details/900579c3-cae7-4029-9f20-900baa41d473
["_RtlUserThreadStart"]

OS: Windows 10(x86)
Version: 5.2.0.1
Build ID: fcbcb4963bda8633ba72bd2108ca1e802aad557d
CPU Threads: 4; OS Version: Windows 6.2; UI Render: GL;
Locale: ja-JP (ja_JP)
Comment 7 Commit Notification 2016-09-23 12:15:38 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=01889962cab8449e1d9682d22db0f6e1e28252fd

Resolves: tdf#99626 only the first queryTermination call in wizards works

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2016-09-23 13:50:24 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-5-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=557404178d4327395212485e65a224d47a3c7dc1&h=libreoffice-5-2

Resolves: tdf#99626 only the first queryTermination call in wizards works

It will be available in 5.2.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2016-09-23 14:53:38 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-5-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a498e734f0954f401f430fd04c38e16ec7072489&h=libreoffice-5-1

Resolves: tdf#99626 only the first queryTermination call in wizards works

It will be available in 5.1.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 baffclan 2016-10-23 07:52:39 UTC
Cannot reproduce with LibO 5.3.0.0.alpha1(x64)
Thanks for Fixing this.

Version: 5.3.0.0.alpha1 (x64)
Build ID: f4ca1573fcf445164c068c1046ab5d084e1b005f
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; 
Locale: ja-JP (ja_JP); Calc: group