Bug Hunting Session
Bug 99627 - Calc freezes when applying natural sorting on text columns
Summary: Calc freezes when applying natural sorting on text columns
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.1.2.2 release
Hardware: x86-64 (AMD64) Linux (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard: target:6.1.0
Keywords: haveBacktrace, perf, regression
Depends on:
Blocks:
 
Reported: 2016-05-02 11:52 UTC by Crecida Müller
Modified: 2018-05-06 05:36 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Test file (102.86 KB, application/vnd.oasis.opendocument.spreadsheet)
2016-05-03 13:35 UTC, Crecida Müller
Details
what menu shows to me (167.93 KB, image/jpeg)
2016-05-03 17:16 UTC, Crecida Müller
Details
what calc menu shows to me (187.07 KB, image/jpeg)
2016-05-03 17:17 UTC, Crecida Müller
Details
new list issued originally in calc by me (16.76 KB, application/vnd.oasis.opendocument.spreadsheet)
2016-05-03 17:18 UTC, Crecida Müller
Details
This is what About LO shows (135.75 KB, image/jpeg)
2016-05-03 18:20 UTC, Crecida Müller
Details
GDB trace of freeze (13.52 KB, text/plain)
2016-05-07 12:03 UTC, Buovjaga
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Crecida Müller 2016-05-02 11:52:31 UTC
This is the first time, I'm placing a bug report, therefore I ask for kind understanding.

I've tried multiple ways - sorting of text columns works with applying column title included and formats included - the output seems to be correctly sorted.

As soon as I apply "activate natural sorting", calc freezes and has to be interrupted.

Sorting only over columns containing numbers is working correctly, even with all
3 options ticked.

I noticed this behaviour with .ods .xls and .csv files.

This problem occurs since having upgraded Ubuntu 15.10 to 16.04. The LO version installed in 15.10 was 5.0.5.2, which worked just fine.

I cannot attach the lists since they contain sensible data.
Comment 1 Cor Nouws 2016-05-03 11:57:37 UTC
Hi Crecida,

Thanks for reporting.
I cannot reproduce a freeze when using 'natural sorting'.
Not in 5,1,2,1 and not in a recent daily build.

This on 32 bits Ubuntu with OpenGL (Tools > Options > LibreOffice > View) disabled

Do you have a test file please?
Comment 2 Crecida Müller 2016-05-03 13:35:07 UTC
Created attachment 124815 [details]
Test file

Hi cno,
I've overwritten personal details.
What is OpenGL? Am I right that this is corresponding to OpenCL?
I've tested with OpenCL activated and not activated - with the same result - freezing.
Then I replaced the personal data by test data - with the same result - freezing.
The original list included 3000 rows, I took out 2900 rows - to my astonishment
now sorting went fine.
Afterwards I put in the 2900 rows again (current state of the test file) and
it froze again.

I hope, I could be of help. Sorry, but I'm only working with Calc and have no
background knowledge of software - but I will try to help as best as I can.
Comment 3 Cor Nouws 2016-05-03 14:18:09 UTC
Thanks for the test file.
It does not freeze for me.

OpenGL is here: Tools > Options > LibreOffice > View .. Use OpenGL for ..
Comment 4 Crecida Müller 2016-05-03 17:16:24 UTC
Created attachment 124822 [details]
what menu shows to me
Comment 5 Crecida Müller 2016-05-03 17:17:39 UTC
Created attachment 124823 [details]
what calc menu shows to me
Comment 6 Crecida Müller 2016-05-03 17:18:55 UTC
Created attachment 124824 [details]
new list issued originally in calc by me
Comment 7 Crecida Müller 2016-05-03 17:27:45 UTC
Hi cno,

once again, what I found out now, is that with the first list (originally an xls from other person) I can sort text columns even with natural sort, but as soon as I want to sort with the column "Artikelbezeichnung" calc freezes. I tried to cut out the column and put it at the end, sorted again, freezing. I copied the column into meld and diffuse but could not see anything suspicious.

Therefore I thought I take another list which I myself issued on my system (which I attached "new list"). If I try to sort with column A, freezing.

So, I'm really at a loss.

As to the OpenGl I've attached my "menus" as they are shown to me (I've changed to US-English interface) - but obviously my interface is structured different from yours.

Do you have any slight idea where this odd behaviour could derive from?

Sorry for bothering you!
Comment 8 Cor Nouws 2016-05-03 17:50:53 UTC
(In reply to Crecida Müller from comment #5)
> Created attachment 124822 [details]
> what menu shows to me

What does Help > About LibreOffice say ?
(In reply to Crecida Müller from comment #4)


(In reply to Crecida Müller from comment #7)

> as soon as I want to sort with the column "Artikelbezeichnung" calc freezes.

I tested that column..
Comment 9 Crecida Müller 2016-05-03 18:20:59 UTC
Created attachment 124826 [details]
This is what About LO shows

Hi cno,
that's what LO Help License is saying.

I made one further try and replaced whitespace with _ - however still freezing.

At the moment I'm running out of further ideas what I could test.

With regard to OpenGL resp. OpenCL my system uses OpenCL - I've searched in Wikipedia about the meaning.

Thank you for your help.
Comment 10 Cor Nouws 2016-05-03 18:36:14 UTC
(In reply to Crecida Müller from comment #9)
> Created attachment 124826 [details]
> This is what About LO shows
> 
> Hi cno,
> that's what LO Help License is saying.

thanks. It's the Ubuntu version of LibreOffice.
That could explain why we cannot reproduce.

If you have some time, you can try a parallel installation of a default LibreOffice:
  http://www.libreoffice.org/download/
  https://wiki.documentfoundation.org/Installing_in_parallel

> At the moment I'm running out of further ideas what I could test.

clean userprofile?
https://wiki.documentfoundation.org/UserProfile

> With regard to OpenGL resp. OpenCL my system uses OpenCL - I've searched in
> Wikipedia about the meaning.

Oh good!
 
> Thank you for your help.

You're welcome!
Comment 11 Crecida Müller 2016-05-03 19:24:04 UTC
Hi Cor (sorry I only detected now what your name is),

okay, I will give it a try and install from the source indicated and look whether this will solve the problem (after having checked my user profile).

I really do appreciate your kind assistance!
Comment 12 Crecida Müller 2016-05-03 19:46:56 UTC
Just for short info:

I just controlled my user profile like indicated in the link you gave me.

I found no corruption because with the brand-new profile both lists freeze again.

At least this option can be excluded. Then I'll do in a virtual box a fresh install from the source indicated in the other link. And see what will happen then.
Comment 13 Crecida Müller 2016-05-04 07:32:53 UTC
Good morning, Cor,

so, now I've done what you proposed. In a virtual box I first purged libreoffice*, afterwards I downloaded from the link you gave me and installed it. 
So, I did not change anything from the options.
I run the 2 lists once again and both times they froze.
Could it be that the problem really lies in the 64-bit version, since you have 32bit?
Comment 14 Buovjaga 2016-05-07 12:03:05 UTC
Created attachment 124893 [details]
GDB trace of freeze

(In reply to Crecida Müller from comment #6)
> Created attachment 124824 [details]
> new list issued originally in calc by me

I get a freeze when sorting with column A and having activated Enable natural sorting in the sort dialog "options" tab.

64-bit, KDE Plasma 5
Build ID: 5.1.2.2 Arch Linux build-1
CPU Threads: 8; OS Version: Linux 4.5; UI Render: default; 
Locale: fi-FI (fi_FI.UTF-8)
Comment 15 Cor Nouws 2016-05-07 20:28:56 UTC
Hi Crecida and Buovjaga,

Thanks for testing this. Indeed 64 bits..
Comment 16 raal 2016-05-12 07:35:26 UTC
(In reply to Crecida Müller from comment #0)
> This problem occurs since having upgraded Ubuntu 15.10 to 16.04. The LO
> version installed in 15.10 was 5.0.5.2, which worked just fine.
> 
regression
Comment 17 Aron Budea 2016-05-12 10:30:41 UTC
Bug 99773 is likely the same issue. As I mentioned there, I tested with release candidate 5.1.3.2 now. Issue is not reproducible.
Please use this, or the final 5.1.3 version when it's released.

I'm going to wait a bit for feedback from Crecida before closing this bug report.
Comment 18 Crecida Müller 2016-05-12 11:29:50 UTC
(In reply to Aron Budea from comment #17)
> Bug 99773 is likely the same issue. As I mentioned there, I tested with
> release candidate 5.1.3.2 now. Issue is not reproducible.
> Please use this, or the final 5.1.3 version when it's released.
> 
> I'm going to wait a bit for feedback from Crecida before closing this bug
> report.

Okay I will install the 5.1.3.2 in a virtual box and look whether the problem will occur again. However, at the moment I do not have the time, perhaps this evening.
It would also be a good idea to let buovjaga also try the same, wouldn't it?

But, only curious, do you have the 64bit version and linux?
Comment 19 Buovjaga 2016-05-12 11:31:20 UTC
(In reply to Crecida Müller from comment #18)
> Okay I will install the 5.1.3.2 in a virtual box and look whether the
> problem will occur again. However, at the moment I do not have the time,
> perhaps this evening.

Virtualbox is not needed: https://wiki.documentfoundation.org/Installing_in_parallel/Linux
Comment 20 Crecida Müller 2016-05-12 11:34:58 UTC
I know, that it's not needed, but I already have installed a virtual box for testing purposes - so I prefer it that way.
Comment 21 Aron Budea 2016-05-12 13:56:18 UTC
(In reply to Crecida Müller from comment #18)
> But, only curious, do you have the 64bit version and linux?

I tried in Windows and in Linux, in this case, both LO builds were 64-bit.
Also, 5.1.3 is now released.
Comment 22 Crecida Müller 2016-05-12 14:07:32 UTC
In fact, already installed, and what should I say - no freezing - simply wonderful. Everything's fine again and therefore

many, many thanks to all developers and helpers for this premium class software!!!
Comment 23 Aron Budea 2016-05-12 14:19:34 UTC
I'm glad to hear the issue is gone for you as well.
Closing the bug report.
Comment 24 Commit Notification 2018-05-06 05:36:50 UTC
Zdeněk Crhonek committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=6898da014b1db1f5b8d4a21af204b04cc7915a92

uitest for bug tdf#99627

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.