Bug Hunting Session
Bug 99651 - PRINTING - text in an embedded EMF not printed/exported to PDF correctly
Summary: PRINTING - text in an embedded EMF not printed/exported to PDF correctly
Status: RESOLVED DUPLICATE of bug 104252
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
4.0.2.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: preBibisect, regression
Depends on:
Blocks: EMF-WMF
  Show dependency treegraph
 
Reported: 2016-05-03 14:55 UTC by bureautiquelibre
Modified: 2017-06-14 06:12 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
ODP file with embedded table (174.88 KB, application/vnd.oasis.opendocument.presentation)
2016-05-03 14:55 UTC, bureautiquelibre
Details
Result when performing PDF export, print gives the same result. (145.50 KB, application/pdf)
2016-05-03 14:57 UTC, bureautiquelibre
Details
PDF export with a tiny difference (top of the text in next row is visible) (144.81 KB, application/pdf)
2016-05-07 15:54 UTC, Aron Budea
Details
pdf export in daily 20161111 on Linux 64 bits (429.68 KB, application/pdf)
2016-11-12 07:38 UTC, Cor Nouws
Details

Note You need to log in before you can comment on or make changes to this bug.
Description bureautiquelibre 2016-05-03 14:55:29 UTC
Created attachment 124817 [details]
ODP file with embedded table

The embedded image is displayed OK but text in the table doesn't print properly.

See example document.

Might be a duplicate of bug #77525 (https://bugs.documentfoundation.org/show_bug.cgi?id=77525) but I can't tell that for sure.
Comment 1 bureautiquelibre 2016-05-03 14:57:06 UTC
Created attachment 124818 [details]
Result when performing PDF export, print gives the same result.
Comment 2 Buovjaga 2016-05-07 11:44:39 UTC
I don't get the problem with 5.1.2, but I guess you Nantes folks want to stick with 5.0.x for a while..

64-bit, KDE Plasma 5
Build ID: 5.1.2.2 Arch Linux build-1
CPU Threads: 8; OS Version: Linux 4.5; UI Render: default; 
Locale: fi-FI (fi_FI.UTF-8)
Comment 3 Aron Budea 2016-05-07 15:54:38 UTC
Created attachment 124896 [details]
PDF export with a tiny difference (top of the text in next row is visible)

Reproduced with 5.0.5.2, 5.0.6.3 and master builds (all 32-bit) on Windows 7. 

Exported to PDF with default settings.
Result looks almost the same as the one attached by the reporter, except the top of the text in the next row is visible, too.
Comment 4 Aron Budea 2016-05-07 16:08:43 UTC
It's a regression, works in 4.0.0.3, but broken in 4.1.0.4.
Comment 5 Aron Budea 2016-05-09 11:59:28 UTC
Checked 4.0.x versions, works in 4.0.1.2, but (really) broken in 4.0.2.2.
Comment 6 Xisco Faulí 2016-09-13 14:31:30 UTC
As per today, this regression can't be bibisected as it was introduced before 4.4 branch and there's no bibisect repository for the affected branch, thus change 'bibisectRequest' to 'preBibisect'
Comment 7 Cor Nouws 2016-11-12 07:38:12 UTC
Created attachment 128684 [details]
pdf export in daily 20161111 on Linux 64 bits

Hi,

Is this windows only?
The attached PDF is OK.
Created in Version: 5.3.0.0.alpha1+
Build ID: 0af30952982767543cddd0b1ce643cb8d5c253a2
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk2; Layout Engine: new; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2016-11-11_23:43:27
Locale: nl-NL (nl_NL.UTF-8); Calc: group

maybe you can test a daily master too?
Comment 8 Aron Budea 2016-11-12 19:32:04 UTC
Yes, it's Windows only, and the embedded object is an EMF file.
Good idea, I tested in the below 5.3 daily build, and the issue is gone, text appears correctly in exported PDF (same with old layout engine, so not related to common layout).

Issue is still there in 5.2.3.3. => setting to WORKSFORME, adding bibisectRequest to reverse bibisect in Windows.

Version: 5.3.0.0.alpha1+
Build ID: 0d6f974b97597744119db9dc3d193aeeb8f9d3fa
CPU Threads: 4; OS Version: Windows 6.1; UI Render: GL; Layout Engine: old; 
TinderBox: Win-x86@39, Branch:master, Time: 2016-11-11_23:56:36
Locale: hu-HU (hu_HU); Calc: CL
Comment 9 Terrence Enger 2016-11-17 16:21:13 UTC
Working on Windows Vista in bibisect-win32-5.3, I see that commit
2ea0f9e2 (s-h 44523738, dated 2016-11-04 17:45:25) still truncates
text in the output .pdf.  Later commits exhibit tdf#103989, "FILEOPEN:
crash with .odt attached to tdf#99651".

Perhaps, somebody with a different setup will have more success
reverse bibisecting this bug.
Comment 10 Aron Budea 2016-11-17 19:51:39 UTC
I have to correct myself, it's exported correctly if OpenGL is enabled, but still not if it's disabled (and the behavior in 5.3 is the same as in 5.2). Back to NEW. Thanks for checking!
Comment 11 V Stuart Foote 2016-12-31 17:36:19 UTC

*** This bug has been marked as a duplicate of bug 104252 ***