Bug Hunting Session
Bug 99667 - Can not open files on network - solved with libreoffice-gnome
Summary: Can not open files on network - solved with libreoffice-gnome
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.1.2.2 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Network
  Show dependency treegraph
 
Reported: 2016-05-04 08:37 UTC by LucHey
Modified: 2017-08-24 15:07 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Print-screen of main packages LO.png (104.89 KB, image/png)
2016-05-04 19:07 UTC, LucHey
Details

Note You need to log in before you can comment on or make changes to this bug.
Description LucHey 2016-05-04 08:37:09 UTC

    
Comment 1 LucHey 2016-05-04 08:51:17 UTC
With LibreOffice 5.1.2.2 running under Ubuntu Linux or derivates, i can not open and edit .odt, ods and .odg files that are stored on the home network. 
With the previous LibreOffice versions 4.x and older this was never a problem.
The problem occurred when i switched to the newer Ubuntu 16.4 and Ubuntu Mate 16.4 who are both shipped with LO 5.x.
The behaviour is: after a double click on a file, very short is the start-screen LibreOffice 5 visible, than it goes away and noting happens.
To edit files that are stored on network drive / usb stick attached on the router i have to drag and drop these to the desktop and vise-versa. That is very annoying..

LucHey
Comment 2 MM 2016-05-04 15:43:41 UTC
Somehow ubuntu 16.04 doesn't ship with the full LO package. So you might wanna try installing that, manually, and see if it solves your problem.
Comment 3 LucHey 2016-05-04 19:07:06 UTC
Created attachment 124846 [details]
Print-screen of main packages LO.png
Comment 4 LucHey 2016-05-04 19:09:28 UTC
Witch package do i need ?
Comment 5 Maxim Monastirsky 2016-05-04 19:47:39 UTC
What do you mean by "stored on the home network"? Is it smb, ftp, something else? Does it work with other apps, just not with LO?

Anyway, I can't reproduce with Ubuntu 16.04 with smb share. Double click in Files works just fine here.

(In reply to LucHey from comment #4)
> Witch package do i need ?
At least for smb, you need libreoffice-gnome (that you already have) + make sure you have gvfs packages properly installed.
Comment 6 LucHey 2016-05-04 19:58:26 UTC
Al other files have no problems to open and edit on the network, it is just LO files that have this behaviour. I have this problem too on Ubuntu Mate 16.04.
Smb of ftp, hmmm, not sure, i just mount a network drive in the file manager and than i can access al the files ...
Comment 7 LucHey 2016-05-04 20:06:25 UTC
Yes, it is smb, with properties i see this path:
smb://b-box%203/disk_a1/
Comment 8 LucHey 2016-05-07 14:18:30 UTC
So, i sorted it out and the problem occurs only when i try to open LO files that are stored on an usb stick that connected to my Bbox3 modem/router.
The LO files that are stored on an HDD connected to the FritzBox are no problem.
So i transferred al the necessary files to the HDD. and use the usb stick as backup.
Why is worked well with LO 4.x stays a mystery to me...something to do with rights ? Why all the rest works fine and i can edit all files except LO files ?
Case close for me, i'll wait for a fix...
Comment 9 doubtful500 2016-10-21 15:58:21 UTC
I do not know if this will fix this particular issue, but with Ubuntu 16.04 and LibreOffice 5.1.4.2 I had to make sure these two packages were installed in order to open files on a Samba share mounted via gvfs.

$ sudo aptitude install libreoffice-gnome gvfs-backend
Comment 10 Don Haire 2016-10-23 18:25:32 UTC
With "Ubuntu 16.04.1 LTS" and LibreOffice Version: 5.1.4.2 Build ID: 1:5.1.4-0ubuntu1, I have this same problem.  The files on networked storage are visible in the LibreOffice file dialogs, but attempts to open them produce no results (no file opened and no error message seen).  Accessing the files via a file manager from the OS and attempting to open with LibreOffice from there, produces the same result.  Accessing the identical networked file from LibreOffice on a Windows7 machine works perfectly.  These files are on a Western Digital hard drive with Ethernet interface, on an Ethernet local network.  These files can be successfully opened by other applications (example, text editor) on the Ubuntu machine, showing that there is no hardware-level connectivity issue.
Comment 11 Timur 2016-10-24 17:27:04 UTC
Don Haire, did you follow Comment 5 an Comment 9?
Comment 12 Don Haire 2016-11-02 06:11:55 UTC
Responding to comment 11, my system is Xubuntu, which uses xfce instead of gnome.  Based on that, I did not follow comments 5 and 9.  On my system, the Gigolo application is used to mount the networked SMB drives as gvfs objects.
Comment 13 Don Haire 2016-12-29 23:49:12 UTC
As suggested by others, installing the package libreoffice-gnome made this work.  Thanks for the guidance.  I would have found it helpful if some educational words had been provided to explain what was missing, and what this package provided to fix it.
Comment 14 Timur 2017-08-24 15:07:23 UTC
Looks like both reporters have WorksForMe.
If you disagree, please explain.