Bug 99689 - Subscript not working in Illustration index or Index of Tables
Summary: Subscript not working in Illustration index or Index of Tables
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.1.2.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium minor
Assignee: Tamas Bunth
URL:
Whiteboard: target:6.0.0 target:5.4.3
Keywords:
Depends on:
Blocks: TableofContents-Indexes
  Show dependency treegraph
 
Reported: 2016-05-05 05:10 UTC by Mark
Modified: 2017-10-16 10:25 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Example of Subscript formatting not working in ToC (9.39 KB, application/vnd.oasis.opendocument.text)
2016-05-05 05:10 UTC, Mark
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mark 2016-05-05 05:10:59 UTC
Created attachment 124853 [details]
Example of Subscript formatting not working in ToC

Similar to Bug 30732
Using Version: 5.1.2.2 - in main Table of Contents - superscript and subscript formatting are now kept. However in Table of Figures or Table of Illustrations they are not.

Presume same issue needs same fix.
 
Example default ODT attached.
Comment 1 raal 2016-05-05 06:44:06 UTC
Hello, bug 30732 is still open. This bug is duplicate of bug 30732?
Comment 2 Mark 2016-05-05 13:02:19 UTC
well I was under the impression 30732 was "fixed" in terms of subscript / superscript.
As the current release I have has it working in the main Table of Contents.  

I raised it as another bug as the formatting does not update this formatting in the other Tables of Content as discussed.
Comment 3 Buovjaga 2016-05-07 12:48:23 UTC
Confirmed.

64-bit, KDE Plasma 5
Build ID: 5.1.2.2 Arch Linux build-1
CPU Threads: 8; OS Version: Linux 4.5; UI Render: default; 
Locale: fi-FI (fi_FI.UTF-8)
Comment 4 Mark 2016-05-08 23:48:31 UTC
May I add that I forgot to add that this also applies to the Index of Tables.
Comment 5 Commit Notification 2017-09-29 12:37:40 UTC
Tamas Bunth committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=141d4427d2d2db6a16133fcf7571798233a99cb0

tdf#99689 allow Subscript in Illustration Index...

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2017-10-07 07:10:31 UTC
Tamas Bunth committed a patch related to this issue.
It has been pushed to "libreoffice-5-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=382af3b87fabb1b5d748e6e339c3e60146dd5a6f&h=libreoffice-5-4

tdf#99689 allow Subscript in Illustration Index...

It will be available in 5.4.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2017-10-16 10:25:07 UTC
Tamas Bunth committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=1ca2a2119ad3e910f848344d51ba9ec173880715

tdf#99689 add tests for subscript attribute in ToX

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.