Bug 99701 - Calc multiline input: Multiline button very thin
Summary: Calc multiline input: Multiline button very thin
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.2.0.0.alpha1
Hardware: All All
: medium normal
Assignee: Samuel Mehrbrodt (CIB)
QA Contact:
URL:
Whiteboard: target:5.2.0
Keywords:
Depends on:
Blocks:
 
Reported: 2016-05-06 06:15 UTC by Samuel Mehrbrodt (CIB)
Modified: 2016-10-02 12:06 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Button in GTK2 (30.11 KB, image/png)
2016-05-06 06:15 UTC, Samuel Mehrbrodt (CIB)
Details
Button in GTK3 (32.71 KB, image/png)
2016-05-06 06:15 UTC, Samuel Mehrbrodt (CIB)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Samuel Mehrbrodt (CIB) 2016-05-06 06:15:44 UTC
Created attachment 124874 [details]
Button in GTK2

The button to open the calc multiline input is very thin on Ubuntu.
It was bad with GTK2, is is even worse with GTK3.
The problem is that its width depends on the scrollbar width.

Instead this button should have a fixed width.
Comment 1 Samuel Mehrbrodt (CIB) 2016-05-06 06:15:57 UTC
Created attachment 124875 [details]
Button in GTK3
Comment 2 Commit Notification 2016-05-06 09:18:29 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=23f86273068b2389fc8703a8cc6b5c77968c918d

tdf#99701 Calc multiline input: Give button a fixed width

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.