Bug 99708 - Calc Formula Bar multiline input doesn't remember state
Summary: Calc Formula Bar multiline input doesn't remember state
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.2.0.0.alpha1
Hardware: All All
: medium enhancement
Assignee: Samuel Mehrbrodt (allotropia)
URL:
Whiteboard: target:7.4.0
Keywords:
: 137685 (view as bug list)
Depends on:
Blocks: Calc-Formula-Bar
  Show dependency treegraph
 
Reported: 2016-05-06 09:53 UTC by Samuel Mehrbrodt (allotropia)
Modified: 2022-10-27 14:27 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Samuel Mehrbrodt (allotropia) 2016-05-06 09:53:18 UTC
1. Open the multiline input in calc
2. Save document & close calc
3. reopen document

The multiline input is closed again. Its state should be stored in the document (how many lines are shown in the multiline input) and restored when reopening.
Comment 1 raal 2016-05-06 11:21:46 UTC
confirm. Version: Version: 5.2.0.0.alpha1+; win7
Comment 2 m.a.riosv 2016-05-06 21:56:45 UTC
I`m not sure it's always useful.
Comment 3 V Stuart Foote 2020-10-22 18:55:38 UTC
*** Bug 137685 has been marked as a duplicate of this bug. ***
Comment 4 V Stuart Foote 2020-10-22 18:59:37 UTC
The Formula Bar will be either a single line, or can be toggled to multi-line mode with the count of lines selected by user. That line count will persist during a calc session--but on restart the default single line is reused, and the line count for multi-line is reset to its default height.
Comment 5 gnomek 2020-10-23 08:55:49 UTC
(In reply to m.a.riosv from comment #2)
> I`m not sure it's always useful.

Certainly not always. It really depends what you do with your spreadsheet. I use it to prepare text database for language learning. Formula Bar for me is just a preview of cell content. And it would really make my work a lot easier if I could have fixed line state after Calc restart. 


(In reply to Samuel Mehrbrodt (CIB) from comment #0)
> Its state should be stored in the document (how many lines are shown in the multiline input) and restored when reopening.

That is the best solution.
Comment 6 Commit Notification 2022-05-03 12:53:38 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/d0cacf09a1105d89bf3df84b18623d790e3aeb82

tdf#99708 Save formula bar height to document

It will be available in 7.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2022-05-18 20:49:35 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/33339778c83f2e2d06e302f392d3ae36ee886e8f

tdf#99708 Make sure to get the sanitized value

It will be available in 7.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Eike Rathke 2022-06-10 13:47:39 UTC
In current 7.4 when loading a document the (one line) Input Line (aka Formula Bar) height appears too small by a few pixels, but in fact is shifted down by that amount and cut at the bottom, until clicked into then it gets positioned and as tall as it should. I suspect that is related to these changes.
Comment 9 Eike Rathke 2022-09-17 16:52:14 UTC
That is bug 150664.
Comment 10 jon.goodwin97 2022-10-26 20:19:30 UTC
LibreOffice Version 7.4.2.3

Agree with Eike. The input line height is not fully displayed when opening the document despite having expanded it before saving.
It is ok on a new virgin document but shrinks after data has been entered and the document is saved.
Comment 11 Gabor Kelemen (allotropia) 2022-10-27 14:27:10 UTC
Please do not reopen bugs just because of regressions. Reopen if the original issue is still not resolved.