Bug Hunting Session
Bug 99727 - Text Disappears when printing word document
Summary: Text Disappears when printing word document
Status: RESOLVED DUPLICATE of bug 104252
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.0.5.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:emf
Depends on:
Blocks: EMF-WMF
  Show dependency treegraph
 
Reported: 2016-05-08 05:03 UTC by Chris Rossall
Modified: 2016-12-28 15:30 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
EMF table with errant fonts on printing extracted from Word document (52.18 KB, image/x-emf)
2016-05-08 16:36 UTC, V Stuart Foote
Details
DOC file for testing (34.50 KB, application/msword)
2016-11-16 17:50 UTC, Buovjaga
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Rossall 2016-05-08 05:03:09 UTC
Downloaded the document at

http://www.ifah.se/ImageVaultFiles/id_628338/cf_57129/Slaget_om_Stockholm_2016_spelschema_B2.DOC

Everything looks ok on screen but when printing, some of the text disappears, for example in the lower table.

Also tried exporting to pdf but the text disappeared in the pdf too.
Comment 1 Buovjaga 2016-05-08 15:17:30 UTC
No problem for me.

What operating system and what LibreOffice version are you using?

Set to NEEDINFO.
Change back to UNCONFIRMED after you have provided the information.

64-bit, KDE Plasma 5
Build ID: 5.1.2.2 Arch Linux build-1
CPU Threads: 8; OS Version: Linux 4.5; UI Render: default; 
Locale: fi-FI (fi_FI.UTF-8)
Comment 2 Chris Rossall 2016-05-08 15:37:14 UTC
(In reply to Buovjaga from comment #1)
> No problem for me.
> 
> What operating system and what LibreOffice version are you using?
> 
> Set to NEEDINFO.
> Change back to UNCONFIRMED after you have provided the information.
> 
> 64-bit, KDE Plasma 5
> Build ID: 5.1.2.2 Arch Linux build-1
> CPU Threads: 8; OS Version: Linux 4.5; UI Render: default; 
> Locale: fi-FI (fi_FI.UTF-8)

Windows 10 64-bit.
Libre Office
Version: 5.0.5.2 (x64)
Build ID: 55b006a02d247b5f7215fc6ea0fde844b30035b3
Locale: en-US (en_US)

I had the same problem on an earlier version too, 4. something and the problem still exists in 5.0.2.2.
Comment 3 Chris Rossall 2016-05-08 15:51:21 UTC
It appears the table in question is some kind of embedded image.
When I try and save it the type defaults to WMF - windows metafile.
Comment 4 V Stuart Foote 2016-05-08 16:36:30 UTC
Created attachment 124911 [details]
EMF table with errant fonts on printing extracted from Word document

Confirming, Windows print to PCL6 printer, export to PDF, or print to ghostscript based PDF

On Windows 10 Pro 64-bit en-US with
Version: 5.1.2.2 (x64)
Build ID: d3bf12ecb743fc0d20e0be0c58ca359301eb705f
CPU Threads: 8; OS Version: Windows 6.19; UI Render: default; 
Locale: en-US (en_US)

Issues seems to be with the embedded EMF image, it is a table that views fully in writer on import. The print preview of the document shows the table fully, but when printed (or exported to PDF) only a portion of text actually prints.

If exported from Word 2007 to ODF format--the EMF image renders well and prints in other EMF viewers (Imagamagick, Inkcape, IrfanView) 

Opening just the errant EMF into Draw (attached) it renders to canvas in Draw, but print preview and print actions have the same missing text in the table.
Comment 5 Chris Rossall 2016-05-08 17:13:47 UTC
Looking at the attached EMF file in a hex viewer, the font name "Calibri" can be seen several times (in UTF-16).

I have the Calibri font on my system so it doesn't seem to be a matter of a missing font.
Comment 6 Timur 2016-11-16 17:47:28 UTC
Doc from link not available, please attach.
Did you search before reporting? Unlikely this is not reported before. 
Did you see Bug 77525? 
Did you test with LO 5.2.1 or later?
Comment 7 Buovjaga 2016-11-16 17:50:33 UTC
Created attachment 128794 [details]
DOC file for testing
Comment 8 V Stuart Foote 2016-11-16 18:18:10 UTC
The EMF and the Word .doc file both seem to render correctly for print/export now with a current master and new layout engine.

On Windows 10 Pro 64-bit (1607) en-US with
Version: 5.3.0.0.alpha1+
Build ID: 84f644eee78106f01486098d446d9163b62927eb
CPU Threads: 8; OS Version: Windows 6.2; UI Render: GL; Layout Engine: new; 
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2016-11-15_23:52:44
Locale: en-US (en_US); Calc: CL
Comment 9 Timur 2016-11-17 07:51:27 UTC
Yes, WorksForMe, but I'll mark as a duplicate of Bug 77525.

*** This bug has been marked as a duplicate of bug 77525 ***
Comment 10 V Stuart Foote 2016-12-28 15:30:43 UTC
Workaround 

disable Tools -> Options -> View: "Use hardware acceleration" (or enable "OpenGL rendering" if system supports).


=-=-=
QA clean up of bug 77525, splitting it to bug 104252 and bug 103833

*** This bug has been marked as a duplicate of bug 104252 ***