Bug 99771 - font properties for check box ignored in print preview
Summary: font properties for check box ignored in print preview
Status: RESOLVED DUPLICATE of bug 97244
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.0.5.2 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2016-05-11 07:06 UTC by JormaJJ
Modified: 2016-05-13 12:07 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
see the difference between document and preview (421.72 KB, image/jpeg)
2016-05-11 07:06 UTC, JormaJJ
Details

Note You need to log in before you can comment on or make changes to this bug.
Description JormaJJ 2016-05-11 07:06:07 UTC
Created attachment 124966 [details]
see the difference between document and preview

When adding a checkbox in Calc for internal documentation I can change the font for that Label in the properties and those changes show in the sheet immediately. 

However, if I print that document or switch to print preview, it's just showing that label text in a huge and otherwise unformatted style.

I don't know if I'm doing something wrong in general but the font-style was working perfectly in LO4 and changed with 5.x (tried several 5.x versions up to the current release 5.1.2.2).

Attached is a screenshot showing Form properties and Print Preview.
Comment 1 Aron Budea 2016-05-11 07:44:25 UTC
Thanks for the bug report. Yes, this is a bug, and a regression.
An easier reproduction is to just add a Check Box without any changes, and the print preview will already show the label in huge size.

Reproduced in Windows 7 with 5.0.5.2 and 5.1.2.2, not reproduced with 4.4.0.1. Also reproduced in Ubuntu 15.10 with 5.0.5.2.
Comment 2 raal 2016-05-13 12:07:26 UTC
946e3a3d952ed45ff0926b767839a5d2fa7b7979 is the first bad commit
commit 946e3a3d952ed45ff0926b767839a5d2fa7b7979
Author: Norbert Thiebaud <nthiebaud@gmail.com>
Date:   Fri Oct 23 16:14:34 2015 -0700

    source sha:825b3df7f1d987021ec4a08ff8e7ed78e5772c97
	
	author	Tomaž Vajngerl <tomaz.vajngerl@collabora.com>	2015-10-22 17:03:01 (GMT)
committer	Tomaž Vajngerl <tomaz.vajngerl@collabora.com>	2015-10-22 17:16:14 (GMT)
commit	825b3df7f1d987021ec4a08ff8e7ed78e5772c97 (patch)
tree	ea377df8cb251150d9606bf1c09a2dfbb7377b62
parent	8e49a523c932936c1e38e0d26e5946619c2ed321 (diff)
tdf#94138 fix printing of edit form fields
Comment 3 raal 2016-05-13 12:07:54 UTC

*** This bug has been marked as a duplicate of bug 97244 ***