Bug Hunting Session
Bug 99773 - EDITING: calc freezes if sorting in natural mode
Summary: EDITING: calc freezes if sorting in natural mode
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.1.2.2 release
Hardware: All All
: medium major
Assignee: Not Assigned
URL:
Whiteboard: target:6.1.0
Keywords: bibisectRequest, regression
Depends on:
Blocks:
 
Reported: 2016-05-11 08:55 UTC by Paolo Benvenuto
Modified: 2018-05-06 05:38 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
document witch freezes calf if cells sorted in natural mode (8.31 KB, application/vnd.oasis.opendocument.spreadsheet)
2016-05-11 08:55 UTC, Paolo Benvenuto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Paolo Benvenuto 2016-05-11 08:55:58 UTC
Created attachment 124969 [details]
document witch freezes calf if cells sorted in natural mode

I have a document where a column has text values with numbers after letters and spaces (user case = addresses: street number, like "Alabama Av. 35").

If I select all the cell with those value and issue a natural sort, calc freezes

Attacched document triggers the bug
Comment 1 Paolo Benvenuto 2016-05-11 08:57:04 UTC
I'm quite sure the bug wasn't in v. 4
Comment 2 Aron Budea 2016-05-11 09:54:42 UTC
Reproduced in 5.1.2.2 both in Linux and Windows.
Not reproduced in 5.0.5.2 (Linux+Windows), 5.0.6.3 (Windows), and with master build (Windows).
Comment 3 Aron Budea 2016-05-11 09:59:58 UTC
Raising severity to major, since it completely freezes Calc.
Comment 4 m.a.riosv 2016-05-11 22:27:50 UTC
Not reproducible.
Win10x64
Version: 5.1.3.2 (x64)
Build ID: 644e4637d1d8544fd9f56425bd6cec110e49301b
CPU Threads: 4; OS Version: Windows 6.19; UI Render: GL;
Comment 5 raal 2016-05-12 07:16:53 UTC
No freeze with Version: 5.2.0.0.alpha1+; win7

Paolo, Aron,
seems to be fixed with dev version. Please could you test it with dev version?  You can download it here: http://dev-builds.libreoffice.org/daily/master/
Thank you
Comment 6 Crecida Müller 2016-05-12 07:30:43 UTC
Just one question, is there perhaps a relation to bug 99627?
Comment 7 Aron Budea 2016-05-12 10:22:42 UTC
(In reply to raal from comment #5)

Yes, I tested on master, and it appeared fixed, hence the regression-related tags.

(In reply to Crecida Müller from comment #6)

It very well could be the same issue.

I also tested with release candidate 5.1.3.2 now. Issue is not reproducible.
Please use this, or the final 5.1.3 version when it's released.
Comment 8 Aron Budea 2016-05-12 10:44:26 UTC
(In reply to raal from comment #5)

Sorry, I meant the backportRequest:5.1 tag, not the regression-related ones (but the it turned out it's already fixed in 5.1, I just haven't tested the RC version).
Comment 9 Commit Notification 2018-05-06 05:38:14 UTC
Zdeněk Crhonek committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c64dd1afb95b4945b438ee60ef811703413e416d

uitest for bug tdf#99773

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.