Download it now!
Bug 99837 - LibreOffice crashes when applying selected Firefox theme/persona
Summary: LibreOffice crashes when applying selected Firefox theme/persona
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.0.0.5 release
Hardware: All All
: medium normal
Assignee: Muhammet Kara
URL:
Whiteboard:
Keywords: haveBacktrace, needUITest
: 114739 (view as bug list)
Depends on:
Blocks: Options-Dialog Firefox-Themes
  Show dependency treegraph
 
Reported: 2016-05-14 10:47 UTC by MartR
Modified: 2018-10-30 16:32 UTC (History)
10 users (show)

See Also:
Crash report or crash signature: ["Application::RemoveUserEvent(ImplSVEvent *)"]


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description MartR 2016-05-14 10:47:42 UTC
Go to
Tools > Options > LibreOffice > Personalisation > Select Theme > search for some random theme, select one, click ok.

The status text "Applying theme" shows, but then LibreOffice quickly and reliably crashes. With some themes (Firefox Personas), the application of a different theme works, but it seems, that with most themes/personas, the crash is very reliable.

This happens since LibreOffice versions 5.0.0 through to 5.1.x, and still happens with 5.0.6.

Both in Windows (32-bit) and Linux (Knoppix).
Comment 1 Buovjaga 2016-05-14 19:51:18 UTC
You could get a backtrace of the crash either on Win or Linux:
https://wiki.documentfoundation.org/QA/BugReport/Debug_Information
https://wiki.documentfoundation.org/How_to_get_a_backtrace_with_WinDbg
Comment 2 Aron Budea 2016-10-25 19:46:43 UTC
I believe I got the same bug with 5.3 alpha1 / Windows 7.
I wend to Tools -> Options...; LibreOfficeDev -> Personalization, clicked Own Theme; in Select Firefox Theme dialog I clicked Color category, and selected the first entry (Best Color Swirl).

Got a crash with this crash report:
http://crashreport.libreoffice.org/stats/crash_details/75d0109c-6e71-4d71-8720-7497fe804d41

On second try it was working though, so the reproduction might not be reliable.
Comment 3 m.a.riosv 2018-01-03 10:56:05 UTC
*** Bug 114818 has been marked as a duplicate of this bug. ***
Comment 4 Xisco Faulí 2018-01-04 10:15:45 UTC
*** Bug 114739 has been marked as a duplicate of this bug. ***
Comment 5 Heiko Tietze 2018-10-08 09:15:05 UTC
The Firefox themes integration has been reworked in https://gerrit.libreoffice.org/#/c/61449/ and this issue was likely solved too. It will be available in 6.2 (or nightly builds).
Comment 6 BogdanB 2018-10-30 16:32:32 UTC
Fixed. Verified on:
Version: 6.2.0.0.alpha1+
Build ID: 3cccff0bbd17ecd4ce386c9eaea06bfa3d14115b
CPU threads: 4; OS: Linux 4.15; UI render: GL; VCL: gtk3; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2018-10-27_16:28:45
Locale: ro-RO (ro_RO.UTF-8); Calc: threaded