Bug 99919 - With OpenGL enabled Impress startup causes Windows 10 bluescreen
Summary: With OpenGL enabled Impress startup causes Windows 10 bluescreen
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.1.3.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:5.3.0 target:5.2.0.1 target:5.1.5
Keywords:
: 100243 (view as bug list)
Depends on:
Blocks: VCL-OpenGL
  Show dependency treegraph
 
Reported: 2016-05-17 20:59 UTC by nudelkiste
Modified: 2018-01-29 16:26 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Windows bluescreen screenshot (2.02 MB, image/jpeg)
2016-05-17 20:59 UTC, nudelkiste
Details
Libre Office errormessage starting writer after impress crash (15.05 KB, image/png)
2016-05-18 11:40 UTC, nudelkiste
Details
try to find openGL option in German version (79.13 KB, image/png)
2016-05-18 11:40 UTC, nudelkiste
Details
openGL disabled (in german version) (90.82 KB, image/png)
2016-05-18 12:45 UTC, nudelkiste
Details
opengl_device.log (322 bytes, text/plain)
2016-05-18 13:29 UTC, nudelkiste
Details

Note You need to log in before you can comment on or make changes to this bug.
Description nudelkiste 2016-05-17 20:59:54 UTC
Created attachment 125128 [details]
Windows bluescreen screenshot

Try to open Impress leads to bluescreen and reboot of Windows (cf IMG_0400.JPG).
Microsoft Windows [Version 10.0.10586]

Can be reproduced by simply starting the libre-office main screen and clicking on impress: This will produce the bluescreen and subsequently windows reboot every single time.
Starting all the others like writer and calc works fine.
Starting the writer/calc/etc. after the reboot causes a warning that a central file is in use and continnuing might lead to inconsistency.

Exact Version of libre-office I use:
Version: 5.1.3.2
Build-ID: 644e4637d1d8544fd9f56425bd6cec110e49301b
CPU-Threads: 4; BS-Version: Windows 6.2; UI-Render: GL; 
Gebietsschema: de-DE (de_DE)
Comment 1 V Stuart Foote 2016-05-17 21:51:37 UTC
That is not good, first please check if disabling OpenGL rendering helps.

Done from Tools -> Options -> View and uncheck "Use OpenGL for all rendering (on restart)"

Restart and check again, let us know if that eliminates the blue screen on launch of Impress.
Comment 2 nudelkiste 2016-05-18 11:39:46 UTC
As I use the german version, I am not sure where to find the option you are talking about.
I found one called OpenCL - but this had no influence.
Please check the uploaded image: libreoffice_options_window.PNG

After the crash an other message is presented when starting any other libre office application like writer or clac: libreoffice_errormessage_after_crash.PNG
Comment 3 nudelkiste 2016-05-18 11:40:33 UTC
Created attachment 125146 [details]
Libre Office errormessage starting writer after impress crash
Comment 4 nudelkiste 2016-05-18 11:40:58 UTC
Created attachment 125147 [details]
try to find openGL option in German version
Comment 5 nudelkiste 2016-05-18 11:42:26 UTC
Comment on attachment 125146 [details]
Libre Office errormessage starting writer after impress crash

It is no problem to hit the "Ja" (yes) button and continue.
But it might give an indication to the source of the problem that causes the windows blue-screen.
Comment 6 V Stuart Foote 2016-05-18 12:02:03 UTC
(In reply to nudelkiste from comment #4)
> Created attachment 125147 [details]
> try to find openGL option in German version

It is in the Ansicht panel.
Comment 7 nudelkiste 2016-05-18 12:45:05 UTC
Created attachment 125150 [details]
openGL disabled (in german version)

I can confirm that impress starts without error as soon as openGL is disabled.
Do I have to consider this as temporary workaround or as best-practice now?
Comment 8 V Stuart Foote 2016-05-18 13:03:43 UTC
Bluescreen crash of OS is never a good thing especially if LibreOffice is the cause!

Devs will want to poke at your issue I'm sure.

For now, can you copy and paste details of your %APPDATA%\LibreOffice\4\cache\opengl_device.log

LibreOffice on Windows systems with unsupported OpenGL drivers and hardware are supposed to block use of OpenGL--you may require a driver update, or may need to work without OpenGL rendering.
Comment 9 nudelkiste 2016-05-18 13:29:08 UTC
Created attachment 125151 [details]
opengl_device.log

I can perfectly live without openGL.
But I wonder if this setting (disabled openGL) should better be the standard setting in this case?
Comment 10 V Stuart Foote 2016-05-18 14:13:30 UTC
One last question from me, but suspect the devs would like to chat.

Is your Windows 10 OS 32-bit or 64-bit? And if 64-bit do you have better result with OpenGL (especially not bluescreen crash the OS) if you use the 64-bit build of LibreOffice?

=-ref-=
http://downloadarchive.documentfoundation.org/libreoffice/old/5.1.3.2/win/x86_64/
Comment 11 nudelkiste 2016-05-18 14:30:05 UTC
I use Win10 Home 64 bit.
Installing LibreOffice 64 bit, does not change anything.
OpenGL enabled -> Impress launch causes crash with Windows Bluescreen
OpenGL disabled -> Impress starts like a charm.
Comment 12 nudelkiste 2016-05-18 14:31:43 UTC
Just for Info:
so far I did neither install any openGL driver, nor directX; all is Windows default.
Even no java is installed so far.
Comment 13 Michael Meeks 2016-05-26 12:53:56 UTC
Wow - a horrible OS / driver bug; we basically need to produce an OpenGL black-list fragment for this driver & version - thank you for your information. Luckily we don't need to actually use the driver to get that data (its fetched from the registry).

Is there an updated Intel driver for your system ?
Comment 14 nudelkiste 2016-05-26 13:51:55 UTC
The latest Driver available is 10.18.15.4279 from 17.12.2015 which is already installed.
Unfortunately no other, more recent driver is available.

On top, I should tell you that it is all but a rare system, as it had been sold by one of the biggest german discount store called "Aldi"

If you are interested in the details:
Drivers are available at: https://www.medion.com/de/service/download/treiber.php
Model: E6424 Notebook (Medion akoya)
Model No.: MD99850
MSN No.: 30020435 (to search for drivers)

In any case, many thanks for your support - it is ways better than everything I ever saw by professional services like oracle, VMware, Microsoft or even SUN (may God rest its soul)
Comment 15 Tor Lillqvist 2016-06-02 10:18:18 UTC
Odd that the opengl_device.log says that DriverVersion: 20.19.15.4352 but then the bug reporter says that the latest driver version is 10.18.15.4279.
Comment 16 Tor Lillqvist 2016-06-02 10:32:02 UTC
... and looking at https://downloadcenter.intel.com/search?keyword=iris , the version numbers there start with 15... Fun. Anyway, I will add a blacklist entry for the exact data mentioned in the attached opengl_device.log.
Comment 17 Commit Notification 2016-06-02 11:24:22 UTC
Tor Lillqvist committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=2cf09f0dcfa4b24a6c3c5560aa82b72a95a7b41b

tdf#99919: Blacklist that specific vendor, version, and device combination

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 18 Commit Notification 2016-06-02 11:33:43 UTC
Tor Lillqvist committed a patch related to this issue.
It has been pushed to "libreoffice-5-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ff6bb3fbbf98df16b73460c74e428379fb216c8f&h=libreoffice-5-2

tdf#99919: Blacklist that specific vendor, version, and device combination

It will be available in 5.2.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 19 Commit Notification 2016-06-03 07:52:43 UTC
Tor Lillqvist committed a patch related to this issue.
It has been pushed to "libreoffice-5-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=646be121eba7c3d833161a7115b4a788c2cc6474&h=libreoffice-5-1

tdf#99919: Blacklist that specific vendor, version, and device combination

It will be available in 5.1.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 20 Tor Lillqvist 2016-06-06 09:19:20 UTC
Presumably can be resolved now, re-open if necessary (but only if *exactly* the same issue still occurs).
Comment 21 nudelkiste 2016-06-06 10:01:15 UTC
Currently I have to beg your patience, as I have no access to the equipment for the coming two weeks. Will verify it asap.

Thanks a lot for this impressive support.
Comment 22 Julien Nabet 2018-01-29 16:26:29 UTC
*** Bug 100243 has been marked as a duplicate of this bug. ***