Bug 99947 - XLSX export of conditional formatting broken
Summary: XLSX export of conditional formatting broken
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.1.0.3 release
Hardware: All All
: medium normal
Assignee: Markus Mohrhard
URL:
Whiteboard: target:5.2.0
Keywords:
Depends on:
Blocks:
 
Reported: 2016-05-19 08:46 UTC by Daniel Rentz
Modified: 2016-11-06 22:10 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
test document (7.54 KB, application/vnd.oasis.opendocument.spreadsheet)
2016-05-19 08:46 UTC, Daniel Rentz
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Rentz 2016-05-19 08:46:35 UTC
Created attachment 125166 [details]
test document

1. Open the attached document.
2. Save as XLSX.
3. Open the exported file in Excel.

=> Excel reports errors in the conditional formatting.

First, the source ranges are written incorrectly. The test document contains a conditional formatting based on the ranges B2:B4 and D2:D4. Excel uses spaces as range separator, but LO writes semicolon:

LO:       <conditionalFormatting sqref="B2:B4;D2:D4">
expected: <conditionalFormatting sqref="B2:B4 D2:D4">

Second, after fixing this manually in the XML file with a text editor for testing, Excel still complains about invalid data in the conditional formatting elements.
Comment 1 raal 2016-05-19 12:35:46 UTC
Version: 5.2.0.0.alpha1+; win7 - after export to xlsx is conditional formatting lost in the file 
In version 5.1.1.3 is Range empty after export to xlsx
Comment 2 m.a.riosv 2016-05-19 21:56:41 UTC
Seems a duplicate of https://bugs.documentfoundation.org/show_bug.cgi?id=99917

Please if you are not agree reopen it.

*** This bug has been marked as a duplicate of bug 99917 ***
Comment 3 Daniel Rentz 2016-05-20 07:59:36 UTC
Reopened because of the multi-range problem described in this bug and its attached test document.
Comment 4 Markus Mohrhard 2016-05-21 01:39:07 UTC
Thanks.

The sqref error has been fixed.
Comment 5 Commit Notification 2016-05-21 02:20:02 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f18a996409657a2f8f53cca1fad3c045f8f031ec

use correct separator for ScRangeList, tdf#99947

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2016-05-21 02:20:06 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=97ecd865c64d9f2bbba7002e87595f3b7401063b

use CONV_XL_OOX for xlsx export, related tdf#99947

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2016-05-21 02:22:29 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f56fb307d59897a33aa425bde06fab22ab3f8d0e

add test for tdf#99947

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Peter J. Alotta 2016-11-06 22:10:50 UTC
This is still a problem in version 5.2.3.