Bug 99967 - Drop Web Wizard
Summary: Drop Web Wizard
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard: target:5.4.0
Keywords:
Depends on:
Blocks: Draw-File-Handling
  Show dependency treegraph
 
Reported: 2016-05-20 13:46 UTC by Samuel Mehrbrodt (CIB)
Modified: 2017-05-26 16:38 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Samuel Mehrbrodt (CIB) 2016-05-20 13:46:00 UTC
The Web wizard exports a set of documents as html with an index and some very nice styles from the last century.

These days you wouldn't publish documents on the internet like this, there are much better options.

I suggest to remove the web wizard completely.


Note: This is not about removing the ability to edit or export html.
Comment 1 V Stuart Foote 2016-05-20 22:40:05 UTC
per Design/UX meeting 2016-05-20

Agree it should probably go (and free crud from the gallery).
Comment 2 Heiko Tietze 2016-05-23 07:31:59 UTC
Plus, the wizard crashes when the style is a frameset. And I doubt if this wizard would be in-scope, if it works well and fit some requirements. It's better realized as user extension.
Comment 3 Heiko Tietze 2016-05-31 11:32:02 UTC
It looks like File > Export > HTML (Impress and Draw) incorporate parts of the web page wizard.
Comment 4 Olivier Hallot 2017-01-05 12:35:33 UTC
I'd  like to state that XHTML export for Writer (text documents) and Calc (spreadsheets) are indeed important features for LibreOffice and must be preserved.
Comment 5 Heiko Tietze 2017-01-05 14:52:15 UTC
(In reply to Olivier Hallot from comment #4)
> I'd  like to state that XHTML export for Writer (text documents) and Calc
> (spreadsheets) are indeed important features for LibreOffice and must be
> preserved.

Why? Do you want to create an HTML page with Writer? Is the export of presentation to HTML (with variable sizes; bug 66259) really crucial for LibreOffice? And if you say yes, where is the limit meaning yes or no to a structured data like XML?
Comment 6 V Stuart Foote 2017-01-05 16:03:13 UTC
Heiko, *

Please don't confuse the HTML 4.0 Web Wizard with the rather more functional XSLT based filter export for converting ODF to XHTML.

The XSLT filters are functional and need to remain and maintained.  Just the HTML wizard as here should go.


=-ref-=
http://cgit.freedesktop.org/libreoffice/core/tree/filter/source/xslt
Comment 7 Heiko Tietze 2017-01-12 13:13:40 UTC Comment hidden (no-value)
Comment 8 jani 2017-01-13 08:29:32 UTC Comment hidden (obsolete)
Comment 9 Samuel Mehrbrodt (CIB) 2017-01-13 09:03:06 UTC Comment hidden (obsolete)
Comment 10 Samuel Mehrbrodt (CIB) 2017-01-27 09:06:24 UTC
Patch is here: https://gerrit.libreoffice.org/#/c/26381/

Need to reach consensus whether we really want to remove it or not. Jan abondened it.
Comment 11 jani 2017-01-27 09:12:02 UTC
(In reply to Samuel Mehrbrodt (CIB) from comment #10)
> Patch is here: https://gerrit.libreoffice.org/#/c/26381/
> 
> Need to reach consensus whether we really want to remove it or not. Jan
> abondened it.

Just to be clear, I only abandoned it as part of the regular gerrit cleanup, because it had a comment
"IMHO, it may be dropped and if someone wants to maintain it as an extension, this person can retrieve the code in git history."

I have no opinion on whether or not this patch is ok or not.
Comment 12 Heiko Tietze 2017-01-27 09:15:04 UTC
(In reply to Samuel Mehrbrodt (CIB) from comment #10)
> Need to reach consensus whether we really want to remove it or not. 

You mean consensus beyond the design team? We discussed the issue and decided to remove the wizard. This result was communicated via minutes and nobody complained.
Comment 13 Julien Nabet 2017-02-17 08:49:24 UTC
Samuel: would it be possible you submit your patch on Gerrit?
I mean if it's ok to drop it, let's do it and avoid some new bugtrackers related to this.
Comment 14 Samuel Mehrbrodt (CIB) 2017-02-17 09:04:55 UTC
(In reply to Julien Nabet from comment #13)
> Samuel: would it be possible you submit your patch on Gerrit?
> I mean if it's ok to drop it, let's do it and avoid some new bugtrackers
> related to this.

Ok, will try to rebase and submit it next week.
Comment 15 Commit Notification 2017-02-17 22:22:34 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=5b3022860abfe7eefd2e25b60b5b2a563b42b3c0

tdf#99967 Drop Web Wizard

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 16 Commit Notification 2017-02-20 07:08:15 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=82d863b4a410fa78120d2efc41bd2b3b61f21cee

Related tdf#99967: Cleanup after Web Wizard drop

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 17 Commit Notification 2017-03-27 20:44:59 UTC
Gabor Kelemen committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=16d658196f9963a5eed6071c5c3db5c85520650e

tdf#99967 (related) Drop Web Wizard help pages
Comment 18 Commit Notification 2017-04-07 08:37:55 UTC
Gabor Kelemen committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b3f96d2ccba362a2898bc3a4d365ce7c4d0698e2

tdf#99967 (related) Drop Web Wizard HIDs

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 19 Xisco Faulí 2017-04-22 19:06:42 UTC
*** Bug 105303 has been marked as a duplicate of this bug. ***
Comment 20 Fakabbir amin 2017-05-26 16:38:20 UTC
*** Bug 105303 has been marked as a duplicate of this bug. ***