Download it now!
Bug 30421 - Libre office doesn't works if openoffice already installed
Summary: Libre office doesn't works if openoffice already installed
Status: CLOSED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: x86 (IA32) Windows (All)
: high normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-09-28 07:42 UTC by gypsymauro
Modified: 2011-12-22 05:49 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description gypsymauro 2010-09-28 07:42:10 UTC
I'm on windows XP with openoffice 3.2.1 already installed, then
I downloaded the beta of LO, the installation goes well, 
but it uninstall openoffice.org without asking me.. then I try to launch
LO and it says that the application can't be launhed 'cause there is a wrong
configuration (sorry I've the italian translation)

I tried to rebbot the machine but I got the same error
Comment 1 Tor Lillqvist 2010-09-28 08:57:48 UTC
I can reproduce that installing LibreOffice uninstalls OpenOffice.org, but not the failure to start. So there are probably two different bugs that you are seeing. If you want to keep using the Italian localisation, I suggest you uninstall LibreOffice and install OpenOffice.org until we have an Italian UI pack available?
Comment 2 gypsymauro 2010-09-29 05:59:01 UTC
uhmm.. I want to get to libreoffice a try :)
of course I can use oo.org ..
Comment 3 Dave 2010-09-29 08:31:03 UTC
I have some input on this, and have just chatted with the folks on IRC about it.  My system is running W2K which, like XP, does not have the side-by-side folders in the basic edition. (possibly introduced in a later service pack?)

The error is partially with OO.o and partially with LO. On installing LO, it runs the uninstall for OO.o. This uninstall removes files from the system32 folder, specifically MSVCR90.dll and MSVCP90.dll.  Both of these files are installed via the MS C++ 9 redistributable pack, and are used by other software also.

On installing, LO installs it's own copies of these files inside its installation folders but does not put them into the system32 folder. LO actually installs 4 copies of each of these files, instead of using the centralized file in system32 or sxs:

\LibreOffice 3\share\extensions\mysql-connector-ooo\
\LibreOffice 3\share\extensions\pdfimport\
\LibreOffice 3\share\extensions\presentation-minimizer\
\LibreOffice 3\share\extensions\presenter-screen\

For those experiencing this problem, simply copy these two files to your system32 folder and everything will work normally.
Comment 4 Raphael Bircher 2010-09-29 16:30:20 UTC
.
Comment 5 Jan Holesovsky 2010-10-14 04:20:00 UTC
gypsymauro: Please, is this still valid with the Beta2?
Comment 6 gypsymauro 2010-10-14 05:09:07 UTC
it seems closed for me, anyone else?

tank you
Comment 7 m.a.riosv 2010-10-14 16:26:43 UTC
To have a try, install in other user only for this user.
This works for me with beta 2 in Windows 7.
Comment 8 Don't use this account, use tml@iki.fi 2010-11-19 04:57:06 UTC
Installing LibreOffice no longer uninstalls OpenOffice.org (since beta2). Resolving this as fixed. We never got any more information about the failure to start that the reporter also mentioned, so I'll assume that was some other glitch but not reproducible.
Comment 9 sophie 2011-01-12 07:54:58 UTC
Closing - Sophie
Comment 10 Björn Michaelsen 2011-12-22 05:35:52 UTC
Remove infoprovider from closed and resolved bugs.
Comment 11 Björn Michaelsen 2011-12-22 05:49:48 UTC
RESOLVED, FIXED or CLOSED bugs cant be KEYWORD NEEDINFO.