Download it now!
Bug 30467 - required visual studio 2008 redistributable libraries not installed, failed to start
Summary: required visual studio 2008 redistributable libraries not installed, failed t...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Fridrich Strba
URL:
Whiteboard:
Keywords:
: 30579 (view as bug list)
Depends on:
Blocks: mab3.5
  Show dependency treegraph
 
Reported: 2010-09-29 09:21 UTC by Daniil Bratashov
Modified: 2011-11-24 07:56 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
Windows Error Report File (364.55 KB, text/plain)
2011-05-13 13:55 UTC, Scott M. Sanders
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Daniil Bratashov 2010-09-29 09:21:37 UTC
If libreoffice installed on win32 vista without vs2008 redistributable package (http://www.microsoft.com/downloads/en/details.aspx?FamilyID=a5c84275-3b97-4ab7-a40d-3802b2af5fc2&displaylang=en), application don't start with error: 

Ошибка при создании контекста активации для "C:\Program Files\LibreOffice 3\program\simpress.exe". Не найдена зависимая сборка "Microsoft.VC90.CRT,processorArchitecture="x86",publicKeyToken="1fc8b3b9a1e18e3b",type="win32",version="9.0.21022.8"". Используйте sxstrace.exe для подробной диагностики.

(microsoft.vc90.crt not found)
Comment 1 Cédric Bosdonnat 2010-09-29 09:33:26 UTC
Could you please provide the error message in English?
Comment 2 Daniil Bratashov 2010-09-29 09:58:30 UTC
(In reply to comment #1)
> Could you please provide the error message in English?

Error in activation context creation for "C:\Program Files\LibreOffice
3\program\simpress.exe". Depending build "Microsoft.VC90.CRT,processorArchitecture="x86",publicKeyToken="1fc8b3b9a1e18e3b",type="win32",version="9.0.21022.8"" not found. 
Use sxstrace.exe for more detailed diagnostics.
Comment 3 Cesare Leonardi 2010-09-29 14:02:56 UTC
Even if the error message i encounter is not exactly the same, i think it's the same bug, just different OS version.
Under Windows 2000 SP4 (italian), after a successful installation, if i try to run every LibreOffice program, an error appears saying that MSVCR90.dll cannot be found. And nothing starts.

Cesare.
Comment 4 Katarina Behrens 2010-09-30 02:55:11 UTC
Fridrich, didn't we see this already?
Comment 5 Johannes Schmid 2010-10-01 00:55:40 UTC
Related to #30421?
Comment 6 Raphael Bircher 2010-10-01 10:50:43 UTC
CCing me
Comment 7 Jean-Baptiste Faure 2010-10-02 14:37:53 UTC
OOO330m9 installs itself Microsoft Visual C++ 2008 SP1 Redistributable Package (x86). If you remove this package OOo-dev does not start.
LibO installer should do the same.

Kind regards. JBF
Comment 8 Jean-Baptiste Faure 2010-10-02 15:35:39 UTC
OOO330m9 decompression folder contains a subfolder redist which contains:
vcredist_x64.exe
vcredist_x86.exe
OOO330m9 installs them (if needed ?) before the screen saying that it is ready to install OOo.
LibO should do the same.

Kind regards. JBF
Comment 9 sophie 2010-10-03 01:25:21 UTC
*** Bug 30579 has been marked as a duplicate of this bug. ***
Comment 10 Cesare Leonardi 2010-10-13 19:57:01 UTC
No progress with beta2.

As pointed out by someone else, i confirm that OOo 3.2.1 has a bug that during uninstall remove the VC runtime, in fact other programs complains about that.
But the deletion doesn't pass from windows installer, since the VC entry is still present in the control panel.

I think the problem reside here.

In my control panel there were three "Microsoft Visual C++ 2008 Redistributable -x86 9.0.xxxx" with different xxxx version. Probably the LO installer, correctly, think that a valid VC runtime is already installed and so it doesn't install another one.
I verified that uninstalling all the VC runtime reported in the control panel then running the LO installer, the VC runtime get installed.

But i've also verified that installing LO having the VC runtime that come with LO itself already installed, LO installs the runtime another time.

Seems that there are some bug in the runtime check code.

And there will be definitevely problems for those who will migrate from OOo3.2.1.

Cesare.
Comment 11 Rainer Bielefeld Retired 2010-11-24 00:16:51 UTC
If we will have a hint on the download page for WIN LibO versions, this one would not be a 3.3 blocker (Bug 31865); what do you think?
Comment 12 Cesare Leonardi 2010-12-25 10:40:34 UTC
To me this bug can be closed, since now LO (3.3.0rc2) always install the VC++2008 runtime. And with always i mean always (see #32650).  ;-)
Verified under Win2000.

Cesare.
Comment 13 Daniil Bratashov 2010-12-25 21:49:05 UTC
As for me, I have not seen this bug with all rc and pre versions after reported one (tested with Vista). May be it is worth to add some text to download page, describing where to find VS2008 redistributable libraries in the case it appears again.
Comment 14 paour 2011-04-08 01:19:50 UTC
Hello,
This bug already exist with :
LibreOffice 3.3.2 
OOO330m19 (Build:202)
tag libreoffice-3.3.2.2
On a fresh install on Win2000 (without Visual C++ 2008) error message say
"msvcr90.dll missing"
The redist/vcredist_x86.exe is not automaticaly installed
Regards
Nicolas
Comment 15 Michail Pappas 2011-04-12 23:57:16 UTC
(In reply to comment #14)
> This bug already exist with :
> LibreOffice 3.3.2 
> OOO330m19 (Build:202)
> tag libreoffice-3.3.2.2
> On a fresh install on Win2000 (without Visual C++ 2008) error message say
> "msvcr90.dll missing"
> The redist/vcredist_x86.exe is not automaticaly installed

I can confirm the exact same behaviour on both Libreoffice and OOO 3.3. This was not the case with Oo versions up to 3.2. Something is wrong with the installer. 

For the time, please consider providing a huge warning for those downloading LibreO, some may be using it to deploy to a multitude of systems using group policies...

IMHO, this is not a medium seriousness bug, but a high one.
Comment 16 Andras Timar 2011-04-30 06:34:48 UTC
(In reply to comment #15)
> I can confirm the exact same behaviour on both Libreoffice and OOO 3.3. This
> was not the case with Oo versions up to 3.2. Something is wrong with the
> installer. 

Please help us to debug the problem. Please start setup.exe with /l switch:
setup.exe /l logfile.txt

Then attach logfile.txt here. Thanks!
Comment 17 Scott M. Sanders 2011-05-13 10:24:03 UTC
I am now getting this every time with 3.4 beta 5 on XP Pro SP3. It did not occur with beta 4.

I have for a few hours now been doing various install and re-install combinations of both LibO 3.4 beta 5 and Visual C++ 2008 Redistributable but have so far gotten nowhere (and boy is setup ever slow), though I had definitely installed vcredist at least once by now.

So I'm just alerting you that it affects the present beta for me; I should have some debug files soon.
Comment 18 Scott M. Sanders 2011-05-13 13:54:57 UTC
My guess at end of workday Friday is that LibO 3.4 beta 5 may have issue with my system's latest vcredist that other apps are using...

x86_Microsoft.VC90.CRT_1fc8b3b9a1e18e3b_9.0.30729.5570_x-ww_0517bbc6 (5570)

...while beta 5 has packaged this version of vcredist...

x86_Microsoft.VC90.CRT_1fc8b3b9a1e18e3b_9.0.30729.4148_x-ww_d495ac4e (4148)

...and I cannot determine how to get LibO to use its own copy of vcredist, if it would even help, where to put it, etc.

What follows is my Windows Error Report signature and attached some other file that got sent with the error report...

AppName: soffice.bin	 AppVer: 3.4.5.500	 ModName: msvcr90.dll
ModVer: 9.0.30729.5570	 Offset: 0002e9f4
Comment 19 Scott M. Sanders 2011-05-13 13:55:27 UTC
Created attachment 46691 [details]
Windows Error Report File
Comment 20 Rainer Bielefeld Retired 2011-09-25 02:32:32 UTC
Report date seems to say: from the beginning?

This worked some time quite nice for me, I had no problems. But WIN7 Server Installation from 
"master~2011-09-24_00.41.37_LibO-Dev_OOO350m1_Win_x86_install_en-US.exe" does not start, message "Programm can not be launched beccause of missing MSVCR90.dll on th computer. Install new to solve the problem (free translation from German)

Same effect with "normal" installation.

WIN Master is unusable so.
Comment 21 Fridrich Strba 2011-09-25 03:00:57 UTC
This is a known problem. The executables lack any resource section, due to the gbuildification of desktop module. We are working on it. Don't expect it to be fixed this week though.
Comment 22 Andras Timar 2011-11-24 07:56:06 UTC
Original problem was solved long ago. 
A different problem reported under this bug, i.e. the missing resource sections in 3.5 daily builds was solved, too. 
Moreover, we will not have separate vcredist_x86.exe in LibreOffice 3.5 installer. There will be just one big MSI file, and the required MSVCRT files will be embedded there.
So this bug is fixed.