Download it now!
Bug 30485 - Configure fails
Summary: Configure fails
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: x86 (IA32) Mac OS X (All)
: medium normal
Assignee: Thorsten Behrens (CIB)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-09-29 22:55 UTC by Ole Guldberg
Modified: 2010-11-05 02:45 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ole Guldberg 2010-09-29 22:55:33 UTC
Doing a: ./autogen.sh --with-distro=LibreOfficeMacOSX --with-git --with-num-cpus=2

results in a configure error. Output below.


bin/piece/Makefile.am:1: wildcard env-*: non-POSIX variable name
bin/piece/Makefile.am:1: (probably a GNU make extension)
bin/piece/Makefile.am:1: wildcard build-*: non-POSIX variable name
bin/piece/Makefile.am:1: (probably a GNU make extension)
bin/piece/Makefile.am:1: wildcard file-list-*: non-POSIX variable name
bin/piece/Makefile.am:1: (probably a GNU make extension)
bin/piece/Makefile.am:1: wildcard inst-*: non-POSIX variable name
bin/piece/Makefile.am:1: (probably a GNU make extension)
bin/piece/Makefile.am:1: wildcard post-inst-*: non-POSIX variable name
bin/piece/Makefile.am:1: (probably a GNU make extension)
desktop/16x16/Makefile.am:1: wildcard ooo-*.png: non-POSIX variable name
desktop/16x16/Makefile.am:1: (probably a GNU make extension)
desktop/22x22/Makefile.am:1: wildcard ooo-*.png: non-POSIX variable name
desktop/22x22/Makefile.am:1: (probably a GNU make extension)
desktop/24x24/Makefile.am:1: wildcard ooo-*.png: non-POSIX variable name
desktop/24x24/Makefile.am:1: (probably a GNU make extension)
desktop/32x32/Makefile.am:1: wildcard ooo-*.png: non-POSIX variable name
desktop/32x32/Makefile.am:1: (probably a GNU make extension)
desktop/48x48/Makefile.am:1: wildcard ooo-*.png: non-POSIX variable name
desktop/48x48/Makefile.am:1: (probably a GNU make extension)
desktop/Makefile.am:3: wildcard *.desktop.in.in: non-POSIX variable name
desktop/Makefile.am:3: (probably a GNU make extension)
desktop/Makefile.am:17: `%'-style pattern rules are a GNU make extension
desktop/Makefile.am:17: wildcard $(top_srcdir: non-POSIX variable name
desktop/Makefile.am:17: (probably a GNU make extension)
desktop/Makefile.am:20: `%'-style pattern rules are a GNU make extension
desktop/Makefile.am:23: wildcard *.png: non-POSIX variable name
desktop/Makefile.am:23: (probably a GNU make extension)
desktop/mimetypes/16x16/Makefile.am:1: wildcard *.png: non-POSIX variable name
desktop/mimetypes/16x16/Makefile.am:1: (probably a GNU make extension)
desktop/mimetypes/22x22/Makefile.am:1: wildcard *.png: non-POSIX variable name
desktop/mimetypes/22x22/Makefile.am:1: (probably a GNU make extension)
desktop/mimetypes/24x24/Makefile.am:1: wildcard *.png: non-POSIX variable name
desktop/mimetypes/24x24/Makefile.am:1: (probably a GNU make extension)
desktop/mimetypes/32x32/Makefile.am:1: wildcard *.png: non-POSIX variable name
desktop/mimetypes/32x32/Makefile.am:1: (probably a GNU make extension)
desktop/mimetypes/48x48/Makefile.am:1: wildcard *.png: non-POSIX variable name
desktop/mimetypes/48x48/Makefile.am:1: (probably a GNU make extension)
desktop/scalable/Makefile.am:1: wildcard ooo-*.svg: non-POSIX variable name
desktop/scalable/Makefile.am:1: (probably a GNU make extension)
distro-configs/Makefile.am:1: wildcard *.conf.in: non-POSIX variable name
distro-configs/Makefile.am:1: (probably a GNU make extension)
doc/Makefile.am:1: wildcard *.txt *.sh *.sample: non-POSIX variable name
doc/Makefile.am:1: (probably a GNU make extension)
etc/Makefile.am:1: wildcard test*.list: non-POSIX variable name
etc/Makefile.am:1: (probably a GNU make extension)
etc/Makefile.am:1: wildcard test*.blacklist: non-POSIX variable name
etc/Makefile.am:1: (probably a GNU make extension)
extensions/tweakconfig/Makefile.am:1: wildcard *.xcu: non-POSIX variable name
extensions/tweakconfig/Makefile.am:1: (probably a GNU make extension)
extensions/tweakconfig/Makefile.am:1: wildcard *.xml: non-POSIX variable name
extensions/tweakconfig/Makefile.am:1: (probably a GNU make extension)
patches/64bit/Makefile.am:1: wildcard *.diff: non-POSIX variable name
patches/64bit/Makefile.am:1: (probably a GNU make extension)
patches/Makefile.am:3: wildcard *.diff: non-POSIX variable name
patches/Makefile.am:3: (probably a GNU make extension)
patches/cairo/Makefile.am:1: wildcard *.diff: non-POSIX variable name
patches/cairo/Makefile.am:1: (probably a GNU make extension)
patches/dev300/Makefile.am:1: wildcard *.diff*: non-POSIX variable name
patches/dev300/Makefile.am:1: (probably a GNU make extension)
patches/emf+/Makefile.am:1: wildcard *.diff: non-POSIX variable name
patches/emf+/Makefile.am:1: (probably a GNU make extension)
patches/evo2/Makefile.am:1: wildcard *.diff: non-POSIX variable name
patches/evo2/Makefile.am:1: (probably a GNU make extension)
patches/gstreamer/Makefile.am:1: wildcard *.diff: non-POSIX variable name
patches/gstreamer/Makefile.am:1: (probably a GNU make extension)
patches/hotfixes/Makefile.am:1: wildcard *.diff: non-POSIX variable name
patches/hotfixes/Makefile.am:1: (probably a GNU make extension)
patches/lwp/Makefile.am:1: wildcard *.diff: non-POSIX variable name
patches/lwp/Makefile.am:1: (probably a GNU make extension)
patches/mono/Makefile.am:1: wildcard *.diff: non-POSIX variable name
patches/mono/Makefile.am:1: (probably a GNU make extension)
patches/ooxml/Makefile.am:1: wildcard *.diff: non-POSIX variable name
patches/ooxml/Makefile.am:1: (probably a GNU make extension)
patches/postgresql/Makefile.am:1: wildcard *.diff: non-POSIX variable name
patches/postgresql/Makefile.am:1: (probably a GNU make extension)
patches/unittesting/Makefile.am:1: wildcard *.diff: non-POSIX variable name
patches/unittesting/Makefile.am:1: (probably a GNU make extension)
patches/vba/Makefile.am:1: wildcard *.diff: non-POSIX variable name
patches/vba/Makefile.am:1: (probably a GNU make extension)
po/Makefile.am:3: wildcard *.po: non-POSIX variable name
po/Makefile.am:3: (probably a GNU make extension)
po/Makefile.am:3: wildcard *.sdf: non-POSIX variable name
po/Makefile.am:3: (probably a GNU make extension)
po/Makefile.am:9: wildcard ooo-build-*.po: non-POSIX variable name
po/Makefile.am:9: (probably a GNU make extension)
po/Makefile.am:13: wildcard sdf-templates/*.sdf: non-POSIX variable name
po/Makefile.am:13: (probably a GNU make extension)
po/Makefile.am:28: `%'-style pattern rules are a GNU make extension
po/sdf-templates/Makefile.am:1: wildcard *.sdf: non-POSIX variable name
po/sdf-templates/Makefile.am:1: (probably a GNU make extension)
src/Makefile.am:3: wildcard *.dic: non-POSIX variable name
src/Makefile.am:3: (probably a GNU make extension)
src/helpcontent2/Makefile.am:1: wildcard *.xsl: non-POSIX variable name
src/helpcontent2/Makefile.am:1: (probably a GNU make extension)
src/icons/Makefile.am:3: wildcard *.png: non-POSIX variable name
src/icons/Makefile.am:3: (probably a GNU make extension)
src/icons/tango/Makefile.am:1: wildcard *.png: non-POSIX variable name
src/icons/tango/Makefile.am:1: (probably a GNU make extension)
src/layout/Makefile.am:1: wildcard *.png: non-POSIX variable name
src/layout/Makefile.am:1: (probably a GNU make extension)
src/sdf/Makefile.am:1: wildcard *.sdf: non-POSIX variable name
src/sdf/Makefile.am:1: (probably a GNU make extension)
templates/Makefile.am:1: wildcard *.ott: non-POSIX variable name
templates/Makefile.am:1: (probably a GNU make extension)
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... ./install-sh -c -d
checking for gawk... no
checking for mawk... no
checking for nawk... no
checking for awk... awk
checking whether make sets $(MAKE)... yes
checking how to create a ustar tar archive... gnutar
checking whether to enable maintainer-specific portions of Makefiles... no
checking for perl... /usr/bin/perl
checking for pkg-config... /usr/local/bin/pkg-config
./configure: line 3298: syntax error near unexpected token `FOO_COMMON,'
./configure: line 3298: `PKG_CHECK_MODULES( FOO_COMMON,'
Comment 1 Fridrich Strba 2010-09-30 00:23:02 UTC
This means, that the pkg.m4 that is part of the pkg-config package was not found, please, try to run the autogen.sh this way:
ACLOCAL_FLAGS='-I/usr/local/share/aclocal' ./autogen.sh --with-distro=LibreOfficeMacOSX --with-git --with-num-cpus=2
That should pick it correctly given where your pkg-config is and then the configure should pass well.
Comment 2 Ole Guldberg 2010-09-30 00:25:53 UTC
(In reply to comment #1)
> This means, that the pkg.m4 that is part of the pkg-config package was not
> found, please, try to run the autogen.sh this way:
> ACLOCAL_FLAGS='-I/usr/local/share/aclocal' ./autogen.sh
> --with-distro=LibreOfficeMacOSX --with-git --with-num-cpus=2
> That should pick it correctly given where your pkg-config is and then the
> configure should pass well.

That fixes the problem for me. Now it configures. Thanks a bunch!
Comment 3 Thorsten Behrens (CIB) 2010-09-30 00:30:52 UTC
Confirmed. Currently OSX builds need a few bits and pieces from MacPorts, among them pkg-config.

Which is of course pathetically extraneous - would you be up to make those places conditional?

Like this:

if test "z`uname -s`" != "zDarwin"; then
  <blah>
fi

(my boxen are infested with tools I need for other projects, so any help here from someone with a clean install greatly appreciated)
Comment 4 Thorsten Behrens (CIB) 2010-09-30 00:33:15 UTC
Hrm, crossing comments -

Ole, would you be willing to clean up configure.in a bit, according to my text above?
Comment 5 Ole Guldberg 2010-09-30 00:35:11 UTC
(In reply to comment #4)
> Hrm, crossing comments -
> 
> Ole, would you be willing to clean up configure.in a bit, according to my text
> above?

I'll try to look into it.
Comment 6 Ole Guldberg 2010-09-30 08:33:52 UTC
(In reply to comment #4)
> Hrm, crossing comments -
> 
> Ole, would you be willing to clean up configure.in a bit, according to my text
> above?

I have been trying a construct like this:

# MacOSX doesnt have pkg-config
if test "z`uname -s`" != "zDarwin"; then
   AC_PATH_PROG(PKG_CONFIG, pkg-config)
   if test ! -x "$PKG_CONFIG" ; then
      AC_MSG_ERROR([
   *** You need the latest pkg-config.
   *** Get the latest version of pkg-config from
   *** <http://www.freedesktop.org/software/pkgconfig/>.])
   fi
   AC_SUBST(PKG_CONFIG)

   PKG_CHECK_MODULES( FOO_COMMON,
                   [ libxml-2.0 fontconfig >= 1.0.1 ],
                   have_common=true, have_common=false )
fi

But this will get the same configure problem. My autoconf-foo is not as good as it should be - can anyone see whats wrong?

I have removed the pkg-config i had installed (MacOSX 10.6 doesnt supply pkg-config), to be sure my local installation is clean.

Another problem will be wget, which download.in will need.
Comment 7 Raphael Bircher 2010-10-01 05:27:31 UTC
Change prio add myself to CC

@torsten please have a look
Comment 8 Thorsten Behrens (CIB) 2010-10-04 01:10:53 UTC
Workaround available, reducing prio - will look into mac today, though.
Comment 9 Thorsten Behrens (CIB) 2010-11-05 02:45:16 UTC
Ok, the pkg-config problem is fixed. There's one remaining issue, when not using MacPorts, on a 10.4 box - AM_INIT_AUTOMAKE([1.8b tar-ustar]) is not supported. This has some chance to get fixed implicitely, as we retire this configure in favour of the one from bootstrap. For the while, this option is though necessary.

Anyway, since the reported problem is fixed -> resolving as fixed.