Download it now!
Bug 30643 - ooinstall exit with error
Summary: ooinstall exit with error
Status: RESOLVED DUPLICATE of bug 30769
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-06 01:16 UTC by Tonal
Modified: 2013-11-23 13:08 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
installation log (335.21 KB, text/plain)
2010-10-06 01:16 UTC, Tonal
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tonal 2010-10-06 01:16:53 UTC
Created attachment 39212 [details]
installation log

My steps to install:
# git pull -r
...
# make
...
# bin/ooinstall -l /opt/libreoffice
...
**************************************************
ERROR: ERROR: Could not register all components for file services.rdb (gid_Starregistry_Services_Rdb)!
in function: create_services_rdb
**************************************************

**************************************************
ERROR: Saved logfile: /mnt/my_book/lang/sources/git/libreoffice/build/libreoffice-3.2.99.1/instsetoo_native/util/OpenOffice//logging/en-US/log_OOO330_en-US.log
**************************************************
Wed Oct  6 13:31:15 2010 (01:24 min.)
Failed to install:  at bin/ooinstall line 144.
Comment 1 Michael Meeks 2010-10-07 03:50:24 UTC
Nasty ! sorry about this; I believe the root of the problem is a broken python path - that needs to include more elements.

Any chance you can run:

strace -f -s 256 -o /tmp/log bin/ooinstall <path>
gzip /tmp/log

and attach the log.gz here ? - clearly the path to this module is busted.

It would be great to know what distribution and version you are using, and also which profile [ are you using the system-python - ie. no --with-distro flag (this is recommended) ].

Sorry for the grief - really frustrating; if you want a quick 'fix' you might want to consider rm -Rf build/libreoffice*/scp2/unxlngi6.pro; re-autogen with --disable-python and re-run an incremental make.

Are you aware of the need to run: "bin/g pull -r" to update the bulk of the code [ although this will prolly trigger quite a large re-build, which would be better done from clean I suspect (ie. rm -Rf build/) - so lets debug your issue first ;-) ].

Any chance you can prod me (mmeeks) on #libreoffice on irc.freenode.net to chase it more interactively ?

Thanks.
Comment 2 Thorsten Behrens (CIB) 2010-10-11 02:17:12 UTC
Tonal - could you retry / poke us on irc? there were several fixes in this area.
Comment 3 Caolán McNamara 2010-10-21 04:22:32 UTC

*** This bug has been marked as a duplicate of bug 30769 ***
Comment 4 Björn Michaelsen 2011-12-22 05:49:54 UTC
RESOLVED, FIXED or CLOSED bugs cant be KEYWORD NEEDINFO.