Download it now!
Bug 30671 - slide transitions appears to use GL_DOUBLE vertices
Summary: slide transitions appears to use GL_DOUBLE vertices
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: lowest enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-07 02:27 UTC by Dave Airlie
Modified: 2013-02-28 12:14 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dave Airlie 2010-10-07 02:27:20 UTC
No modern GPU hw support double vertices, so we end up translating them to floats internally in the driver. There is probably little reason to use GL_DOUBLEs.

http://cgit.freedesktop.org/libreoffice/impress/tree/slideshow/source/engine/OGLTrans/OGLTrans_TransitionImpl.cxx
Comment 1 Caolán McNamara 2010-10-07 02:39:44 UTC
B2DTuple is using doubles, so I'm guessing if we want to present floats to the opengl layer we'd probably have to do something like turn B2DTuple into a template and use B2DTuple<float> in impress/slideshow/source/engine/OGLTrans to avoid ending up just doing the same double->float conversion ourselves
Comment 2 Don't use this account, use tml@iki.fi 2010-11-19 05:16:15 UTC
I think this is in Rodo's area? Reassign back to the list if not.
Comment 3 Rainer Bielefeld Retired 2012-08-22 04:35:45 UTC
Back to list due to facts

Very old Bug report, not easy to understand for me what consequences "it" has.
Comment 4 Joel Madero 2012-09-24 19:37:24 UTC
Does this belong in UNCONFIRMED or should it be in NEEDINFO?
Comment 5 Kohei Yoshida 2012-10-15 18:37:38 UTC
I'll set this "confirmed".  This is a user-invisible, mostly plumbing-only kind of bug report.  I doubt this really impacts end users directly.
Comment 6 Joel Madero 2012-10-15 18:39:42 UTC
Potential Easy Hack then?
Comment 7 Joel Madero 2012-10-15 18:41:01 UTC
Changed priority to lowest enhancement as Kohei has stated that the real impact will be minimal if anything at all
Comment 8 Caolán McNamara 2013-02-28 12:14:54 UTC
Ah well, so our B2DTuple are doubles and it would be pretty dramatic to change that to floats at this stage to use floats throughout LibreOffice and presumably converting them to floats just at the point of insertion into opengl is effectively the same thing that the driver does already and would gain nothing.