Download it now!
Bug 30689 - Calc compatibility issues with OOo 2.x
Summary: Calc compatibility issues with OOo 2.x
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-07 13:13 UTC by Maximiliano Curia
Modified: 2010-12-15 00:00 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Example ods file to test the problem (32.98 KB, application/vnd.oasis.opendocument.spreadsheet)
2010-10-07 13:13 UTC, Maximiliano Curia
Details
Resulting file after editing with OOo 3.2 (33.49 KB, application/vnd.oasis.opendocument.spreadsheet)
2010-10-07 13:14 UTC, Maximiliano Curia
Details
Screenshot of how the original file looks in OOo 2.4 (76.21 KB, image/png)
2010-10-07 13:16 UTC, Maximiliano Curia
Details
Screenshot of how the file looks in OOo 2.4 after being edited in OOo 3.2 (56.42 KB, image/png)
2010-10-07 13:17 UTC, Maximiliano Curia
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Maximiliano Curia 2010-10-07 13:13:34 UTC
Created attachment 39262 [details]
Example ods file to test the problem

Hi,

The latest releases from OOo and also LO are showing a compatibility problem with older versions of OOo still in use, in particular in what regards to text boxes inside spreadsheets.  There are several issues and several ways to reproduce, but all of them related to text boxes and using older OOo versions.

So, for example, opening the ods file attached and saving it into the same or a new ods, breaks the format of the text and the placement of the textboxes.  This file was created a long time ago as an xls, then saved into an ods and editted with various versions of OOo.  It's worked fine until the arrival of OOo 3.X and now LO is exhibiting the same problems.

Another way of reproducing the same problem is to open an xls file that has a textbox, edit it with OOo and save, keeping the xls format.  The textboxes and text format also breaks in this case.

What does seem to work, however, is creating a new file in OOo 3.X / LO with textboxes and then edit that file with the older OOo 2.X version.  So, it looks like the format of the textboxes was changed in a way that is not compatible, when in the textbox was created in an xls, even if the file had been saved as an ods long ago.

Steps to reproduce: open the attached file in OOo 3.X / LO, make a trivial change and save.  Open the resulting file in OOo 2.X.  The text format is all broken.

I'm attaching the test file, I'll be attaching the resulting file and screenshots (if bugzilla lets me)
Comment 1 Maximiliano Curia 2010-10-07 13:14:30 UTC
Created attachment 39263 [details]
Resulting file after editing with OOo 3.2
Comment 2 Maximiliano Curia 2010-10-07 13:16:55 UTC
Created attachment 39264 [details]
Screenshot of how the original file looks in OOo 2.4
Comment 3 Maximiliano Curia 2010-10-07 13:17:32 UTC
Created attachment 39265 [details]
Screenshot of how the file looks in OOo 2.4 after being edited in OOo 3.2
Comment 4 Noel Power 2010-10-26 03:19:35 UTC
(In reply to comment #0)
> Created an attachment (id=39262) [details]
> Example ods file to test the problem
t
> boxes inside spreadsheets.  There are several issues and several ways to
> reproduce, but all of them related to text boxes and using older OOo versions.
> 
if that's the case please can you file individual issues ( with minimal testdoc/instructions for each ). It gets very confusing otherwise. ( btw if I understood things this most likely looks like a fix to a bug in 2.x that unfortunately screws up documents saved with that 'bug' )
Comment 5 Don't use this account, use tml@iki.fi 2010-11-19 05:24:04 UTC
Assigning to Kohei, but honestly I don't think this has high priority. How old is OOo 2.x now? Is there some still commonly used platform/OS version where OOo 2.x is the newest supported/available OOo?
Comment 6 Maximiliano Curia 2010-11-21 06:24:31 UTC
Currently Debian Lenny (the current stable version) ships with OOo 2.4.1, also you have to take into account that many people are slow to upgrade to the latest version.

However this is not only a problem of OOo 2.x, it also fails with xls files with text boxes. Fails means that after a trivial change in a xls file all the formating of the text boxes is lost for OOo 3.x/LO.

About splitting this report, it's difficult to say if it's the same bug or not. To me, it seems to be the same bug.
Comment 7 Rainer Bielefeld Retired 2010-12-15 00:00:28 UTC
NOT reproducible with "K-31.2.4.ods" and "LibreOffice 3.3.0 RC1 - WIN XP German UI  [OOO330m17 (build 3.3.0.1", I don't see the damages from "Screenshot of how the file looks in OOo 2.4 after being edited in OOo 3.2". in XLS export (after some edits)fine in MS XLS viewer and also wuth OOo 2.4.
I see the damages in an .ods after few edits, but until proof of the contrary I see that as an OOo2.4 problem, that can't be fixed here. Same document looks fine in OOo 3.1.1, so that that problem seems to be fixed between 2.4 and 3.1.1. 

So currently I can't see any problems left and close this Issue WFM.

@Maximiliano Curia
May I ask you to read <http://wiki.documentfoundation.org/BugReport>?
For new comments:
- add information 
  -- concerning your PC (especially graphic card)
  -- concerning your OS and the LibO version you used.
  -- precise information! "breaks the format" and "Trivial Edit" is not precise,
     please describe all details of your edit and
     all details what you see broken. You never can know what other users 
     will see on their screen with your sample documents 
     (but your screenshots, of course, show what your problem is.)
  -- everything else crossing your mind after you read a.m. URL

If you contribute sample documents and others, please create a complete test kit with document before / after edit, screenshots and so on, Zip it, attach all files as ONE attachment and comment how to use the kit 

Please also mention Noel's hints.

Please feel free to reopen this Bug if you find out that the problem still exists in the latest release of LibO and if you can provide requested additional information.