Download it now!
Bug 30700 - Advanced Find = Simple Content Analysis
Summary: Advanced Find = Simple Content Analysis
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Linguistic (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-07 19:16 UTC by fadingdust
Modified: 2012-08-31 10:04 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description fadingdust 2010-10-07 19:16:32 UTC
You already have a built-in thesaurus, so why not find (a) similar terms based on the thesaurus and (b) gimme an outline of terms by frequency in sentences which contain those terms. I simply mean:

(1) I search for the term “religion” in the Content-Analysis view.
(2) It searches for “religion” and finds, say 20 sentences. A sub-analysis loop runs, using the terms in those 20 sentences, and finds “priest” and “economics” as the top 2 co-existing terms surrounding “religion.” Perhaps there are others too, like “alienation” and “political.”
(3) I then get a sidebar-outline of these terms in the structure of the paper:
Chapter 1:
(page 4) [Religion::priest] ..Sentence..
Chapter 4:
(page 89) [Religion::politics::economics] ..sentence..
(page 94) [Religion::priest::alienation] ..sentence..
I’m sure you get the picture; these would be visually correlated with the length of the document.

This would drastically aid in research-work. Especially if these "hits" could be associated/turned into "annotations" or some other idea of "key terms."
Comment 1 Rainer Bielefeld Retired 2010-12-12 07:40:52 UTC
Yes, might be a nice feature, but for normal office work not very important.
Comment 2 fadingdust 2010-12-12 11:38:26 UTC
Oh sure, "normal office work" wouldn't so often need this, except when the legal document is long. My use-case is academia, which does this sort of thing all day long. Forgetting that user-base is frankly a mistake.
Comment 3 Björn Michaelsen 2011-12-23 11:33:23 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 4 Florian Reisinger 2012-08-14 13:58:58 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 5 Florian Reisinger 2012-08-14 14:00:11 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 6 Florian Reisinger 2012-08-14 14:04:52 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 7 Florian Reisinger 2012-08-14 14:06:57 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian