Download it now!
Bug 30704 - MAILMERGE produces empty pages (except first document) if text frame is only contents in source document
Summary: MAILMERGE produces empty pages (except first document) if text frame is only ...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-08 04:54 UTC by jacksjy
Modified: 2015-03-25 16:57 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Explanation of "base textframe" & "inner textframe" (8.52 KB, application/vnd.oasis.opendocument.text)
2010-10-26 06:10 UTC, jacksjy
Details
Just with blank textframe (8.08 KB, application/vnd.oasis.opendocument.text)
2010-10-26 06:11 UTC, jacksjy
Details
Step_2 (8.16 KB, application/vnd.oasis.opendocument.text)
2010-10-26 06:12 UTC, jacksjy
Details
result of mail merge (8.70 KB, application/vnd.oasis.opendocument.text)
2010-10-27 09:31 UTC, Noel Power
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jacksjy 2010-10-08 04:54:12 UTC
If base textframe  dosen't has any "text" content merge result will be blank.


How to Repeat.

1,Create a odt just have a textframe (inner textframe, just hava a textframe in base textframe).
2,Just insert data "Field" in the inner textframe (not in the base textframe)
3,Mail merge (blank page)


Temporary Work around.

Insert a "space char" in the base textframe. 
The content in the inner textframe will be show.
Comment 1 Noel Power 2010-10-26 03:31:49 UTC
(In reply to comment #0)
> If base textframe  dosen't has any "text" content merge result will be blank.
> 
> 
> How to Repeat.
> 
> 1,Create a odt just have a textframe (inner textframe, just hava a textframe in
> base textframe).
> 2,Just insert data "Field" in the inner textframe (not in the base textframe)
> 3,Mail merge (blank page)
> 
> 
> Temporary Work around.
> 
> Insert a "space char" in the base textframe. 
> The content in the inner textframe will be show.

uhm, not being familiar at all with mailmerge could you provide a text document with the content described in steps 1 & 2 and additionally provide some more finely grained substeps to better describe step 3?
Comment 2 jacksjy 2010-10-26 06:10:05 UTC
Created attachment 39784 [details]
Explanation of "base textframe" & "inner textframe"
Comment 3 jacksjy 2010-10-26 06:11:16 UTC
Created attachment 39785 [details]
Just with blank textframe
Comment 4 jacksjy 2010-10-26 06:12:52 UTC
Created attachment 39786 [details]
Step_2
Comment 5 jacksjy 2010-10-26 06:20:08 UTC
(In reply to comment #1)
> (In reply to comment #0)
> > If base textframe  dosen't has any "text" content merge result will be blank.
> > 
> > 
> > How to Repeat.
> > 
> > 1,Create a odt just have a textframe (inner textframe, just hava a textframe in
> > base textframe).
> > 2,Just insert data "Field" in the inner textframe (not in the base textframe)
> > 3,Mail merge (blank page)
> > 
> > 
> > Temporary Work around.
> > 
> > Insert a "space char" in the base textframe. 
> > The content in the inner textframe will be show.
> 
> uhm, not being familiar at all with mailmerge could you provide a text document
> with the content described in steps 1 & 2 and additionally provide some more
> finely grained substeps to better describe step 3?

I now upload 3 file.
Step 3 can produce by 
Tool -> MailMerge -> Save or Print

P.S. 
mailmerge will create additional useless blank page with each entry.
so if I have one entry in database(and my mailmerge template just consum one page), it will create one more invisible blank page.
Comment 6 Noel Power 2010-10-27 09:31:01 UTC
If I understand things correctly ( and thanks for the uploads ) then if I don't insert a char in the 'base' text frame then after doing the Tool-> Mailmerge -> Save or Print I should see a blank page. 
After using your doc ( Step2 ) and performing the above step ( without inserting a char ) I however do get content in the document ( saving as a single doc I get ( see the about to be attached doc ) So, is it correct I don't see your problem here ( by the way I am using beta2 on linux opensuse 11.3 )
Comment 7 Noel Power 2010-10-27 09:31:44 UTC
Created attachment 39812 [details]
result of mail merge
Comment 8 jacksjy 2010-10-27 22:03:12 UTC
(In reply to comment #6)
> If I understand things correctly ( and thanks for the uploads ) then if I don't
> insert a char in the 'base' text frame then after doing the Tool-> Mailmerge ->
> Save or Print I should see a blank page. 
> After using your doc ( Step2 ) and performing the above step ( without
> inserting a char ) I however do get content in the document ( saving as a
> single doc I get ( see the about to be attached doc ) So, is it correct I don't
> see your problem here ( by the way I am using beta2 on linux opensuse 11.3 )

I open your upload("result_of_mail_merge") with OOo 3.2 under Ubuntu 10.04 amd64
JRE 1.6.0_22

First Page is all right.
But Page 2~63 is blank.
Comment 9 jacksjy 2010-10-27 22:08:17 UTC
(In reply to comment #6)
> If I understand things correctly ( and thanks for the uploads ) then if I don't
> insert a char in the 'base' text frame then after doing the Tool-> Mailmerge ->
> Save or Print I should see a blank page. 
> After using your doc ( Step2 ) and performing the above step ( without
> inserting a char ) I however do get content in the document ( saving as a
> single doc I get ( see the about to be attached doc ) So, is it correct I don't
> see your problem here ( by the way I am using beta2 on linux opensuse 11.3 )

I also unzip your upload

an view the content.xml

and sure there is no content in 2~63 page.

and the blank result may be not related to the render system.
Comment 10 Noel Power 2010-10-28 02:50:32 UTC
(In reply to comment #8)
> (In reply to comment #6)
> > If I understand things correctly ( and thanks for the uploads ) then if I don't
> > insert a char in the 'base' text frame then after doing the Tool-> Mailmerge ->
> > Save or Print I should see a blank page. 
> > After using your doc ( Step2 ) and performing the above step ( without
> > inserting a char ) I however do get content in the document ( saving as a
> > single doc I get ( see the about to be attached doc ) So, is it correct I don't
> > see your problem here ( by the way I am using beta2 on linux opensuse 11.3 )
> 
> I open your upload("result_of_mail_merge") with OOo 3.2 under Ubuntu 10.04
> amd64
> JRE 1.6.0_22
> 
> First Page is all right.
so it seems I don't experience the problem you mentioned, are you using beta2? or are you reporting a problem with openoffice3.2 ? ( I notice you mention somewhere that is what you used to open my file )
> But Page 2~63 is blank.
one problem ( and ideally one issue ) at a time :-) I must admit I didn't notice the comment about the blank pages earlier
Comment 11 jacksjy 2010-10-28 07:33:19 UTC
(In reply to comment #10)

> one problem ( and ideally one issue ) at a time :-) I must admit I didn't
> notice the comment about the blank pages earlier

Sorry, for my too short description in the Title, make you misunderstand the "blank"(like blank window, etc.)
This problem can reproduce from OOo 3.0 to 3.3
And I think LibreOffice will inherit it from OOo.

With your last upload I can sure this problem certainly exist in LibreOffice.

I hate OOo's complicate bug report procedure, so I report here.
Comment 12 Rainer Bielefeld Retired 2010-12-18 10:58:40 UTC
Is this the same as a.m. OOo issue 25840?

@jacksjy:
What OS did you test?
Comment 13 jacksjy 2010-12-18 21:25:13 UTC
(In reply to comment #12)
> Is this the same as a.m. OOo issue 25840?
> 
> @jacksjy:
> What OS did you test?

@Rainer Bielefeld 

Not the same. if base textframe have text(even a "space"),data import correctly, and show correctly(though it will Zip in Blank Page). if base textframe has nothing, no content show in the inner textframe (though in some test it will create first page correctlly , but subseq page blank)


OS Ubuntu/XP i'm using, but I think java is cross platform, even it's bug.
Comment 14 Rainer Bielefeld Retired 2011-01-20 04:39:11 UTC
@Noel:
Still additional information required?
Comment 15 Noel Power 2011-01-21 04:02:08 UTC
caolan, you know something about mail merge, any wisdow ?
Comment 16 Caolán McNamara 2011-03-21 02:34:44 UTC
This probably boils down to less a mail merge issue, and more a cut and paste sort of thing, i.e. select all on a document that contains only a text frame and paste it into another document and the text frame doesn't get copied. 

mail merge itself is probably something of a red herring
Comment 17 Rainer Bielefeld Retired 2011-10-27 23:18:04 UTC
Modified Version due to report date.

[Reproducible] with "LibreOffice 3.4.4RC1  - WIN7 Home Premium (64bit) German UI [OOO340m1 (Build:401)]" 

Steps  I tried:
0. I prepared my Address Database Spreadsheet with a filter criteria for 
   4 addresses and save/close.
1. opened new WRITER document and saved it as "source.dot"
2. Opened a Letter document with Address Fields for Mail Merge Address
   data (Name, Street/No, Zipcode, Town) I use for my business
3. Copy/Paste address fields from my Letter document to "source.dot"
4. Menu 'Insert -> Frame' <ok>
   Frame will be inserted.
5. Select Name field from Address , <control+c> for copy
6. Click into Frame from step 4
7. Menu 'Tools -> Mail Merge Wizard'
8. 'Use Current Document' <Next>
9. 'Letter'' <Next>
10. Select Address List
11. 'Filter' Select my filter criteria from step 0' <ok> <Next>
12. In Dialog "Preview and edit the document" I switch through 4 filtered
    Addresses, everything is ok, Name also visible in text frame
    <next>
13. Print merged Document dialog:
    Select "Print merged Document", Select Printer "FreePDF"
    Print all Documents
    <Print Documents>
    Printout will start
14. I proceed FreePDF until PDF with Printout opens
    Expected: All Address data, also in frame, visible in document with 7 pages
              (I did not suppress empty pages), contents in pages 1,3,5,7
    Actual: as expected

I can't see any problem. Same result with LibO 3.3.3 Portable, but that's not unexpected, reporter said that everythin works if the document contains text outside the frame.

So new Test:
------------
20. Address Database Spreadsheet still is prepared
21. Open reporter's "Step_1.odt"  and saved it as "Step_1_source.dot"
22. Opened a Letter document with Address Fields for Mail Merge address
    data (Name, Street/No, Zipcode, Town) I use for my business
33. Copy/Paste address fields from my Letter document into the empty 
    ("inner") frame of "Step_1_source.dot"
37. Menu 'Tools -> Mail Merge Wizard'
38. 'Use Current Document' <Next>
39. 'Letter'' <Next>
40. Select Address List
41. 'Filter' Select my filter criteria from step 0' <ok> <Next>
42. In Dialog "Preview and edit the document" I switch through 4 filtered
    Addresses, everything is ok, Name also visible in text frame
    <next>
42a. In Step 7 Dialog "Personalize the mail merge document":
     <edit document>  (Result document will open)
     Document has 7 pages as expected, but contents only in page 1, pages
     3,5,7 are empty, that's UNEXPECTED
42b. Click in message box 'Return ot mail merge wizard'
    <next>
43. Step 8, Print merged Document dialog:
    Select "Print merged Document", Select Printer "FreePDF"
    Print all Documents
    <Print Documents>
    Printout will start
44. I proceed FreePDF until PDF with Printout opens
    Expected: All Address data (Name) in frame visible in document with 
    7 pages
    Actual: contents only on page 1, all following empty

Same result with "Step_1.odt" with empty frame: frame only shown in step 44 on page 1


@Caolán:
I am a little sceptical concerning the red herring hypothesis. When I type a simple x into the document outside the frame in a step 33a, the mail merge process will have the expected result with an x and frame with contents on all odd page numbers, but Copy with <control+a> ->  <control+a> -> switch to other document ->  <control+v> still will only paste the "x", but not the frame. To heal the copy paste problem the "x" plus an additional <Enter> will be required.
So the copy/paste problem might be a different issue, but of course, I am not sure.

Please feel free to reassign (or reset Assignee to default) if it’s not your area or if provided information is not sufficient. Please set Status to ASSIGNED if you accept this Bug.
Comment 18 Björn Michaelsen 2011-12-23 13:23:00 UTC
Since all new unconfirmed bugs start in state UNCONFIRMED now and old unconfirmed bugs were moved to NEEDINFO with a explanatory comment, all bugs promoted above those bug states to NEW and later are automatically confirmed making the CONFIRMED whiteboard status redundant. Thus it will be removed.
Comment 19 mark 2012-12-16 23:48:47 UTC
I can confirm this bug in

LibreOffice 3.5.4.2 
Build ID: 350m1(Build:2)

Reproducable by using mail merge wizard. The document Only contains the Address Block and a text box (for the return address). Creating the merged document results in the first sheet is as expected and all the following sheets have the correct Address Block but the text box is gone. Putting a space char on the document i.e. next to the text box the merge is produced as expected.

Let me know if more info is needed.

mark
Comment 20 QA Administrators 2014-10-23 17:31:42 UTC
Please read this message in its entirety before responding.

Your bug was confirmed at least 1 year ago and has not had any activity on it for over a year. Your bug is still set to NEW which means that it is open and confirmed. It would be nice to have the bug confirmed on a newer version than the version reported in the original report to know that the bug is still present -- sometimes a bug is inadvertently fixed over time and just never closed.

If you have time please do the following:
1) Test to see if the bug is still present on a currently supported version of LibreOffice (preferably 4.2 or newer).
2) If it is present please leave a comment telling us what version of LibreOffice and your operating system.
3) If it is NOT present please set the bug to RESOLVED-WORKSFORME and leave a short comment telling us your version and Operating System

Please DO NOT
1) Update the version field
2) Reply via email (please reply directly on the bug tracker)
3) Set the bug to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)

+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + 
LibreOffice is powered by a team of volunteers, every bug is confirmed (triaged) by human beings who mostly give their time for free. We invite you to join our triaging by checking out this link:
https://wiki.documentfoundation.org/QA/BugTriage

There are also other ways to get involved including with marketing, UX, documentation, and of course developing -  http://www.libreoffice.org/get-help/mailing-lists/. 

Lastly, good bug reports help tremendously in making the process go smoother, please always provide reproducible steps (even if it seems easy) and attach any and all relevant material
Comment 21 m.inno 2014-12-06 10:16:38 UTC
It may be incredible, but the bug is still there.
I had that problem last week printing a mail merge odt document with textframes linked to a odb file.
I had used libreoffice 4.3.4 on windows. In that occasion, I have been forced to print all my 90 pages one by one (one for each data row).
Then, I tried with libreoffice 1:4.3.3-2 on debian sid with same results.
I was considering to try with scribus with scribus generator script. Then, I found that bug.
Adding some spaces to the document will do the trick as described by jacksjy in the far 2010.

Michele
Comment 22 Joel Madero 2014-12-15 01:06:38 UTC
I am removing Caolan as the assigned developer. Rainer assigned the bug to him but it was never accepted and I see no evidence that he is interested in fixing this.

That being said - this project is powered by volunteers so if a volunteer wants to fix it - they can do so of course, and we can try to find them a mentor to find out what's going on. Without a volunteer - it's unlikely the bug will be fixed unless a enterprise user decides to pay a company to fix it.

Thanks all for your input, patience, and understanding in this matter.
Comment 23 Alex Thurgood 2015-01-03 17:40:46 UTC
Adding self to CC if not already on
Comment 24 Jan-Marek Glogowski 2015-03-25 16:57:54 UTC
Version: 4.5.0.0.alpha0+
Build ID: 3dad00879295c04d03f8a5eaeff6794d36ea6d07
Platform: Linux

I downloaded and MM'ed the Step_2.odt.

Works for me.

Guess it was fixed in the 4.4 mail merge rework, but didn't try.