Download it now!
Bug 30762 - Opening a document in a language not supported by LanguageTool Extension maximizes CPU load
Summary: Opening a document in a language not supported by LanguageTool Extension maxi...
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Linguistic (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-10 23:52 UTC by luctur
Modified: 2011-12-28 04:08 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description luctur 2010-10-10 23:52:55 UTC
Here my system:

Windows Vista Home Edition SP3
CPU AMD 64 X2 5000+
Graphic Card: Nvidia 9400GT
LibO vers: LibreOffice 3.3.0 OOO330m7 English version (Build:9526)

How to reproduce the bug/feature:

a) open a large Writer document (more than 150+ pages or 500.000 characters) written in a language whose linguistic tools are not installed in LibO;

b) the English grammar checker automatically starts underlining text;

What it is expected:

- LibO understands that the document is written in a language whose linguistic tools are not installed and disables the English grammar checker.

What it is the current behavior:

- the Grammar checker checks the foreign language up to text end maximizing one or more CPU core. If the text is long enough, it takes 5 or more minutes to finish the task and LibO becomes completely unresponsive in the meanwhile. An average user can reasonably think that the application has frozen and may try to kill the process (with data loss?)
Comment 1 luctur 2010-10-11 00:06:13 UTC
Here is my system:

Windows Vista Home Edition SP3
CPU AMD 64 X2 5000+
Graphic Card: Nvidia 9400GT
LibO vers: LibreOffice 3.3.0 OOO330m7 (Build:9526
Extensions installed: Italian linguistic tools  (spell checkers, thes, ...)

How to reproduce the (minor) bug/feature:

a) open a large Writer document (more than 150+ pages or 500.000 characters);

b) do same text changes in the middle of the document, save and close the documents;

c) open your document again;

What it is expected (OOo 3.2.x do so):

- the document is opened and the last page where the caret was before saving is displayed. The input caret is flashing where it was positioned when the document was saved.

What it's the current behavior:

- last page where the caret was is displayed but the input caret is missing and its last position lost. The user must click into the document to start typing.
Comment 2 Noel Power 2010-10-26 04:23:36 UTC
are you reporting 2 bugs here? If so, please open separate bugs for each individual issue,
Also iirc correctly the grammer checker ( 'LanguageTool' ) is actually a packaged extension so it maybe that the problem is with the LanguageTool extension itself ( and worth opening a bug against them ) note we only *package* the language tool
Comment 3 Don't use this account, use tml@iki.fi 2010-11-19 05:56:29 UTC
luctur, please respond to Noel's questions.
Comment 4 Stefano Fraccaro 2010-12-06 01:07:42 UTC
I have the same problem with RC1... when open a 14 pages document with Writer the program is unresponsive for ~10 seconds (while grammar checker is working).
After red and blu lines appear, all works fine
Comment 5 Stefano Fraccaro 2010-12-06 01:33:28 UTC
I have uploaded a sample video to my personal site:
http://www.stefanofraccaro.org/test1.avi

Object1 seems to be a html frame. Document was pasted from this url:
http://www.ilfattoquotidiano.it/2010/11/25/la-casta-non-rinuncia-al-vitalizio/78785/
Comment 6 Stefano Fraccaro 2010-12-06 01:48:50 UTC
Errata corrige:

all works fine... grammar checker is very slow to respond the first time (see video). Sometime pages scroll down automatically when grammar window seems freezed.
Comment 7 Rainer Bielefeld Retired 2010-12-18 11:17:34 UTC
(In reply to comment #6)
 
> all works fine... grammar checker is very slow 

Hi,

that means we only have a general performance problem?
Comment 8 Daniel Naber 2011-09-02 14:16:03 UTC
LanguageTool's bug report is here: http://sourceforge.net/tracker/?func=detail&atid=655717&aid=3153545&group_id=110216

Basically, LO seems to hang 6 seconds where it calls getLocales() more than 200 times. However, LanguageTool answer that call in less than 1ms. If we don't iterate to return all the locales we support but only one, the hang is still 3.5 seconds instead of 7 seconds. So the problem seems to be in the way LO uses/calls the extension.

I have no idea how to further debug this from outside LO, so any ideas are welcome.
Comment 9 Björn Michaelsen 2011-12-23 11:34:00 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 10 Björn Michaelsen 2011-12-23 17:00:56 UTC
needinfo keyword redundant by needinfo status.
Comment 11 Rainer Bielefeld Retired 2011-12-26 00:31:51 UTC
Currently I see this one as a LanguageTool problem, so this problem should be reported at <http://www.languagetool.org/> with a link to this report. LanguageTool developer will contact LibO and reopen this bug if additionally LibO bug fixing will be required.
Comment 12 Daniel Naber 2011-12-28 04:08:29 UTC
There are indeed several problems mixed up in one bug report. The freeze on the first grammar check is known (see comment 8) but probably not a LanguageTool problem. The original bug report seems to talk about a document whose language was not properly set (LanguageTool doesn't run English rules on non-English documents).