Download it now!
Bug 30769 - problem with python on Ubuntu
Summary: problem with python on Ubuntu
Status: CLOSED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 30643 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-10-11 07:20 UTC by Laurent Godard
Modified: 2011-01-13 06:30 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
does this make a difference ? (687 bytes, patch)
2010-10-11 08:02 UTC, Caolán McNamara
Details
excerpt of critical section, missing the _socket library. (10.07 KB, text/plain)
2010-10-11 08:05 UTC, Michael Meeks
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Laurent Godard 2010-10-11 07:20:25 UTC
#
######################################################
#
Registering python UNO components:
#
######################################################
#
SUCCESS: Source for types.rdb: /home/lgodard/projets/libreoffice/build/build/libreoffice-3.2.99.2/solver/330/unxlngi6.pro/bin/types.rdb
#
SUCCESS: Source for pyuno_services.rdb: /home/lgodard/projets/libreoffice/build/build/libreoffice-3.2.99.2/solver/330/unxlngi6.pro/bin/pyuno_services.rdb
#
Systemcall:  /home/lgodard/projets/libreoffice/build/build/libreoffice-3.2.99.2/solver/330/unxlngi6.pro/bin/regcomp -register -br /home/lgodard/projets/libreoffice/build/build/libreoffice-3.2.99.2/solver/330/unxlngi6.pro/bin/types.rdb -br /home/lgodard/projets/libreoffice/build/build/libreoffice-3.2.99.2/solver/330/unxlngi6.pro/bin/pyuno_services.rdb -r /tmp/ooopackaging/i_70371286781422/unxlngi6.pro/LibreOffice//gid_Starregistry_Services_Rdb_servicesrdb/fr_inprogress_1/services.rdb -c vnd.openoffice.pymodule:pythonscript -l com.sun.star.loader.Python 2>&1 |
#
vnd.openoffice.pymodule:pythonscript
#
register component 'vnd.openoffice.pymodule:pythonscript' in registry '/tmp/ooopackaging/i_70371286781422/unxlngi6.pro/LibreOffice//gid_Starregistry_Services_Rdb_servicesrdb/fr_inprogress_1/services.rdb' failed!
#
error (RuntimeException): python object raised an unknown exception ('No module named _socket', traceback follows
#
<traceback object at 0x41321554>
#
ERROR:  /home/lgodard/projets/libreoffice/build/build/libreoffice-3.2.99.2/solver/330/unxlngi6.pro/bin/regcomp -register -br /home/lgodard/projets/libreoffice/build/build/libreoffice-3.2.99.2/solver/330/unxlngi6.pro/bin/types.rdb -br /home/lgodard/projets/libreoffice/build/build/libreoffice-3.2.99.2/solver/330/unxlngi6.pro/bin/pyuno_services.rdb -r /tmp/ooopackaging/i_70371286781422/unxlngi6.pro/LibreOffice//gid_Starregistry_Services_Rdb_servicesrdb/fr_inprogress_1/services.rdb -c vnd.openoffice.pymodule:pythonscript -l com.sun.star.loader.Python 2>&1 |
#
Systemcall:  /home/lgodard/projets/libreoffice/build/build/libreoffice-3.2.99.2/solver/330/unxlngi6.pro/bin/regcomp -register -br /home/lgodard/projets/libreoffice/build/build/libreoffice-3.2.99.2/solver/330/unxlngi6.pro/bin/types.rdb -br /home/lgodard/projets/libreoffice/build/build/libreoffice-3.2.99.2/solver/330/unxlngi6.pro/bin/pyuno_services.rdb -r /tmp/ooopackaging/i_70371286781422/unxlngi6.pro/LibreOffice//gid_Starregistry_Services_Rdb_servicesrdb/fr_inprogress_1/services.rdb -c vnd.openoffice.pymodule:mailmerge -l com.sun.star.loader.Python 2>&1 |
#
vnd.openoffice.pymodule:mailmerge
#
register component 'vnd.openoffice.pymodule:mailmerge' in registry '/tmp/ooopackaging/i_70371286781422/unxlngi6.pro/LibreOffice//gid_Starregistry_Services_Rdb_servicesrdb/fr_inprogress_1/services.rdb' failed!
#
error (RuntimeException): python object raised an unknown exception ('No module named _socket', traceback follows
#
<traceback object at 0x41321554>
#
ERROR:  /home/lgodard/projets/libreoffice/build/build/libreoffice-3.2.99.2/solver/330/unxlngi6.pro/bin/regcomp -register -br /home/lgodard/projets/libreoffice/build/build/libreoffice-3.2.99.2/solver/330/unxlngi6.pro/bin/types.rdb -br /home/lgodard/projets/libreoffice/build/build/libreoffice-3.2.99.2/solver/330/unxlngi6.pro/bin/pyuno_services.rdb -r /tmp/ooopackaging/i_70371286781422/unxlngi6.pro/LibreOffice//gid_Starregistry_Services_Rdb_servicesrdb/fr_inprogress_1/services.rdb -c vnd.openoffice.pymodule:mailmerge -l com.sun.star.loader.Python 2>&1 |
#
 
#
Moved directory from /tmp/ooopackaging/i_70371286781422/unxlngi6.pro/LibreOffice//gid_Starregistry_Services_Rdb_servicesrdb/fr_inprogress_1 to /tmp/ooopackaging/i_70371286781422/unxlngi6.pro/LibreOffice//gid_Starregistry_Services_Rdb_servicesrdb/fr_witherror_1
#
 
#
Removing directory /tmp/ooopackaging/i_70371286781422
#
 
#
***************************************************************
#
ERROR: Could not register all components for file services.rdb (gid_Starregistry_Services_Rdb)!
#
in function: create_services_rdb
#
***************************************************************


as requested by mmeeks, attached
strace -f -s 256 -o /tmp/ilog bin/ooinstall -l /path/to/install
Comment 1 Laurent Godard 2010-10-11 07:36:44 UTC
the file is too large

available here
http://oooconv.free.fr/tests/ilog.zip
Comment 2 Caolán McNamara 2010-10-11 07:54:25 UTC
in ooinstall what's this for ?

# Workaround for the Python
$configure_vars{'PYTHONPATH'} = "$setup_vars{'OOBUILDDIR'}/instsetoo_native/$configure_vars{'INPATH'}/bin:$configure_vars{'SOLARVERSION'}/$configure_vars{'INPATH'}/lib";

Maybe we should be adding solver/330/unxlngx6.pro/lib/python/lib-dynload to this path as well to get it to find _socket.so in there, maybe something like...

$configure_vars{'PYTHONPATH'} = "$setup_vars{'OOBUILDDIR'}/instsetoo_native/$configure_vars{'INPATH'}/bin:$configure_vars{'SOLARVERSION'}/$configure_vars{'INPATH'}/lib:$configure_vars{'INPATH'}/lib/python/lib-dynload";

you get the picture anyway, even if that's a junk line in practice.
Comment 3 Caolán McNamara 2010-10-11 08:02:16 UTC
Created attachment 39342 [details]
does this make a difference ?
Comment 4 Michael Meeks 2010-10-11 08:05:13 UTC
Created attachment 39343 [details]
excerpt of critical section, missing the _socket library.
Comment 5 Michael Meeks 2010-10-11 08:12:44 UTC
Laurent - it would be great to have the result of:

find -name '_socket*'

from your build directory [ or best inside build/libreoffice*/solver ] would be good:
Comment 6 Laurent Godard 2010-10-11 08:19:12 UTC
as requested in build directory

 find -name '_socket*'


./build/libreoffice-3.2.99.2/solver/330/unxlngi6.pro/lib/python/lib-dynload/_socket.so
./build/libreoffice-3.2.99.2/boost/unxlngi6.pro/misc/build/boost_1_39_0/doc/html/boost_asio/reference/socket_base/_socket_base.html
./build/libreoffice-3.2.99.2/pyuno/unxlngi6.pro/bin/python-core-2.6.1/lib/lib-dynload/_socket.so
./build/libreoffice-3.2.99.2/python/unxlngi6.pro/misc/build/python-inst/lib/python2.6/lib-dynload/_socket.so
./build/libreoffice-3.2.99.2/python/unxlngi6.pro/misc/build/Python-2.6.1/PCbuild/_socket.vcproj
./build/libreoffice-3.2.99.2/python/unxlngi6.pro/misc/build/Python-2.6.1/build/lib.linux-i686-2.6/_socket.so
./build/libreoffice-3.2.99.2/python/unxlngi6.pro/misc/build/Python-2.6.1/PC/VC6/_socket.dsp
./build/libreoffice-3.2.99.2/python/unxlngi6.pro/misc/build/Python-2.6.1/PC/VS7.1/_socket.vcproj
./build/libreoffice-3.2.99.2/python/unxlngi6.pro/misc/build/Python-2.6.1/PC/VS8.0/_socket.vcproj
Comment 7 Caolán McNamara 2010-10-11 08:39:36 UTC
So, I committed+pushed in my suggested fix, and I'll *assume* that it fixes this. Give it a go, and if its still busted reopen this bug and we'll have another go
Comment 8 Laurent Godard 2010-10-12 03:29:29 UTC
fixed for me too
thx guys
Comment 9 Caolán McNamara 2010-10-21 04:22:32 UTC
*** Bug 30643 has been marked as a duplicate of this bug. ***
Comment 10 sophie 2011-01-13 06:30:12 UTC
Closing - Sophie