Download it now!
Bug 30820 - Writer: sorting table cells does not move row formatting
Summary: Writer: sorting table cells does not move row formatting
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-13 00:47 UTC by martin f. krafft
Modified: 2011-06-20 23:09 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Please see Comment 3! (14.34 KB, application/x-compressed)
2010-12-19 01:23 UTC, Rainer Bielefeld Retired
Details

Note You need to log in before you can comment on or make changes to this bug.
Description martin f. krafft 2010-10-13 00:47:24 UTC
[This bug is with OpenOffice.org 3.2.1, but I am reporting it here since that seems more sensible]

Given a table with highlit rows in Writer, if I now sort the table, the highlighting stays fixed on the rows and does not move with the contents.

For example, let * denote a row that is highlit:

   |3|blue |
  *|1|red  |*
   |2|green|

Now sort it by column 1 and you get:

   |1|red  |
  *|2|green|*
   |3|blue |

I think the formatting should move along.
Comment 1 Noel Power 2010-10-26 05:44:19 UTC
can you reference the bug ( in openoffice ) here, probably there is useful info, examples and such there that would be useful
Comment 2 martin f. krafft 2010-10-26 07:26:56 UTC
There is no bug report for openoffice. I was unsure where to put it, given the current state of OOo.
Comment 3 Rainer Bielefeld Retired 2010-12-19 01:20:53 UTC
In my test kit your find "sample0.odt" and "sample0.ods", and you will find cell background behaviour inconsistent for sort.

Steps to reproduce with "sample0.odt" 
0. unzip test kit, open smaple document
1. 2 times <cntl>+<a> to select all table
2. Menu 'Table -> Sort -> Column 1 - descending'
   to sort contents in opposite order
  Expected: text contents an all character and Cell properties will have 
            new order (column 1 "3 ... 1")
  Actual: Contents and properties EXCEPT cell background color 
          will have new order.

Now redo from 1. with "sample0.ods"
Here the cell background will follow text contents to new position.

Bug or feature? If complete rows will be sorted newly I cant imagine any advantage of the current behaviour.

Because it seems inherited from OOo version to most early available one. 

Same as <http://www.openoffice.org/issues/show_bug.cgi?id=32533>?

Currently I don't see necessity for any additional information
Comment 4 Rainer Bielefeld Retired 2010-12-19 01:23:04 UTC
Created attachment 41246 [details]
Please see Comment 3!
Comment 5 Rainer Bielefeld Retired 2010-12-19 01:26:04 UTC
BTW, also if you sort columns the background will stay in it's old column.
Comment 6 ubhh11 2011-06-18 07:30:29 UTC
This is not a bug. The formatting should not move along. An example table that is formatted with autoformat 'yellow'(in German 'gelb') should not re-formatted.